Author Topic: QT4 still needed?  (Read 1268 times)

Blues

  • Jr. Member
  • **
  • Posts: 52
QT4 still needed?
« on: November 05, 2016, 05:22:25 AM »
Code: [Select]
~ $ avidemux3_qt4
avidemux3_qt4: error while loading shared libraries: libQtGui.so.4: cannot open shared object file: No such file or directory
It builds fine but does not run.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1538
Re: QT4 still needed?
« Reply #1 on: November 05, 2016, 08:55:22 AM »
Short answer: Yes. Did ldd on libADM_UIQT*.so suggest otherwise?

Blues

  • Jr. Member
  • **
  • Posts: 52
Re: QT4 still needed?
« Reply #2 on: November 05, 2016, 02:50:17 PM »
Oh well, reinstalling QT4 ... I just cleaned up my box, thinking Avidemux won't need QT4 any more.

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10950
Re: QT4 still needed?
« Reply #3 on: November 05, 2016, 03:01:25 PM »
Qt4 or Qt5

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1538
Re: QT4 still needed?
« Reply #4 on: November 05, 2016, 09:33:08 PM »
I just cleaned up my box, thinking Avidemux won't need QT4 any more.

avidemux3_qt5 doesn't need Qt4 ;)

What is the purpose of building Avidemux with Qt4?

Blues

  • Jr. Member
  • **
  • Posts: 52
Re: QT4 still needed?
« Reply #5 on: November 06, 2016, 02:53:56 AM »
OK, I misunderstood something? I build it with bash bootStrap.bash, I was under impression it defaults to QT5?

Never mind, I was executing the wrong binary.  :o
« Last Edit: November 06, 2016, 03:02:27 AM by Blues »