Author Topic: No sound during preview (macOS Sierra)  (Read 1017 times)

PBear.SF

  • Newbie
  • *
  • Posts: 4
No sound during preview (macOS Sierra)
« on: May 19, 2017, 12:34:19 AM »
I've read thru the manual and looked at the entire FAQ index - can't find any explanation for why there is no sound during preview.  In fact, in the View menu, under Toolbars, the Volume item is unchecked by default.  If I do check it, I get a greyed-out volume slider placed at the bottom of the main interface.

Any explanation for why I cannot hear any sound when I am previewing input files prior to encoding on Avidemux 2.6 on macOS Sierra?

Thanks.

--
PBear.SF


mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10946
Re: No sound during preview (macOS Sierra)
« Reply #1 on: May 19, 2017, 05:05:25 AM »
Make sure the audio device is coreAudio

PBear.SF

  • Newbie
  • *
  • Posts: 4
Re: No sound during preview (macOS Sierra)
« Reply #2 on: May 19, 2017, 02:26:35 PM »
Make sure the audio device is coreAudio

That did it, thanks.  For some reason, audio defaulted to "Dummy" when Avidemux was installed.  Maybe that's because, on my Mac Mini, even though audio is working in preview window now, the volume slider does nothing at all.  That could be alarming (especially to my neighbours) if my input file should happen to have blaringly loud audio and I'm not able to immediately turn it down -- so, maybe the powers that be, in their wisdom, decided that preview window should default to no-audio on systems that cannot control the preview volume.  :)

Thanks again.

--
PBear.SF
« Last Edit: May 19, 2017, 02:28:46 PM by PBear.SF »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1381
Re: No sound during preview (macOS Sierra)
« Reply #3 on: May 19, 2017, 09:03:25 PM »
Maybe that's because, on my Mac Mini, even though audio is working in preview window now, the volume slider does nothing at all.

No, this is not related. Some sound output drivers support setting volume, some not, like e.g. PulseAudioSimple on Linux and, of course, the dummy output. I wasn't aware of the limitations of the coreAudio output until yesterday, will disable the useless volume widget for this output as well.

We should try harder to avoid the dummy output, I guess. It is a steady source of avoidable support requests.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1381
Re: No sound during preview (macOS Sierra)
« Reply #4 on: May 20, 2017, 12:06:30 AM »
Actually, I got the volume control in Avidemux on macOS working. All credit belongs to http://kaniini.dereferenced.org/2014/08/31/CoreAudio-sucks.html :)

PBear.SF

  • Newbie
  • *
  • Posts: 4
Re: No sound during preview (macOS Sierra)
« Reply #5 on: May 20, 2017, 12:30:28 AM »
Actually, I got the volume control in Avidemux on macOS working. All credit belongs to http://kaniini.dereferenced.org/2014/08/31/CoreAudio-sucks.html :)

That's good news... if you're the author or a contributor to the project -- in which case, I look forward to the next version.

Regards,

--
PBear.SF

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1381
Re: No sound during preview (macOS Sierra)
« Reply #6 on: May 20, 2017, 05:54:05 PM »
I look forward to the next version.

Just grab the latest nightly from http://www.avidemux.org/nightly/osx_sierra/.

PBear.SF

  • Newbie
  • *
  • Posts: 4
Re: No sound during preview (macOS Sierra)
« Reply #7 on: May 20, 2017, 06:29:35 PM »
Just grab the latest nightly from http://www.avidemux.org/nightly/osx_sierra/.

I'm not very adventurous and usually opt for stable updates only but what the hey!  I can try the latest nightly build and, if it seems squirrelly, I can always revert to the last official 2.6 release.

Thanks for the heads up.

--
PBear.SF