Author Topic: audio damaged for AAC codec  (Read 245 times)

mohammad_avr

  • Newbie
  • *
  • Posts: 9
audio damaged for AAC codec
« on: November 13, 2017, 02:02:49 PM »
Hi
i have video clip mp4(h264) with aac codec audio whin i open it by avidemux video is ok but audio is damaged
it seams played in half frame rate !!
in VLC player everything is good
could you please check it?
i have attached sample video file o dropbox with this link:
https://www.dropbox.com/s/4xpif5g8ows77kc/1-08-17-12.mp4?dl=0
Thanks

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5674
Re: audio damaged for AAC codec
« Reply #1 on: November 13, 2017, 04:11:25 PM »
according mediainfo this would be:
Code: [Select]
Audio
ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : HE-AACv2 / HE-AAC / LC
Codec ID                                 : 40
Duration                                 : 48s 504ms
Bit rate mode                            : Variable
Bit rate                                 : 28.9 Kbps
Maximum bit rate                         : 128 Kbps
Channel(s)                               : 2 channels / 1 channel / 1 channel
Channel positions                        : Front: L R / Front: C / Front: C
Sampling rate                            : 48.0 KHz / 48.0 KHz / 24.0 KHz
Frame rate                               : 23.438 fps (1024 spf)
Compression mode                         : Lossy
Stream size                              : 171 KiB (2%)
Language                                 : Persian
Default                                  : Yes
Alternate group                          : 1
Encoded date                             : UTC 1904-01-01 00:00:00
Tagged date                              : UTC 1904-01-01 00:00:00

VLC reports mp4a with AAC extension SBR+PS

Very odd, seems mixed audio (channels or streams) with different properties.

Don't know what the developers make of this?
« Last Edit: November 13, 2017, 04:27:49 PM by Jan Gruuthuse »

mohammad_avr

  • Newbie
  • *
  • Posts: 9
Re: audio damaged for AAC codec
« Reply #2 on: November 13, 2017, 04:22:58 PM »
Mediainfo on vlc different on avidemux
On vlc frame rate is 25 f/s and on avidemux is  50f/s
Audio is 48000 and on avidemux is shown 24000

mohammad_avr

  • Newbie
  • *
  • Posts: 9
Re: audio damaged for AAC codec
« Reply #3 on: November 14, 2017, 06:42:21 AM »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1544
Re: audio damaged for AAC codec
« Reply #4 on: November 14, 2017, 08:01:14 PM »
Audio in both samples plays fine for me in Avidemux. I wonder if the audio track is mislabled in the container, Avidemux seems to get it right.

mohammad_avr

  • Newbie
  • *
  • Posts: 9
Re: audio damaged for AAC codec
« Reply #5 on: November 15, 2017, 07:58:38 AM »
i checked with some version of avidemux but audio was not correct
different information on vlc and avidemux !!!

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1544
Re: audio damaged for AAC codec
« Reply #6 on: November 15, 2017, 10:01:51 PM »
What do you mean by "some version"? It should be the latest git master.

The info differs, but it is likely that Avidemux gets it right (at least it plays the audio in the provided samples fine according to my testing).

mohammad_avr

  • Newbie
  • *
  • Posts: 9
Re: audio damaged for AAC codec
« Reply #7 on: November 16, 2017, 08:39:12 AM »
i have used latest version but same result .
i have tested by 3 pcs separately.
avidemux version is 2.7.0  and    2.7.0_r171114_win64