You don't understand? :
Developer prerogative, whatever we think or request.
That doesn't make it any less silly to have PageUp/PageDown and UpArrow/DownArrow go in the exact opposite directions of eachother!
Look, while I prefer that down = seek forward, the fact that Avidemux uses "DownArrow = seek backwards" isn't the main issue here, is that Avidemux currently does this:DownArrow
= previous i-framePageDown
Nobody in their right could say that makes sense; either make them both be 'previous' or make them both be 'next' - don't split the difference and make things inconsistent and therefore confusing!