Author Topic: No start file!  (Read 1518 times)

cliffhanger

  • Newbie
  • *
  • Posts: 3
No start file!
« on: September 27, 2016, 11:57:38 AM »
Hi

Just compiled Avidemux(twice) for the first time under Linux using the bootStrap.bash script.  Once without GTK support and with GTK.  I'm getting no start file i.e. avidemux_gtk anywhere!   I have the desktop file pointing to it but not the file.

What's going on?   Or have I missed something?

thanks

Cliff

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1462
Re: No start file!
« Reply #1 on: September 27, 2016, 01:29:07 PM »
The GTK Avidemux GUI is long dead, use the Qt (Qt5) one. Write the desktop file yourself and put it e.g. in ~/.local/share/applications, e.g.:

Code: [Select]
[Desktop Entry]
Name=Avidemux Video Editor (Qt5)
Comment=Graphical video editing tool - Qt5 interface
Icon=totem
Exec=/path/to/avidemux/wrapper/script
MimeType=video/mpeg;video/quicktime;video/x-msvideo;video/x-anim;audio/x-mp3;audio/x-mp2;
Terminal=false
Type=Application
Categories=AudioVideo;AudioVideoEditing;
X-Desktop-File-Install-Version=0.23
StartupWMClass=avidemux3_qt5

(adjust the path to match your system). I strongly recommend to use a wrapper around avidemux3_qt5 similar to

Code: [Select]
#!/bin/bash

exec /usr/local/bin/avidemux3_qt5 > /dev/null 2>&1;

exit 0

to prevent it from flooding user's journal with status messages. In case you need these messages for deeper understanding of Avidemux' processes, you can launch avidemux3_qt5 in a terminal.

Using Totem icon instead of low-res Avidemux one is just my personal preference ;-)
« Last Edit: September 27, 2016, 01:34:06 PM by eumagga0x2a »

cliffhanger

  • Newbie
  • *
  • Posts: 3
Re: No start file!
« Reply #2 on: September 27, 2016, 01:49:04 PM »
Many thanks for the advice. 

So can I take it that the bootStrap.bash script is the way to go?  There is reference to cmake from the beginning on the site.

I assume the startup script should be in /usr/bin if I install?

Cliff


eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1462
Re: No start file!
« Reply #3 on: September 27, 2016, 02:31:15 PM »
Use rather /usr/local/bin or a local bin directory instead. Don't mess with system provided binaries.

I recommend to change CMAKE_INSTALL_PREFIX in bootStrap.bash to /usr/local unless you can't add /usr/local/lib and/or /usr/local/lib64 to your shared library loader path in /etc/ld.so.conf.d/something.conf.

Using --rebuild option speeds up repeated builds very much because it doesn't discard existing build directories.

If your CPU has more than 4 cores, I'd recommend also the attached patch to speed up the build of the bundled ffmpeg.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1462
Re: No start file!
« Reply #4 on: September 27, 2016, 02:44:41 PM »
Maybe I should add that I see very little use in packaging provided by CPack component of CMake because such packages lack dependency information and e.g. with RPMs files get wrongly classified as configuration. Just defining /usr/local as prefix and copying the corresponding subfolder of the "install" folder over the existing /usr/local does the trick.

cliffhanger

  • Newbie
  • *
  • Posts: 3
Re: No start file!
« Reply #5 on: September 27, 2016, 04:36:10 PM »
Right the build fails around 90% with:

[ 90%] Generating avidemux_fr.qm
cd /mnt/home/cliffy/Downloads/avidemux_2.6.14/buildQt5/i18n && /usr/bin/cmake -E echo Generating /mnt/home/cliffy/Downloads/avidemux_2.6.14/buildQt5/i18n/avidemux_fr.qm from /mnt/home/cliffy/Downloads/avidemux_2.6.14/avidemux/qt4/i18n/avidemux_fr.ts
Generating /mnt/home/cliffy/Downloads/avidemux_2.6.14/buildQt5/i18n/avidemux_fr.qm from /mnt/home/cliffy/Downloads/avidemux_2.6.14/avidemux/qt4/i18n/avidemux_fr.ts
cd /mnt/home/cliffy/Downloads/avidemux_2.6.14/buildQt5/i18n && /usr/bin/lrelease /mnt/home/cliffy/Downloads/avidemux_2.6.14/avidemux/qt4/i18n/avidemux_fr.ts -qm /mnt/home/cliffy/Downloads/avidemux_2.6.14/buildQt5/i18n/avidemux_fr.qm
lrelease: could not find a Qt installation of '5'
i18n/CMakeFiles/qmfiles.dir/build.make:110: recipe for target 'i18n/avidemux_fr.qm' failed
make[2]: *** [i18n/avidemux_fr.qm] Error 1
make[2]: Leaving directory '/mnt/home/cliffy/Downloads/avidemux_2.6.14/buildQt5'
CMakeFiles/Makefile2:1599: recipe for target 'i18n/CMakeFiles/qmfiles.dir/all' failed
make[1]: *** [i18n/CMakeFiles/qmfiles.dir/all] Error 2
make[1]: Leaving directory '/mnt/home/cliffy/Downloads/avidemux_2.6.14/buildQt5'
Makefile:130: recipe for target 'all' failed
make: *** [all] Error 2

I have both qt4 and qt5 on the system and this is the problem.  Tried exporting PATHS inc: export QT_SELECT=5 but with no luck.  I'm running on Qt4, but looks like i need to remove all PATHS to it.

Cliff

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10946
Re: No start file!
« Reply #6 on: September 27, 2016, 04:42:01 PM »
you need qt5 dev tool installed : qttools5-dev-tools

If you are running ubuntu/fedora, just run the createDebFromSourceUbuntu.bash createRpmFromSourceFedora.bash
It will install all basic dependencies and create the deb/rpm for you