Author Topic: Avidemux geht mit AVI plötzlich nicht mehr  (Read 1401 times)

muxer-raven

  • Newbie
  • *
  • Posts: 24
Avidemux geht mit AVI plötzlich nicht mehr
« on: November 20, 2016, 12:41:05 PM »
es funzt nicht mehr: erst mit 2.6.8. dann mit 2.6.14 probiert, aber die video fraktion wird nicht richtig gerendert. Fertige Filme haben dann nicht mal die Hälfte des ursprünglichen Umfangs, Video ist in ca der ersten Hälfte des Films nicht vorhanden.

Bisher hatte es bestens funktioniert. abspielen mit VLC 2.2.1 oder DVBViewer 5.6.1, läuft nicht. nur der Sound kommt, Video erst vllt nach der Hälfte des Films. Wenn man dann in der timeline (im VLC) zurückgeht, bleibt nur ein Standbild der vorherigen Scene.

wenn mans zB mit mkv rendert, wird das zwar halbwegs was, aber das Bildformat ist 4:3 (nicht 16 : 9) - man muss also immer erst nach-justieren, und auch das vorspulen auf späteren Zeitpunkt funktioniert nicht, wenn man zu weit geht (dh die timeline-anzeige ist völlig unkorrekt!)

Sonstige Einstellungen wurden nicht verändert, das tritt quasi über nacht auf: was ist da los???
hoffe es kann wer helfen, vielen Dank im voraus
Kevin


die Einstellungen, soweit sichtbar:
Lavcodec RGB
Video-Codec: Copy
Audio-Codec: Copy
Ausgabeformat: AVI
Betriebssystem: Win 7 SP 1 64 Bit

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5337
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #1 on: November 20, 2016, 01:00:31 PM »
Avidemux menu: Edit: Preferences: Output:
Code: [Select]
[v] Create OpenDML files
If that fails, delete the .idx2 files, video should re-index upon loading.

muxer-raven

  • Newbie
  • *
  • Posts: 24
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #2 on: November 20, 2016, 01:46:46 PM »
das entfernen dieser .idx2 files hilft leider nichts!
und leider hilft auch dieses OpenDML nicht weiter!

Wenn man beim rendern zuschaut, sieht man, daß video erst sehr spät anfängt MB's zu sammeln, wärend Audio schon von anfang an loslegt.

(in dem ganzen Film gibt es nur 3 Schnitte, einer ganz am Anfang, einer in der Mitte, und einer am Ende, ab dem Schnitt in der Mitte kommt erst das Bild....)

und mit einer anderen Filmdatei geht es ebenso wenig: das Render-Fenster ist nach 1 -2 Sekunden (sic!) wieder geschlossen, die Datei, die ursprünglich ca 2 GB groß war, ist dann nur noch 33 KB (sic!) groß!!!


 Bitte helft, das nervt ja nur noch!
lG

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1165
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #3 on: November 20, 2016, 03:05:45 PM »
Bitte erst mal die Konfiguration von Avidemux zurücksetzen (zum Beispiel den Ordner in %AppData% umbenennen), die Anwendung komplett deinstallieren und die aktuelle Version 2.6.15 installieren. Wenn das Problem trotzdem bleibt, die Textausgabe von MediaInfo zum ursprünglichen Video und zu dem von Avidemux gespeicherten Video posten.

AVI für h264 oder h265 NICHT verwenden.

muxer-raven

  • Newbie
  • *
  • Posts: 24
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #4 on: November 20, 2016, 04:55:21 PM »
hallo, und wo genau finde ich die Konfiguration von Avidemux??
ich hab das hier gefunden, aber dann wirds mehrdeutig:
C:\benutzer > [Benutzername] > Anwendungsdaten / oder Appdata > local/locallow/Roaming > dort gibt auch wieder einige, welche???

könntest Du bitte den genauen Pfad für Win 7 64 bit posten?
und wo finde ich die 'Textausgabe von MediaInfo zum ursprünglichen Video'?
vielen Dank
« Last Edit: November 20, 2016, 05:29:29 PM by muxer-raven »

muxer-raven

  • Newbie
  • *
  • Posts: 24
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #5 on: November 21, 2016, 10:56:28 AM »
BIN grad am verzweiffeln: die Konfig (soweit ich das richtig gemacht habe!?) gelöscht, Avi 2.6.15 neuinstalliert, und der gleiche Zickenzinnober nimmt kein Ende!!!
Bitte helft - ich weiss nicht mehr weiter!!!!
Wo finde ich diese 'Textausgabe von MediaInfo' und die Videoinformationen vom Avidemux-Video ??
Selber suchen ist leider zu uferlos!

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5337
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #6 on: November 21, 2016, 01:50:37 PM »
with loaded video, click the blue icon (i) top left corner of avidemux window.

Install mediainfo: https://mediaarea.net/de/MediaInfo.
Load video and select text info. Copy paste info into notepad. save and attach to your posting.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1165
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #7 on: November 21, 2016, 05:17:06 PM »
hallo, und wo genau finde ich die Konfiguration von Avidemux??
ich hab das hier gefunden, aber dann wirds mehrdeutig:
C:\benutzer > [Benutzername] > Anwendungsdaten / oder Appdata > local/locallow/Roaming > dort gibt auch wieder einige, welche???

Es wird nicht mehrdeutig. Im "Hilfe"-Menü von Avidemux sollte es eine Option geben, sich das Logfile anzusehen. Damit wird der Ordner, der die Konfiguration und das Log (admlog.txt) enthält, im Dateimanager geöffnet. Der Standardpfad lautet

%AppData%\Roaming\avidemux

(ins "Ausführen"-Dialog oder in die Windows-Explorer-Adresszeile eingeben). Die Umgebungsvariable %AppData% zeigt meistens auf C:\Users\<Benutzername>\AppData. Lokalisierte Windows-Versionen erstellen einen Link im Benutzerverzeichnis, der in der deutschen Windows-Version "Anwendungsdaten" heißt, der wirkliche Zielordner heißt immer "AppData".

Es ist wichtig, die Reste der früheren Avidemux-Installationen vollständig zu entfernen.

Wenn das nicht hilft, bitte neben den Textinfos von MediaInfo auch admlog.txt vom Encodieren eines der betroffenen Videos zippen und anhängen.

muxer-raven

  • Newbie
  • *
  • Posts: 24
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #8 on: November 21, 2016, 08:58:09 PM »
eine file in %AppData%\Roaming\etc hatte ich vor neu-installation gelöscht.

wie es aussieht funktionieren andere videos ganz propper, zumindest oberflächlich betrachtet.
Kann es sein, daß ausgerechnet diese Datei verhunzt worden ist? Dann müsste man mal schauen, ob das noch mal/öfters auftritt. Fehler läge dann sozusagen am DVBViewer (mit dem aufgenommen wurde)?/!

ok, hier die beiden logs:

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1165
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #9 on: November 21, 2016, 11:07:52 PM »
Unter Resten meinte ich auch Überbleibsel im Programmordner, aber wenn andere Videos problemlos verarbeitet werden, liegt es wohl am Video.

Quote
Kann es sein, daß ausgerechnet diese Datei verhunzt worden ist?

Das ist durchaus möglich, in diesem Fall wäre ein Testvideo für Entwickler unerlässlich. Übrigens, bei DVB-T/C/S-Mittschnitten niemals mpg (program stream) oder mp4 sondern immer ts (transport stream) im DVBViewer als Container wählen.

Quote
Code: [Select]
[addReferenceVideo] 20:44:39-189 The first frame has a PTS >0, adjusting to 2000 ms

Etwas ungewöhnlich ist nur ein sehr spätes erstes I-Frame (ganze 2 Sekunden vom Anfang des Videos), was DVBViewer anzulasten ist. Die Indexdatei für das Video war bereits vorhanden:

Quote
Code: [Select]
[PS Demuxer] There is an index for that file

Von Interesse wäre das Avidemux-Log vom Encoding-Vorgang und die MediaInfo-Ausgabe für das erzeugte Video. Das Ausgangsvideo ist interlaced, also den Yadif-Deinterlacer beim Kodieren hinzuschalten. Wenn das Audio im mp2-Format bleiben soll, wäre MKV die beste wenn nicht gar die einzige Option.

muxer-raven

  • Newbie
  • *
  • Posts: 24
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #10 on: November 23, 2016, 05:40:14 PM »
Quote
Überbleibsel im Programmordner
hatte ich soweit ersichtlich alle entfernt (kann nat. was übersehen haben, Maulwurfsgrüsse)

Quote
bei DVB-T/C/S-Mittschnitten niemals mpg (program stream) oder mp4 sondern immer ts (transport stream) im DVBViewer als Container
könnteste das (für nen Laien) noch ein wenig erklären?

und wo finde ich denn dieses "Avidemux-Log vom Encoding-Vorgang" ?
MediaInfo-Ausgabe folgt dann auf den Fuss....
Und sorry, aber wie den "Yadif-Deinterlacer beim Kodieren" zuschalten?

Quote
Wenn das Audio im mp2-Format bleiben soll, wäre MKV die beste wenn nicht gar die einzige Option.
wo stell ich das nu wieder ein??
Hatte den Eindruck, bei den ganzen Einstellungen für Video- Audio-codec, und Ausgabe-Formaten scheint fast nur dieses AVI zu funzen...

Muss gestehen, daß bisher immer nur das rausschneiden von Werbung aus den Streifen relevant war, alles andere blieb links liegen, nun müsste ma fast schon nen crash-course einlegen...


eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1165
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #11 on: November 23, 2016, 11:00:15 PM »
Quote from: eumagga0x2a
bei DVB-T/C/S-Mittschnitten niemals mpg (program stream) oder mp4 sondern immer ts (transport stream) im DVBViewer als Container
könnteste das (für nen Laien) noch ein wenig erklären?

AVI, MP4, MPG, TS, MKV, MOV – das alles sind Verpackungen (Container) für die eigentlichen Video- und Audio-Daten sowie zusätzliche Informationen wie z.B. Kapitel oder Untertitel. Nur der TS (transport stream) entspricht den besonderen Anforderungen von DVB wie zum Beispiel die Fortsetzung der Wiedergabe nach einem Drop-out oder ein fliegender Formatwechsel. DVB sendet TS, und das aufnehmende Programm soll die Daten am besten in diesem Format belassen.

Quote
und wo finde ich denn dieses "Avidemux-Log vom Encoding-Vorgang" ?

Avidemux öffnen, das Video laden, Codec und Container-Typ (Format) auswählen, das Video neu encodieren, über das "Hilfe"-Menü ans Logfile kommen, es zippen und hier anhängen.

Quote
Und sorry, aber wie den "Yadif-Deinterlacer beim Kodieren" zuschalten?

Wenn ein Video-Codec und nicht "Copy" ausgewählt ist, wird der Button "Filter" aktiv. Dort unter "Interlacing beseitigen" ganz unten befindet sich der Yadif-Filter. Deinterlacing ist erforderlich, wenn das ursprüngliche Video interlaced ist (im ersten Halbbild werden alle ungeraden, im zweiten alle geraden Zeilen übertragen oder umgekehrt) und das Video nicht einfach geschnitten sondern neu encodiert werden soll.

Quote
Quote
Wenn das Audio im mp2-Format bleiben soll, wäre MKV die beste wenn nicht gar die einzige Option.
wo stell ich das nu wieder ein??

"Ausgabeformat" --> "Mkv Muxer"

Quote
Hatte den Eindruck, bei den ganzen Einstellungen für Video- Audio-codec, und Ausgabe-Formaten scheint fast nur dieses AVI zu funzen...

AVI bitte gut vergessen. Steckt schon im Namen des Programms, und das reicht.

Quote
nun müsste ma fast schon nen crash-course einlegen...

Das wäre sehr anzuraten, ganz davon zu schweigen, dass sämtliche verwendete Begriffe google- oder bingbar sind  ;)

muxer-raven

  • Newbie
  • *
  • Posts: 24
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #12 on: November 26, 2016, 10:50:24 AM »
hi, ich versuchte gerade, das "Avidemux-Log vom Encoding-Vorgang" zu posten, muss dabei leider feststellen, daß ich ein spezifisches Aufnahme-log nicht finde!

Ich hab im Hilfemenue nur Build-Option/Plugins/Advanced/About unter advanced dann noch open Application Log oder open Appl. Data Folder...
Ich vermute jetzt mal ganz prompt, daß es ersteres ist? (siehe Attachment)

So, und wenn ich mir das Ergebnis des letzten Filmschnitts anschaue, stell ich als erstes fest, daß das Bildformat im VLC (2.2.1) nicht mehr stimmt (ist jetzt 4 : 3, wo frühers das Format automatisch war, muss man jetzt händisch umstellen, damits geniessbar wird)
Und dann fängt das Filmchen mitten drin an, also definitiv nicht am Anfang. (ich hatte nen 2-Teiler, die gleich unmittelbar nacheinander kamen bequehmlichkeitshalber in einem Stück aufgenommen)

Das mit den Containern ahnte ich schon etwa, nur habe ich bisher immer MP4 gekapselt. Hab das jetzt mal auf TS umgestellt.
Ach ja: den letzten Versuch, die letzte Datei (Antique-Nero) habe ich jetzt in MKV gekapselt.

Ich habs jetzt grade ebend nicht ausprobiert, aber wenn ich bisher unter Video-Codec was anderes als Copy aussuchte, kam meistens die Meldung, daß es nicht geht. Hab das daher jetzt mal nicht so genau unter Beschuss genommen.

hier schon vorab mal vielen Dank an alle Helfer!!

MIST! ich sehe gerade, daß der Server das file so einfach nicht annimmt, wie zipp ich das am besten? mach sowas sonst so gut wie niee!

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5337
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #13 on: November 26, 2016, 12:06:54 PM »
MIST! ich sehe gerade, daß der Server das file so einfach nicht annimmt, wie zipp ich das am besten? mach sowas sonst so gut wie niee!
7zip: http://www.7-zip.org/

muxer-raven

  • Newbie
  • *
  • Posts: 24
Re: Avidemux geht mit AVI plötzlich nicht mehr
« Reply #14 on: November 26, 2016, 01:52:32 PM »
Ok, hoffe das ist das richtige! sonst bitte nochmal auf die letzte Aw antworten...