Author Topic: AviDemux can't disable Power savings  (Read 744 times)

rolandpisano

  • Newbie
  • *
  • Posts: 15
AviDemux can't disable Power savings
« on: June 18, 2016, 05:54:16 PM »
Hello,
One point I've noticed : when Avidemux is encoding, any kind of encoding (x264, xvid, etc.), Power Savings happens. I've tried many settings, results are the same. Avidemux does not handle power savings. My computer goes to sleep even with a full listing of files to encode !
I'm on Windows 10 64 bits.
Is there a way to let the computer awake during encoding ? A setting ?
Regards,


rolandpisano

  • Newbie
  • *
  • Posts: 15
Re: AviDemux can't disable Power savings
« Reply #2 on: June 21, 2016, 06:57:55 AM »
Ok, I know that.
I used VirtualDub a long time, on Windows XP, Windows 8.1, Windows 10 with the same kind of settings of Power Savings. It never went on sleep while encoding.
Now, I use AviDemux. When encoding, CPU is between 20% and 70%, depending encoding parameters. It should be enough to keep alive the computer. But the PC goes to sleep while encoding.
I really think that Avidemux lacks a function to keep alive the PC while encoding, I don't think my settings are wrong.
I you want, I can retry an experience with VirtualDub to be sure.
Regards,

AQUAR

  • Hero Member
  • *****
  • Posts: 959
Re: AviDemux can't disable Power savings
« Reply #3 on: June 21, 2016, 09:09:46 AM »
Why not create a power saving plan where the PC never goes to sleep.
Use that plan when encoding with ADM.

Personally I have only one plan - never sleep.
But of course I use a desktop PC and a program to turn of the monitor.
Power saving functions are not all that useful on mains powered computers.

rolandpisano

  • Newbie
  • *
  • Posts: 15
Re: AviDemux can't disable Power savings
« Reply #4 on: June 21, 2016, 07:09:47 PM »
Thank you but this is not what I need.
I simply dont want that the pc goes to sleep after avidemux has encoded all the videos.
So, is there a settings somewhere in avidemux that says : stay awake while encoding ?
Regards,

AQUAR

  • Hero Member
  • *****
  • Posts: 959
Re: AviDemux can't disable Power savings
« Reply #5 on: June 23, 2016, 01:48:15 PM »
Seems you're reply is contradictory to your initial requirement.
I think you do want the pc to go to sleep after ADM has encoded all videos, but not whilst its encoding.

You might try setting the priority of ADM to encode in "real time" and see if that will keep the PC alive.

 

rolandpisano

  • Newbie
  • *
  • Posts: 15
Re: AviDemux can't disable Power savings
« Reply #6 on: June 26, 2016, 04:42:55 PM »
Sorry if I am not as clear as I would.
I want that my PC is not going to sleep while AviDemux is encoding.
Today, my PC is using my Power Savings parameters (that is : go to sleep after 45 mn of inactivity), even when AviDemux is encoding.
I have already tried "real time" parameters in AviDemux without success.
Thank you for your reply.

AQUAR

  • Hero Member
  • *****
  • Posts: 959
Re: AviDemux can't disable Power savings
« Reply #7 on: June 27, 2016, 12:50:39 PM »
I meant "real time" execution of the running avidemux process.
This can only be done once you have started avidemux.
Procedure is:
Find the avidemux process in the task manager (processes tab) and set its priority to "real time".
Whilst there maybe also try out a lower cpu core affinity.

These are just suggestions to try as I can't verify if this has any merit.

Otherwise just use a software solution to simulate mouse or keyboard activity.
Google on "Caffeine" or "Mouse Jiggler" for windows.
« Last Edit: June 27, 2016, 01:29:16 PM by AQUAR »

EFG5

  • Newbie
  • *
  • Posts: 1
Re: AviDemux can't disable Power savings
« Reply #8 on: January 12, 2017, 07:12:47 PM »
See this thread -- "Windows 7: How do I prevent going to sleep with processes active?" at http://www.sevenforums.com/performance-maintenance/185644-how-do-i-prevent-going-sleep-processes-active.html