Author Topic: vp9 encoding to x264, ....  (Read 465 times)

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5428
vp9 encoding to x264, ....
« on: February 28, 2017, 12:16:56 PM »
fixed: commit 664021d   Merge pull request #139 from eumagga0x2a/vpx-decoder-vp9
Jut tested vp9 source to x264 encoding  :'(. See attached screenshot
download sample mkv (vp9 - opus)
File (6.15 MB total) Vp9toX264test.zip
Will be deleted on 7 March, 2017
Download link https://we.tl/pERvD56DBU

sample: Vp9-Opus-Sample.mkv
result: x264-mp3-conversion.mkv

warning: turn volume down
« Last Edit: April 03, 2017, 05:27:15 AM by Jan Gruuthuse »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1244
Re: vp9 encoding to x264, ....
« Reply #1 on: March 02, 2017, 09:08:02 PM »
All I-frames are OK, other display only garbage: the VP9 decoding is broken. This is at least not a regression from 2.6.16 I've briefly tested with a VP9 video from YouTube.

Encoding with x264 is unrelated.
« Last Edit: March 02, 2017, 09:11:45 PM by eumagga0x2a »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1244
Re: vp9 encoding to x264, ....
« Reply #2 on: April 02, 2017, 07:48:02 PM »
This problem was reported as early as in January 2016: VP9 is Scrambled. I wonder if it was really (working) for a while and then got broken again. The issue still persists.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5428
Re: vp9 encoding to x264, ....
« Reply #3 on: April 03, 2017, 05:24:48 AM »
Seems to be working now with above sample:
Quote
Merge pull request #139 from eumagga0x2a/vpx-decoder-vp9
at 1st looks, player is fine, encoding seems fine to.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5428
Re: vp9 encoding to x264, ....
« Reply #4 on: April 03, 2017, 06:38:40 AM »
Done a larger test (350 MB) webm vp9 to H264.
Took 6 minutes with Nvidia H264.
Don't forget to check quality of video! Out of the box going from 25.5 Mbps vp9  to 8.241 Mbps h264 is a big image quality drop. Visual pixelation, visual squares, ....