Author Topic: Ganzes Video wird nicht decoded  (Read 397 times)

UltraNic

  • Newbie
  • *
  • Posts: 4
Ganzes Video wird nicht decoded
« on: March 21, 2017, 05:38:27 PM »
Hallo Leute.
Hab mir erst vor kurzem Avidemux geholt weil meine fraps aufnahmen teilweise über 200gb groß sind und ich die dateien einfach etwas kleiner haben wollte...
Funktioniert mit Avidemux eigentlich auch echt super! Keine Qualitätseinbußungen oder sonstiges. Nun habe ich nur ein bzw. zwei Probleme:

Wenn ich als Ausgabeformat den MP4 Muxer auswähle, dann kommt nach einer Zeit eine Fehlermeldung: "Too short. The Video has been saved but seems to be incomplete"
In einem Forum habe ich gelesen dass MP4v2 das Problem beheben könnte. Also habe ich den ausgewählt, jedoch wird mein Video (das ca. eine Stunde lang ist) schon nach 12 Minuten abgespeichert. Wie kann ich das ändern?
Mfg

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1020
Re: Ganzes Video wird nicht decoded
« Reply #1 on: March 21, 2017, 06:12:33 PM »
Hab mir erst vor kurzem Avidemux geholt weil meine fraps aufnahmen teilweise über 200gb groß sind und ich die dateien einfach etwas kleiner haben wollte...
Funktioniert mit Avidemux eigentlich auch echt super! Keine Qualitätseinbußungen oder sonstiges.

Keine Qualitätseinbußen gibt es einzig und allein beim Speichern im Copy-Modus. Wird denn im Copy-Modus geschnitten oder rekodiert? Wenn letzteres, mit welchem Codec?

Quote
Wenn ich als Ausgabeformat den MP4 Muxer auswähle, dann kommt nach einer Zeit eine Fehlermeldung: "Too short. The Video has been saved but seems to be incomplete"

Diese Fehlermeldung sagt leider nichts über das wirkliche Problem. Bitte das Avidemux-Log (unter Windows ist das die Datei admlog.txt in %appdata%\avidemux, erreichbar über das Menü "Hilfe" im Avidemux) ggf. komprimieren und anhängen.

Quote
In einem Forum habe ich gelesen dass MP4v2 das Problem beheben könnte. Also habe ich den ausgewählt, jedoch wird mein Video (das ca. eine Stunde lang ist) schon nach 12 Minuten abgespeichert. Wie kann ich das ändern?

Für Copy-Modus sind 12 Minuten sehr lang, für Rekodierung ziemlich kurz, aber ohne Infos über die Länge, Auflösung des Quell- und Zielvideos sowie über den Encoder und die Bitrate sind keine Aussagen möglich.

UltraNic

  • Newbie
  • *
  • Posts: 4
Re: Ganzes Video wird nicht decoded
« Reply #2 on: March 21, 2017, 06:52:17 PM »
Hallo und danke erstmal für die schnelle Antwort.
Falls es hilft, ich habe meine Einstellungen aus diesem Video übernommen: https://www.youtube.com/watch?v=CSMKzrYXEo0
Tut mir leid bezüglich der mangelnden Informationen aber da ich noch sehr neu auf dem Gebiet der Videoaufnahme bin dachte ich mir schon dass bald jemand spezielle Informationen anfordern wird die ich ihm natürlich zuteil werden lasse.


Dass man Videos ohne Qualitätsverlust nicht rekodieren kann ist mir klar, jedoch sind die Unterschiede so extrem gering dass sie einem nicht auffallen, weshalb ich mich auch für den avidemux entschieden habe. Und ja hierbei soll NICHT im copy modus geschnitten werden, sondern das Video soll rekodiert werden. Welcher codec lässt sich auf eins der screenshots herausfinden (hoffe natürlich dass das der richtige ist).

Die Logs habe ich als .txt datei in den Anhang abgelegt. Hoffe das ist in Ordnung. Ich danke dir natürlich für deine Zeit und Mühe, falls irgendwas fehlt würde ich es gerne nachreichen um eine reibungslose Fehlersuche zu garantieren

« Last Edit: March 21, 2017, 07:05:23 PM by UltraNic »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1020
Re: Ganzes Video wird nicht decoded
« Reply #3 on: March 21, 2017, 08:24:33 PM »
Danke. In der Tat, das Dekodieren schlägt bei 12 Minuten 3,7 Sekunden vom Anfang des Videos fehl. Vermag Avidemux die Stelle überhaupt abzuspielen? Der Encoder (hier: x264) und Container (MP4) spielen keine Rolle.

UltraNic

  • Newbie
  • *
  • Posts: 4
Re: Ganzes Video wird nicht decoded
« Reply #4 on: March 21, 2017, 10:38:55 PM »
Ich habe die Lösung für das Problem gefunden, naja ich habe nicht die "Lösung" gefunden aber eine Alternative. Und zwar habe ich Avidemux (Version 2.5.6) benutzt (Downloaden kann man das hier: https://sourceforge.net/projects/avidemux/files/avidemux/2.5.6/)
Die Unterschiede sind kaum bemerkbar, das eine ist natürlich etwas verpixelter, jedoch ist das eine 200gb groß und das andere 1,66gb groß ;)
Gibt es vielleicht eine Möglichkeit das Video noch weiter zu verschärfen? Würde mich nicht stören wenn die Datei auch 10GB groß ist

http://i.imgur.com/C35EFdi.jpg (1,66gb)

http://i.imgur.com/jMrMLOm.jpg (200gb)
« Last Edit: March 21, 2017, 11:10:05 PM by UltraNic »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1020
Re: Ganzes Video wird nicht decoded
« Reply #5 on: March 22, 2017, 10:32:25 AM »
Es wäre nett, auf die gestellte Frage zu antworten  ;)

Dass Avidemux 2.5.x das Quellvideo dekodieren kann, ist gut zu wissen, hilft aber niemandem, solange man das Problem nicht in der aktuellen Version des Programms beheben kann (Avidemux 2.5.x ist schon lange tot). Bitte teste mit dem letzten Nightly Build, ob er die problematische Stelle überwinden kann.

edit: Ich kenne 2.5.x nicht. Für bessere Details sollte zumindest die Bitrate in den Einstellungen des Encoders erhöht werden.
« Last Edit: March 22, 2017, 10:41:11 AM by eumagga0x2a »