Author Topic: My Feature Requests v2  (Read 1695 times)

jan771

  • Newbie
  • *
  • Posts: 28
Re: My Feature Requests v2
« Reply #15 on: April 04, 2017, 10:03:29 PM »
ok, I updated my comment and added Features requested :-)

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5374
Re: My Feature Requests v2
« Reply #16 on: April 05, 2017, 05:12:58 AM »
Without an original recording from the box there is nothing much developers can do.
I suspect there are reception errors in your recorded stream, transmission breaks, interference, fluctuating signal, .... . Try improving your reception, if possible at all. Like with an outdoor terrestrial antenna TechniYagi T2 HD (very directional antenna).
If there are holes in the reception stream, there is nothing much avidemux can do to replace the missing content.

jan771

  • Newbie
  • *
  • Posts: 28
Re: My Feature Requests v2
« Reply #17 on: April 05, 2017, 09:04:03 AM »
My AviDemux can't even open the transcoded mkv I attached.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: My Feature Requests v2
« Reply #18 on: April 05, 2017, 09:49:06 AM »
Please no transcoded, remuxed etc. files. Please cut the first ~300 MiB in binary way* from the original transport stream and upload this sample.

*) Well, AQUAR could help with a Windows equivalent for

Code: [Select]
dd if=/path/to/source/video of=/path/to/sample/video bs=1M count=300
I tested DVB-T2 HD capabilities of Avidemux with TS samples recorded in usual way using a USB DVB-T/T2/C card and the dvbv5-zap utility, then dumping the data stream from the /dev/dvb/adapter0/dvr0 device.

jan771

  • Newbie
  • *
  • Posts: 28
Re: My Feature Requests v2
« Reply #19 on: April 05, 2017, 09:53:38 AM »
AviDemux should be capable opening mkv HEVC files, IMAO.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: My Feature Requests v2
« Reply #20 on: April 05, 2017, 09:58:31 AM »
It is capable of opening and saving MKV with HEVC video.

edit: Avidemux built from the current git master has no issues opening, playing and cutting Comag_SL30T2-SampleAsMatroshka.mkv you've provided.
« Last Edit: April 05, 2017, 10:04:08 AM by eumagga0x2a »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: My Feature Requests v2
« Reply #21 on: April 05, 2017, 10:08:09 AM »
Please post admlog.txt from Avidemux run while trying to load your sample. I'd could think of issues with hwaccel and HEVC, please test with hw accelerated decoding and display in Avidemux turned off vs. turned on.

jan771

  • Newbie
  • *
  • Posts: 28
Re: My Feature Requests v2
« Reply #22 on: April 06, 2017, 11:16:04 AM »
ok, I added two recordings in .mpg Container as done by Comag SL65T2, one with ok Quality and one with bad Signal Quality maybe with a cut-off.
https://cloud.gmx.net/ngcloud/external?guestToken=djXXsvFRRsaWTpYg-9jgbQ&loginName=@334663428440331676#/
Also to be found the zipped 28MB admlog.txt file from opening the ok quality file.
hope I could do you a favour.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5374
Re: My Feature Requests v2
« Reply #23 on: April 06, 2017, 11:26:16 AM »
Please provide original. .TS recording. Timed recording for max 1 minute. Not a repackaged video in another container.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: My Feature Requests v2
« Reply #24 on: April 06, 2017, 11:38:12 AM »
Please retest as requested with DXVA completely disabled. It looks for me like .mpg were just a wrong ending for an actual .TS file here ("Augenwischerei" in other words).

Apart from issues with audio (misdetected audio sampling rate in the "good" sample etc.) Avidemux on Linux loads and plays both samples fine.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: My Feature Requests v2
« Reply #25 on: April 06, 2017, 12:13:51 PM »
Retested on Windows 7 with a release build (my own, not Mean's) and no issues loading and playing your samples apart from mangled audio despite DXVA active (no issues with audio with my own samples).

jan771

  • Newbie
  • *
  • Posts: 28
Re: My Feature Requests v2
« Reply #26 on: April 06, 2017, 12:52:34 PM »
OK, indeed, with DVXA2 disabled it works, thank you! Is it due to my CPU generation?

How about my Feature requests No. 8-11?

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: My Feature Requests v2
« Reply #27 on: April 06, 2017, 01:05:46 PM »
It may be due to graphics card drivers.

Feature requests: quality patches warmly welcome.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: My Feature Requests v2
« Reply #28 on: April 06, 2017, 01:29:28 PM »
Probably 5 and 10 could be tackled middle-term in one or another way.

jan771

  • Newbie
  • *
  • Posts: 28
Re: My Feature Requests v2
« Reply #29 on: April 06, 2017, 02:40:14 PM »
ok, added 13 and 14 then