Author Topic: x64, apr. 1: missing aften.exe at startup  (Read 619 times)

me444

  • Full Member
  • ***
  • Posts: 108
x64, apr. 1: missing aften.exe at startup
« on: April 02, 2017, 11:15:51 AM »
avidemux_r170401_win64Qt5_378:
Error box saying that the program cannot be started as aften.exe is missing.
After that, ADM starts, however.

me444

  • Full Member
  • ***
  • Posts: 108
Re: x64, apr. 1: missing aften.exe at startup
« Reply #1 on: April 03, 2017, 06:25:33 PM »
Cause of the problem appears to be:  the logfile mentions that within
<my-program-directory>\plugins\audioEncoders   \libADM_ae_aften.dll cannot be loaded:

Code: [Select]
[ADM_ae_plugin] Scanning directory D:\xyz\avidemux\Release_r170401_win64Qt5\plugins\\audioEncoders
Symbol loading failed for D:\xyz\avidemux\Release_r170401_win64Qt5\plugins\\audioEncoders\libADM_ae_aften.dll
D:\xyz\avidemux\Release_r170401_win64Qt5\plugins\\audioEncoders\libADM_ae_aften.dll:CannotLoad

In fact this DLL does exist within the directory mentioned.
Why this problem?

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10910
Re: x64, apr. 1: missing aften.exe at startup
« Reply #2 on: April 03, 2017, 07:34:52 PM »
The aften dll is there too ?

me444

  • Full Member
  • ***
  • Posts: 108
Re: x64, apr. 1: missing aften.exe at startup
« Reply #3 on: April 03, 2017, 07:51:38 PM »
Hello mean,
of course not ... where is it expected to come from
since apr 1 ?

me444

  • Full Member
  • ***
  • Posts: 108
Re: x64, apr. 1: missing aften.exe at startup
« Reply #4 on: April 06, 2017, 07:40:16 AM »
What can i do?
Currently i cannot use newer nightlies because at each start i have the error box popping up.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: x64, apr. 1: missing aften.exe at startup
« Reply #5 on: April 06, 2017, 08:05:56 AM »
If you have also Linux installed, you could relatively easily build Avidemux for Windows yourself --> https://raw.githubusercontent.com/mean00/avidemux2/master/cross-compiling.txt

edit: Oops, I should have checked first. Currently, the build fails at linking the core with

Code: [Select]
CMakeFiles/ADM_coreImage6.dir/objects.a(ADM_imageUtils.cpp.obj):ADM_imageUtils.cpp:(.text+0x9be): undefined reference to `adm2_emms_yasm'
« Last Edit: April 06, 2017, 08:24:52 AM by eumagga0x2a »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: x64, apr. 1: missing aften.exe at startup
« Reply #6 on: April 06, 2017, 08:50:18 AM »
The first commit that doesn't cross-compile is [build/asm] continue converting to yasm.


me444

  • Full Member
  • ***
  • Posts: 108
Re: x64, apr. 1: missing aften.exe at startup
« Reply #8 on: April 11, 2017, 04:41:27 PM »
Hello eumagga0x2a,
but with nightly x64 (7z-version) april 11th the problem still persists ..
?

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: x64, apr. 1: missing aften.exe at startup
« Reply #9 on: April 11, 2017, 05:14:06 PM »
"Fixed" was related to an issue (temporarily even two issues) which broke cross-compilation. Everyone interested can compile Avidemux for Windows using a Linux system again now. I don't get any "aften.exe missing" errors running my own Avidemux builds for windows because I don't have aften installed in my build environment in the first place. If there is a problem specific to the setup used to generate the official nightlies, only Mean could help.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5374
Re: x64, apr. 1: missing aften.exe at startup
« Reply #10 on: April 11, 2017, 05:27:52 PM »
7z is replace in place, while exe is installer, try exe instead.

Francois_C

  • Newbie
  • *
  • Posts: 6
Re: x64, apr. 1: missing aften.exe at startup
« Reply #11 on: April 12, 2017, 01:33:51 PM »
Hi.
The latest Windows 64 version (today, april, 12, both zip and installer versions) still claims for aften.exe. My dirty workaround was to copy aften.exe into the Avidemux folder. I used the true 64-bit one, but any Windows PE (32 or 64 bits) named aften.exe is accepted.
BTW, I noticed that the blue rectangle showing the part that will be cut does not always fit the cursor's position. The cutting point is several frames before the cursor position.
« Last Edit: April 12, 2017, 01:50:52 PM by Francois_C »

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10910
Re: x64, apr. 1: missing aften.exe at startup
« Reply #12 on: April 12, 2017, 02:45:56 PM »
Confirmed

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1211
Re: x64, apr. 1: missing aften.exe at startup
« Reply #13 on: April 12, 2017, 02:58:10 PM »
BTW, I noticed that the blue rectangle showing the part that will be cut does not always fit the cursor's position. The cutting point is several frames before the cursor position.

Or after, if the current position > 1/2 of the total video duration. This depends on the Qt theme in use.

me444

  • Full Member
  • ***
  • Posts: 108
Re: x64, apr. 1: missing aften.exe at startup
« Reply #14 on: April 12, 2017, 06:11:37 PM »
Back to the aften.exe problem, yes it's both for zip and installer; in both libADM_ae_aften.dll and libaften.dll are there at the appropriate places.
Should it be fixed or is it recommended to use the workaround?