Author Topic: Mint 18.3: Installation of some of the build dependencies failed. Aborting.  (Read 347 times)

zanhe

  • Newbie
  • *
  • Posts: 1
I read through this thread (link), and decided to install AviDemux through github, after GetDeb failed (picture link).

There are contents located in the directory: /home/ken/avidemux2, but even after restarting the computer, nothing came up in the menu panel -> all applications.

This is the full message of trying to install from GitHub

Code: [Select]
ken@KGA-880GMA-UD2H ~ $ cd ~/avidemux2
ken@KGA-880GMA-UD2H ~/avidemux2 $ bash createDebFromSourceUbuntu.bash
This will install all the packages necessary to build avidemux
You will be asked to enter your password because installing build dependencies requires root permissions
[sudo] password for ken:
Hit:1 http://archive.canonical.com/ubuntu xenial InRelease
Ign:2 http://packages.linuxmint.com sylvia InRelease                           
Hit:3 http://packages.linuxmint.com sylvia Release                             
Hit:5 http://security.ubuntu.com/ubuntu xenial-security InRelease             
Hit:6 http://archive.ubuntu.com/ubuntu xenial InRelease                 
Hit:8 http://archive.ubuntu.com/ubuntu xenial-updates InRelease               
Ign:7 http://screenshots.getdeb.net sylvia-getdeb InRelease                   
Hit:9 http://archive.ubuntu.com/ubuntu xenial-backports InRelease       
Ign:10 http://screenshots.getdeb.net sylvia-getdeb Release             
Ign:11 http://screenshots.getdeb.net sylvia-getdeb/apps amd64 Packages
Ign:12 http://screenshots.getdeb.net sylvia-getdeb/apps i386 Packages
Ign:13 http://screenshots.getdeb.net sylvia-getdeb/apps all Packages
Ign:14 http://screenshots.getdeb.net sylvia-getdeb/apps Translation-en_US
Ign:15 http://screenshots.getdeb.net sylvia-getdeb/apps Translation-en
Ign:11 http://screenshots.getdeb.net sylvia-getdeb/apps amd64 Packages
Ign:12 http://screenshots.getdeb.net sylvia-getdeb/apps i386 Packages
Ign:13 http://screenshots.getdeb.net sylvia-getdeb/apps all Packages
Ign:14 http://screenshots.getdeb.net sylvia-getdeb/apps Translation-en_US
Ign:15 http://screenshots.getdeb.net sylvia-getdeb/apps Translation-en
Ign:11 http://screenshots.getdeb.net sylvia-getdeb/apps amd64 Packages
Ign:12 http://screenshots.getdeb.net sylvia-getdeb/apps i386 Packages
Ign:13 http://screenshots.getdeb.net sylvia-getdeb/apps all Packages
Ign:14 http://screenshots.getdeb.net sylvia-getdeb/apps Translation-en_US
Ign:15 http://screenshots.getdeb.net sylvia-getdeb/apps Translation-en
Ign:11 http://screenshots.getdeb.net sylvia-getdeb/apps amd64 Packages
Ign:12 http://screenshots.getdeb.net sylvia-getdeb/apps i386 Packages
Ign:13 http://screenshots.getdeb.net sylvia-getdeb/apps all Packages
Ign:14 http://screenshots.getdeb.net sylvia-getdeb/apps Translation-en_US
Ign:15 http://screenshots.getdeb.net sylvia-getdeb/apps Translation-en
Ign:11 http://screenshots.getdeb.net sylvia-getdeb/apps amd64 Packages
Ign:12 http://screenshots.getdeb.net sylvia-getdeb/apps i386 Packages
Ign:13 http://screenshots.getdeb.net sylvia-getdeb/apps all Packages
Ign:14 http://screenshots.getdeb.net sylvia-getdeb/apps Translation-en_US
Ign:15 http://screenshots.getdeb.net sylvia-getdeb/apps Translation-en
Err:11 http://screenshots.getdeb.net sylvia-getdeb/apps amd64 Packages
  404  Not Found [IP: 104.28.25.125 80]
Reading package lists... Done
W: The repository 'http://archive.getdeb.net/ubuntu sylvia-getdeb Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: Failed to fetch http://screenshots.getdeb.net/dists/sylvia-getdeb/apps/binary-amd64/Packages  404  Not Found [IP: 104.28.25.125 80]
E: Failed to fetch http://screenshots.getdeb.net/dists/sylvia-getdeb/apps/binary-i386/Packages  404  Not Found [IP: 104.28.25.125 80]
E: Failed to fetch http://screenshots.getdeb.net/dists/sylvia-getdeb/apps/binary-all/Packages  404  Not Found [IP: 104.28.25.125 80]
E: Failed to fetch http://screenshots.getdeb.net/dists/sylvia-getdeb/apps/i18n/Translation-en_US  404  Not Found [IP: 104.28.25.125 80]
E: Failed to fetch http://screenshots.getdeb.net/dists/sylvia-getdeb/apps/i18n/Translation-en  404  Not Found [IP: 104.28.25.125 80]
E: Some index files failed to download. They have been ignored, or old ones used instead.
The installation at least of some of the build dependencies failed. Aborting.
ken@KGA-880GMA-UD2H ~/avidemux2 $

 

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2123
You have broken the package management by adding non-functional GetDeb repositories. Please fix this first, this is a general Linux system administration task, not related to Avidemux support.

You likely haven't built and installed Avidemux (the script failed in the dependency install phase), and even if you build it successfully, nothing would come up in the menu. Feel free to add a launcher for /usr/bin/avidemux3_qt5 yourself, it is not supplied by the application. Once built and installed, you should be able to launch Avidemux in the terminal though:

Code: [Select]
avidemux3_qt5