Author Topic: Missing audio on video captured from VLC sometimes  (Read 228 times)

CelticSlayer

  • Newbie
  • *
  • Posts: 3
Missing audio on video captured from VLC sometimes
« on: October 12, 2017, 06:05:05 AM »
Hey, sometimes when I load files recorded from VLC player Avidemux doesn't recognise audio. I can work on these files with audio in XMedia Recode, there seems to be a delay but the audio is still there in the editor. This only happens with a few of the recording clips. I've added a sample, thanks for your help.

https://1drv.ms/v/s!AnoJu6P6OB0thhp6tFC13Ey8bZjE

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10950
Re: Missing audio on video captured from VLC sometimes
« Reply #1 on: October 12, 2017, 06:22:31 AM »
confirmed
No PAT/PMT found

CelticSlayer

  • Newbie
  • *
  • Posts: 3
Re: Missing audio on video captured from VLC sometimes
« Reply #2 on: October 12, 2017, 07:04:36 AM »
Sorry, new here not sure what that means. I'd say about 6/10 times these recording clips from VLC work fine with a .ts extension and AVC/AAC video/audio. I think since I'm recording from a live internet stream sometimes the audio signature goes out of sync but the track is still there in the container so I'm unsure why Avidemux can't pick it up.

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10950
Re: Missing audio on video captured from VLC sometimes
« Reply #3 on: October 12, 2017, 08:30:56 AM »
The PAT (= content of the file) is not present very often
I'll add a deeper probe, so that you get the audio

BTW, The file is incorrect from a DVB point of view, but valid as a TS file
Since avidemux is geared toward DVB content, it fails on such files

Anyway, tomorrow's nightly should be able to read the audio part
!dont forget to delete the .idx2 file!

CelticSlayer

  • Newbie
  • *
  • Posts: 3
Re: Missing audio on video captured from VLC sometimes
« Reply #4 on: October 12, 2017, 09:16:24 PM »
That worked! Wow thank you, amazing support.