Author Topic: Crash on playback with ShadowPlay video with two audio tracks, ExceptionFilter  (Read 273 times)

Mister_Oizo

  • Newbie
  • *
  • Posts: 6
ExceptionFilter

The application has encountered a fatal problem
The current editing has been saved and will be reloaded at next start

EXCEPTION_ACCESS_VIOLATION
ADM_AudiocoderLavcodec::decodeToFloatPlanar(float**, unsigned int*)  [libADM_ad_lav.dll]
ADM_setCrashHook  [libADM_core6.dll]
ADM_setCrashHook  [libADM_core6.dll]
ADM_setCrashHook  [libADM_core6.dll]
UnhandledExceptionFilter  [KERNELBASE.dll]
memset  [ntdll.dll]
_C_specific_handler  [ntdll.dll]
_chkstk  [ntdll.dll]
RtlRaiseException  [ntdll.dll]
KiUserExceptionDispatcher  [ntdll.dll]
ADM_AudiocoderLavcodec::decodeToFloatPlanar(float**, unsigned int*)  [libADM_ad_lav.dll]
ADM_AudiocoderLavcodec::run(unsigned char*, unsigned int, float*, unsigned int*)  [libADM_ad_lav.dll]
ADM_edAudioTrackFromVideo::getPCMPacket(float*, unsigned int, unsigned int*, unsigned long long*)  [avidemux.exe]
AUDMAudioFilter_Bridge::fillIncomingBuffer(AUD_Status*)  [avidemux.exe]
AUDMAudioFilter_Bridge::fill(unsigned int, float*, AUD_Status*)  [avidemux.exe]
GUIPlayback::audioPump(bool)  [avidemux.exe]
GUIPlayback::run()  [avidemux.exe]
GUI_PlayAvi()  [avidemux.exe]
HandleAction(Action)  [avidemux.exe]
MainWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)  [avidemux.exe]
QMetaObject::activate(QObject*, int, int, void**)  [Qt5Core.dll]
MainWindow::actionSignal(Action)  [avidemux.exe]
MainWindow::searchGoMenu(QAction*)  [avidemux.exe]
MainWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)  [avidemux.exe]
QMetaObject::activate(QObject*, int, int, void**)  [Qt5Core.dll]
QMenu::showTearOffMenu()  [Qt5Widgets.dll]
QMenu::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)  [Qt5Widgets.dll]
QMetaObject::activate(QObject*, int, int, void**)  [Qt5Core.dll]
QAction::activate(QAction::ActionEvent)  [Qt5Widgets.dll]
QAction::event(QEvent*)  [Qt5Widgets.dll]
QApplicationPrivate::notify_helper(QObject*, QEvent*)  [Qt5Widgets.dll]
QApplication::notify(QObject*, QEvent*)  [Qt5Widgets.dll]
QCoreApplication::notifyInternal2(QObject*, QEvent*)  [Qt5Core.dll]
QShortcutMap::dispatchEvent(QKeyEvent*)  [Qt5Gui.dll]
QShortcutMap::tryShortcut(QKeyEvent*)  [Qt5Gui.dll]
QWindowSystemInterface::handleShortcutEvent(QWindow*, unsigned long, int, QFlags<Qt::KeyboardModifier>, unsigned int, unsigned int, unsigned int, QString const&, bool, unsigned short)  [Qt5Gui.dll]
QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*)  [Qt5Gui.dll]
QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*)  [Qt5Gui.dll]
QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>)  [Qt5Gui.dll]
QEventDispatcherWin32Private::sendTimerEvent(int)  [Qt5Core.dll]
DispatchMessageW  [USER32.dll]
NotifyWinEvent  [USER32.dll]
QEventDispatcherWin32::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)  [Qt5Core.dll]
qt_plugin_instance  [qwindows.dll]
QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>)  [Qt5Core.dll]
QCoreApplication::exec()  [Qt5Core.dll]
UI_RunApp()  [avidemux.exe]
startAvidemux(int, char**)  [avidemux.exe]
SDL_main  [avidemux.exe]
ms2timedisplay(unsigned int)  [avidemux.exe]
unknown function  [avidemux.exe]
unknown function  [avidemux.exe]
BaseThreadInitThunk  [KERNEL32.DLL]
RtlUserThreadStart  [ntdll.dll]

Mister_Oizo

  • Newbie
  • *
  • Posts: 6
Also the other track does not play at all, even though only that or both tracks are enabled from the Audio -> Select Track menu.
« Last Edit: November 27, 2017, 08:55:51 PM by Mister_Oizo »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1535
Please provide a sample.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1535
We had a similar crash in Crash when muxing AAC.

Please use a service like WeTransfer to provide a sample.

Mister_Oizo

  • Newbie
  • *
  • Posts: 6

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1535
Thank you for the sample, my Avidemux build has some difficulties to handle the hight frame rate, but I can't reproduce the crash. Also both audio tracks can be played (Avidemux plays only the first active audio track).

What Avidemux version are you using? Have you tried with the latest win64 nightly?

It is also possible that the crash is Windows-only (I'm on Mac).

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5671
no crash on ubuntu, plays fine.
Just these past along (audio issue?)
Code: [Select]
Paint event
 [refresh] 11:48:11-856  [Vdpau]Rrefresh
 [HandleAction] 11:48:11-951  ************ PlayAvi **************
[VideoFilterBridge] Creating bridge from 0 s to 1000000 s
 [convertLinearTimeToSeg] 11:48:11-951  Frame time=0, taking first segment
 [seektoTime] 11:48:11-951  First frame of the new segment is a keyframe at 0ms
 [DecodePictureUpToIntra] 11:48:11-951   DecodeUpToInta 0 ref:0
[edCache] Flush
 [vdpGetProcAddressWrapper] 11:48:11-951  Calling vdpGetProcAddressWrapper for function 38
 [vdpGetProcAddressWrapper] 11:48:11-951  Wrapping DECODER_DESTROY decoderDestroy
 [vdpGetProcAddressWrapper] 11:48:11-951  Ok
 [vdpauGetFormat] 11:48:11-962  [vdpau]: GetFormat
 [vdpauGetFormat] 11:48:11-962  [vdpau]: Evaluating 109
 [parseHwAccel] 11:48:11-962  Trying h263_vaapi, hwPixFmt=53, wantedPixFmt 109, hwCodecId =5 : wantedCodecID=28
 [parseHwAccel] 11:48:11-962  Trying h264_cuvid, hwPixFmt=129, wantedPixFmt 109, hwCodecId =28 : wantedCodecID=28
 [parseHwAccel] 11:48:11-962  Trying h264_vaapi, hwPixFmt=53, wantedPixFmt 109, hwCodecId =28 : wantedCodecID=28
 [parseHwAccel] 11:48:11-962  Trying h264_vdpau, hwPixFmt=109, wantedPixFmt 109, hwCodecId =28 : wantedCodecID=28
 [vdpauGetFormat] 11:48:11-962  Found matching hw accelerator : h264_vdpau
 [vdpauGetFormat] 11:48:11-962  Successfully setup hw accel
 [canSupportThis] 11:48:11-962  This is supported by VDPAU
 [lookup] 11:48:11-962  Matching hw accel : vdpau
 [ADM_FFgetFormat] 11:48:11-962  Reusing existing setup
 [vdpGetProcAddressWrapper] 11:48:11-962  Calling vdpGetProcAddressWrapper for function 7
==> GetProcAddress called
 [vdpGetProcAddressWrapper] 11:48:11-962  Ok
 [vdpGetProcAddressWrapper] 11:48:11-962  Calling vdpGetProcAddressWrapper for function 36
==> GetProcAddress called
 [vdpGetProcAddressWrapper] 11:48:11-962  Ok
 [vdpGetProcAddressWrapper] 11:48:11-962  Calling vdpGetProcAddressWrapper for function 37
 [vdpGetProcAddressWrapper] 11:48:11-962  Wrapping DECODER_CREATE decoderCreate
 [vdpGetProcAddressWrapper] 11:48:11-962  Ok
 [vdpGetProcAddressWrapper] 11:48:11-962  Calling vdpGetProcAddressWrapper for function 40
 [vdpGetProcAddressWrapper] 11:48:11-962  Wrapping DECODER_RENDER decoderRender
 [vdpGetProcAddressWrapper] 11:48:11-962  Ok
 [goToTimeVideo] 11:48:11-976  Seek done, in reference, gone to 0 with segment start at 0
 [renderDisplayResize] 11:48:11-977  Render to 1920x1080 zoom=1.0000, old one =1920 x 1080, zoom=1.0000, renderer=0x30665d0
 [renderDisplayResize] 11:48:11-977            No change, nothing to do
 [goToTime] 11:48:11-977   go to time 0.00 secs
 [convertLinearTimeToSeg] 11:48:11-977  Frame time=0, taking first segment
 [goToTime] 11:48:11-977  => seg 0, rel time 0.00 secs
 [resetAfterSeek] 11:48:11-977  Resetting faad
 [initFaad] 11:48:11-977  [FAAD] using 2 bytes of extradata
11 90
 [initFaad] 11:48:11-977  [FAAD] Found :48000 rate 2 channels
[MP4] Go to time succeeded chunk :0 time ask:0 time get:0
 [rewind] 11:48:11-977  [AudioBridge] Going to time 00:00:00,000
 [goToTime] 11:48:11-977   go to time 0.00 secs
 [convertLinearTimeToSeg] 11:48:11-977  Frame time=0, taking first segment
 [goToTime] 11:48:11-977  => seg 0, rel time 0.00 secs
 [resetAfterSeek] 11:48:11-977  Resetting faad
 [initFaad] 11:48:11-977  [FAAD] using 2 bytes of extradata
11 90
 [initFaad] 11:48:11-977  [FAAD] Found :48000 rate 2 channels
[MP4] Go to time succeeded chunk :0 time ask:0 time get:0
 [AUDMAudioFilter_Bridge] 11:48:11-977  [Bridge] Starting with time 00:00:00,000 , shift 0 ms
 [AUDMAudioFilter_Bridge] 11:48:11-977  [Bridge] Ending with time 00:00:00,000, sample 0
 [rewind] 11:48:11-977  [AudioBridge] Going to time 00:00:00,000
 [goToTime] 11:48:11-977   go to time 0.00 secs
 [convertLinearTimeToSeg] 11:48:11-977  Frame time=0, taking first segment
 [goToTime] 11:48:11-977  => seg 0, rel time 0.00 secs
 [resetAfterSeek] 11:48:11-977  Resetting faad
 [initFaad] 11:48:11-977  [FAAD] using 2 bytes of extradata
11 90
 [initFaad] 11:48:11-977  [FAAD] Found :48000 rate 2 channels
[MP4] Go to time succeeded chunk :0 time ask:0 time get:0
 [rewind] 11:48:11-977  [AudioBridge] Going to time 00:00:00,000
 [goToTime] 11:48:11-977   go to time 0.00 secs
 [convertLinearTimeToSeg] 11:48:11-977  Frame time=0, taking first segment
 [goToTime] 11:48:11-977  => seg 0, rel time 0.00 secs
 [resetAfterSeek] 11:48:11-977  Resetting faad
 [initFaad] 11:48:11-977  [FAAD] using 2 bytes of extradata
11 90
 [initFaad] 11:48:11-977  [FAAD] Found :48000 rate 2 channels
[MP4] Go to time succeeded chunk :0 time ask:0 time get:0
 [init] 11:48:11-988  Initializing audioDeviceThreaded with channels=2, fq=48000
DeviceStopped -> DeviceStopped
 [localInit] 11:48:11-988  Pulse, initiliazing channel=2 samplerate=48000
 [localInit] 11:48:11-994  [PulseSimple] open ok for fq=48000 channels=2
DeviceStopped -> DeviceStarted
 [stop] 11:48:11-994  [audioDevice] Stopping device...
DeviceStarted -> DeviceStop_Requested
[AudioDeviceThreaded] Entering loop
DeviceStop_Requested -> DeviceStop_Granted
[AudioDeviceThreaded] Exiting loop
[PulseAudio] Stopped
DeviceStop_Granted -> DeviceStopped
 [init] 11:48:11-996  Initializing audioDeviceThreaded with channels=2, fq=48000
DeviceStopped -> DeviceStopped
 [localInit] 11:48:11-996  Pulse, initiliazing channel=2 samplerate=48000
 [localInit] 11:48:11-999  [PulseSimple] open ok for fq=48000 channels=2
DeviceStopped -> DeviceStarted
[Playback] Latency : 50 ms
[AudioDeviceThreaded] Entering loop
[Playback] Latency is now 0
 [startThread] 11:48:12-004  Starting thread...
 [convertLinearTimeToSeg] 11:48:12-004  Frame time=0, taking first segment
 [startThread] 11:48:12-014  Thread created and started
 [run] 11:48:23-938  Faad: Error 15 :Array index out of range
 [run] 11:48:23-938  Bytes consumed 0, bytes dropped 464
[Composer::getPCMPacket] Track 0, 0x293f420 : drift -42667, computed : 00:00:16,810 got 00:00:16,853
 [refillPacketBuffer] 11:48:23-941  Consumed all data from this audio segment
[MP4Audio] : index max :822/822
 [getPacket] 11:48:23-941  Audio getPacket failed, audioSegment=0
 [getPacket] 11:48:23-941  ..and this is the last segment
 [refillPacketBuffer] 11:48:23-941  End of audio
 [getPCMPacket] 11:48:23-941  [Editor] Cannot refill audio
 [fillIncomingBuffer] 11:48:23-941  [Bridge] End of stream
[MP4Audio] : index max :822/822
 [getPacket] 11:48:25-975  Audio getPacket failed, audioSegment=0
 [getPacket] 11:48:25-975  ..and this is the last segment
[MP4Audio] : index max :822/822 (message repeated 1 times)
 [getPacket] 11:48:26-565  Audio getPacket failed, audioSegment=0 (message repeated 2 times)
 [getPacket] 11:48:26-565  ..and this is the last segment
 [getPacket] 11:48:26-693  Audio getPacket failed, audioSegment=0 (message repeated 6 times)
 [getPacket] 11:48:26-693  ..and this is the last segment
[MP4Audio] : index max :822/822 (message repeated 9 times)
 [getPacket] 11:48:26-808  Audio getPacket failed, audioSegment=0 (message repeated 6 times)
 [getPacket] 11:48:26-808  ..and this is the last segment
 [getPacket] 11:48:26-925  Audio getPacket failed, audioSegment=0 (message repeated 6 times)
 [getPacket] 11:48:26-925  ..and this is the last segment
[MP4Audio] : index max :822/822 (message repeated 10 times)
 [getPacket] 11:48:27-043  Audio getPacket failed, audioSegment=0 (message repeated 6 times)
 [getPacket] 11:48:27-043  ..and this is the last segment
 [getPacket] 11:48:27-155  Audio getPacket failed, audioSegment=0 (message repeated 5 times)
 [getPacket] 11:48:27-155  ..and this is the last segment
[MP4Audio] : index max :822/822 (message repeated 10 times)
 [getPacket] 11:48:27-276  Audio getPacket failed, audioSegment=0 (message repeated 6 times)
 [getPacket] 11:48:27-276  ..and this is the last segment
[MP4Audio] : index max :822/822 (message repeated 9 times)
 [getPacket] 11:48:27-412  Audio getPacket failed, audioSegment=0 (message repeated 7 times)
 [getPacket] 11:48:27-412  ..and this is the last segment
 [getPacket] 11:48:27-519  Audio getPacket failed, audioSegment=0 (message repeated 6 times)
 [getPacket] 11:48:27-519  ..and this is the last segment
[MP4Audio] : index max :822/822 (message repeated 10 times)
 [getPacket] 11:48:27-666  Audio getPacket failed, audioSegment=0 (message repeated 5 times)
 [getPacket] 11:48:27-666  ..and this is the last segment
 [getPacket] 11:48:27-780  Audio getPacket failed, audioSegment=0 (message repeated 7 times)
 [getPacket] 11:48:27-780  ..and this is the last segment
[MP4Audio] : index max :822/822 (message repeated 12 times)
 [getPacket] 11:48:27-893  Audio getPacket failed, audioSegment=0 (message repeated 7 times)
 [getPacket] 11:48:27-893  ..and this is the last segment
 [getPacket] 11:48:28-006  Audio getPacket failed, audioSegment=0 (message repeated 5 times)
 [getPacket] 11:48:28-006  ..and this is the last segment
[MP4Audio] : index max :822/822 (message repeated 9 times)
 [getPacket] 11:48:28-109  Audio getPacket failed, audioSegment=0 (message repeated 5 times)
 [getPacket] 11:48:28-109  ..and this is the last segment
 [getPacket] 11:48:28-215  Audio getPacket failed, audioSegment=0 (message repeated 6 times)
 [getPacket] 11:48:28-215  ..and this is the last segment
[MP4Audio] : index max :822/822 (message repeated 9 times)
 [getPacket] 11:48:28-326  Audio getPacket failed, audioSegment=0 (message repeated 5 times)
 [getPacket] 11:48:28-326  ..and this is the last segment
 [getPacket] 11:48:28-427  Audio getPacket failed, audioSegment=0 (message repeated 5 times)
 [getPacket] 11:48:28-427  ..and this is the last segment
[MP4Audio] : index max :822/822 (message repeated 10 times)
 [getPacket] 11:48:28-534  Audio getPacket failed, audioSegment=0 (message repeated 6 times)
 [getPacket] 11:48:28-534  ..and this is the last segment
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1051
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1052
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1053
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1054
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1055
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1056
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1057
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1058
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1059
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1060
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1061
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1062
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1063
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1064
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1065
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1066
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1067
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1068
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1069
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [DecodeNextPicture] 11:48:29-424  getFrame failed for frame 1070
 [nextPictureInternal] 11:48:29-424  Next picture failed
 [nextPictureInternal] 11:48:29-424  nextPictureInternal Failed
 [nextPictureInternal] 11:48:29-424  while looking for 17516944 us, 17516 ms
ReadIndex:1043, WriteIndex:1051
Edcache content[0]: PTS : 00:00:17,482 17482 ms
Edcache content[1]: PTS : 00:00:17,499 17499 ms
Edcache content[2]: PTS : 00:00:17,516 17516 ms
Edcache content[3]: PTS : 00:00:17,399 17399 ms
Edcache content[4]: PTS : 00:00:17,416 17416 ms
Edcache content[5]: PTS : 00:00:17,432 17432 ms
Edcache content[6]: PTS : 00:00:17,449 17449 ms
Edcache content[7]: PTS : 00:00:17,466 17466 ms
 [nextPicture] 11:48:29-424  Cannot get next picture. Last segment
 [getNextFrameAs] 11:48:29-424  [Bridge] Base did not get an image
 [runAction] 11:48:29-424  Video Thread, no more data
 [runAction] 11:48:29-424  Exiting video thread loop
 [getNextFrameAs] 11:48:29-561  Audio thread stopped, no more data
[Play] Cancelling playback, nextPicture failed
 [cleanup] 11:48:29-561  Cleaning up..
 [stop] 11:48:29-561  [audioDevice] Stopping device...
DeviceStarted -> DeviceStop_Requested
DeviceStop_Requested -> DeviceStop_Granted
[AudioDeviceThreaded] Exiting loop
[PulseAudio] Stopped
DeviceStop_Granted -> DeviceStopped
[Bridge] Destroying bridge
 [cleanup] 11:48:29-567  Destroying video playback chain
 [stopThread] 11:48:29-567  Destroying threadQueue
 [~ADM_threadQueue] 11:48:29-567  Killing audio thread and son
 [GUI_PlayAvi] 11:48:29-567  Restoring display.
 [renderDisplayResize] 11:48:29-567  Render to 1920x1080 zoom=1.0000, old one =1920 x 1080, zoom=1.0000, renderer=0x30665d0
 [renderDisplayResize] 11:48:29-567            No change, nothing to do
Paint event
 [refresh] 11:49:17-626  [Vdpau]Rrefresh

Mister_Oizo

  • Newbie
  • *
  • Posts: 6
I tried with the latest win64-nightly (Nov 27), but it still crashes:

Code: [Select]
EXCEPTION_ACCESS_VIOLATION
ADM_AudiocoderLavcodec::decodeToFloatPlanar(float**, unsigned int*)  [libADM_ad_lav.dll]
ADM_setCrashHook  [libADM_core6.dll]
ADM_setCrashHook  [libADM_core6.dll]
ADM_setCrashHook  [libADM_core6.dll]
UnhandledExceptionFilter  [KERNELBASE.dll]
memset  [ntdll.dll]
_C_specific_handler  [ntdll.dll]
_chkstk  [ntdll.dll]
RtlRaiseException  [ntdll.dll]
KiUserExceptionDispatcher  [ntdll.dll]
ADM_AudiocoderLavcodec::decodeToFloatPlanar(float**, unsigned int*)  [libADM_ad_lav.dll]
ADM_AudiocoderLavcodec::run(unsigned char*, unsigned int, float*, unsigned int*)  [libADM_ad_lav.dll]
ADM_edAudioTrackFromVideo::getPCMPacket(float*, unsigned int, unsigned int*, unsigned long long*)  [avidemux.exe]
AUDMAudioFilter_Bridge::fillIncomingBuffer(AUD_Status*)  [avidemux.exe]
AUDMAudioFilter_Bridge::fill(unsigned int, float*, AUD_Status*)  [avidemux.exe]
GUIPlayback::audioPump(bool)  [avidemux.exe]
GUIPlayback::run()  [avidemux.exe]
GUI_PlayAvi()  [avidemux.exe]
HandleAction(Action)  [avidemux.exe]
MainWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)  [avidemux.exe]
QMetaObject::activate(QObject*, int, int, void**)  [Qt5Core.dll]
MainWindow::actionSignal(Action)  [avidemux.exe]
MainWindow::searchGoMenu(QAction*)  [avidemux.exe]
MainWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)  [avidemux.exe]
QMetaObject::activate(QObject*, int, int, void**)  [Qt5Core.dll]
QMenu::showTearOffMenu()  [Qt5Widgets.dll]
QMenu::qt_static_metacall(QObject*, QMetaObject::Call, int, void**)  [Qt5Widgets.dll]
QMetaObject::activate(QObject*, int, int, void**)  [Qt5Core.dll]
QAction::activate(QAction::ActionEvent)  [Qt5Widgets.dll]
QAction::event(QEvent*)  [Qt5Widgets.dll]
QApplicationPrivate::notify_helper(QObject*, QEvent*)  [Qt5Widgets.dll]
QApplication::notify(QObject*, QEvent*)  [Qt5Widgets.dll]
QCoreApplication::notifyInternal2(QObject*, QEvent*)  [Qt5Core.dll]
QShortcutMap::dispatchEvent(QKeyEvent*)  [Qt5Gui.dll]
QShortcutMap::tryShortcut(QKeyEvent*)  [Qt5Gui.dll]
QWindowSystemInterface::handleShortcutEvent(QWindow*, unsigned long, int, QFlags<Qt::KeyboardModifier>, unsigned int, unsigned int, unsigned int, QString const&, bool, unsigned short)  [Qt5Gui.dll]
QGuiApplicationPrivate::processKeyEvent(QWindowSystemInterfacePrivate::KeyEvent*)  [Qt5Gui.dll]
QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*)  [Qt5Gui.dll]
QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>)  [Qt5Gui.dll]
QEventDispatcherWin32Private::sendTimerEvent(int)  [Qt5Core.dll]
DispatchMessageW  [USER32.dll]
NotifyWinEvent  [USER32.dll]
QEventDispatcherWin32::processEvents(QFlags<QEventLoop::ProcessEventsFlag>)  [Qt5Core.dll]
qt_plugin_instance  [qwindows.dll]
QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>)  [Qt5Core.dll]
QCoreApplication::exec()  [Qt5Core.dll]
UI_RunApp()  [avidemux.exe]
startAvidemux(int, char**)  [avidemux.exe]
SDL_main  [avidemux.exe]
ms2timedisplay(unsigned int)  [avidemux.exe]
unknown function  [avidemux.exe]
unknown function  [avidemux.exe]
BaseThreadInitThunk  [KERNEL32.DLL]
RtlUserThreadStart  [ntdll.dll]

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1535
Okay, as my own build for Windows didn't crash, but the official one did, I looked closer at the official one and the difference is that libfaad in the official nightly is missing. The Faad decoder prints "Error 15 :Array index out of range" to the log, but doesn't crash. Without libfaad, the bundled ffmpeg is used to decode audio, and this doesn't go well here.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1535
Here is the relevant part of the log:

Code: [Select]
[init] 12:27:03-281 Initializing audioDeviceThreaded with channels=2, fq=48000
DeviceStopped -> DeviceStopped
[localInit] 12:27:03-281 [Win32] Opening Audio, channels=2 freq=48000
[localInit] 12:27:03-281 Bucket size=19200
DeviceStopped -> DeviceStarted
[Playback] Latency : 0 ms
[AudioDeviceThreaded] Entering loop
[Playback] Latency is now 0
[startThread] 12:27:03-325 Starting thread...
[startThread] 12:27:03-335 Thread created and started
[adm_lavLogCallback] 12:27:12-155 [lavc] decode_band_types: Input buffer exhausted before END element found
[run] 12:27:12-155 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-156 [lavc] Number of bands (36) exceeds limit (24).
[run] 12:27:12-156 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-156 [lavc] channel element 2.10 is not allocated
[run] 12:27:12-156 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-156 [lavc] channel element 2.6 is not allocated
[run] 12:27:12-156 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-156 [lavc] Reserved bit set.
[adm_lavLogCallback] 12:27:12-156 [lavc] Number of bands (10) exceeds limit (5).
[run] 12:27:12-157 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-157 [lavc] Sample rate index in program config element does not match the sample rate index configured by the container.
[adm_lavLogCallback] 12:27:12-158 [lavc] Inconsistent channel configuration.
[adm_lavLogCallback] 12:27:12-158 [lavc] get_buffer() failed
[run] 12:27:12-158 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-158 [lavc] Reserved bit set.
[adm_lavLogCallback] 12:27:12-158 [lavc] channel element 0.0 is not allocated
[run] 12:27:12-159 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-159 [lavc] Sample rate index in program config element does not match the sample rate index configured by the container.
[adm_lavLogCallback] 12:27:12-159 [lavc] Inconsistent channel configuration.
[adm_lavLogCallback] 12:27:12-159 [lavc] get_buffer() failed
[run] 12:27:12-160 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-160 [lavc] channel element 2.0 is not allocated
[run] 12:27:12-160 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-160 [lavc] Sample rate index in program config element does not match the sample rate index configured by the container.
[adm_lavLogCallback] 12:27:12-160 [lavc] Inconsistent channel configuration.
[adm_lavLogCallback] 12:27:12-160 [lavc] get_buffer() failed
[run] 12:27:12-160 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-161 [lavc] Number of bands (57) exceeds limit (48).
[run] 12:27:12-161 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-161 [lavc] Number of bands (24) exceeds limit (13).
[run] 12:27:12-161 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-161 [lavc] Number of bands (4) exceeds limit (1).
[run] 12:27:12-161 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-161 [lavc] Reserved bit set.
[adm_lavLogCallback] 12:27:12-161 [lavc] Number of bands (24) exceeds limit (17).
[run] 12:27:12-162 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-162 [lavc] Prediction is not allowed in AAC-LC.
[run] 12:27:12-162 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-162 [lavc] Number of bands (3) exceeds limit (2).
[run] 12:27:12-162 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-162 [lavc] Sample rate index in program config element does not match the sample rate index configured by the container.
[adm_lavLogCallback] 12:27:12-162 [lavc] Inconsistent channel configuration.
[adm_lavLogCallback] 12:27:12-162 [lavc] get_buffer() failed
[run] 12:27:12-163 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-163 [lavc] Sample rate index in program config element does not match the sample rate index configured by the container.
[adm_lavLogCallback] 12:27:12-167 [lavc] Inconsistent channel configuration.
[adm_lavLogCallback] 12:27:12-167 [lavc] get_buffer() failed
[run] 12:27:12-167 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-167 [lavc] Number of bands (50) exceeds limit (40).
[run] 12:27:12-167 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-168 [lavc] Number of bands (24) exceeds limit (16).
[run] 12:27:12-168 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-168 [lavc] Number of bands (28) exceeds limit (22).
[run] 12:27:12-168 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-168 [lavc] Reserved bit set.
[adm_lavLogCallback] 12:27:12-168 [lavc] Number of bands (4) exceeds limit (1).
[run] 12:27:12-168 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-168 [lavc] Reserved bit set.
[adm_lavLogCallback] 12:27:12-168 [lavc] Prediction is not allowed in AAC-LC.
[run] 12:27:12-169 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-169 [lavc] channel element 2.0 is not allocated
[run] 12:27:12-169 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-169 [lavc] Prediction is not allowed in AAC-LC.
[run] 12:27:12-169 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-169 [lavc] channel element 3.1 is not allocated
[run] 12:27:12-169 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-169 [lavc] channel element 2.0 is not allocated
[run] 12:27:12-169 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-170 [lavc] channel element 2.12 is not allocated
[run] 12:27:12-170 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-170 [lavc] Number of bands (25) exceeds limit (16).
[run] 12:27:12-170 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-170 [lavc] Number of bands (14) exceeds limit (11).
[run] 12:27:12-170 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-170 [lavc] Reserved bit set.
[adm_lavLogCallback] 12:27:12-170 [lavc] Number of bands (14) exceeds limit (10).
[run] 12:27:12-171 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-171 [lavc] Prediction is not allowed in AAC-LC.
[run] 12:27:12-171 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-174 [lavc] Inconsistent channel configuration.
[adm_lavLogCallback] 12:27:12-174 [lavc] get_buffer() failed
[run] 12:27:12-174 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-174 [lavc] channel element 2.1 is not allocated
[run] 12:27:12-174 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-175 [lavc] Prediction is not allowed in AAC-LC.
[run] 12:27:12-175 [ADM_ad_lav] *** decoding error (1)***
[adm_lavLogCallback] 12:27:12-175 [lavc] Reserved bit set.
[adm_lavLogCallback] 12:27:12-175 [lavc] Multiple frames in a packet.
Saving crash file to C:\Users\Ilja\AppData\Roaming\avidemux\crash.py
Scripting video streams
Scripting segments
Scripting markers
Scripting post-processing
Scripting video encoder
Scripting video filters
Scripting audio tracks
Scripting muxer
RAX: 00000000  RBX: 00000001  RCX: 00000400  RDX: 14EEA850  RSI: 0022ADD8  RDI: 0022AE0C  RSP: 0022AC50  RBP: 051B4080
R8: 118D0F00  R9: 00000000  R10: 00000100  R11: 00000400  R12: 00000000  R13: 655439A0  R14: 04ED32B0  R15: 0022AE0C
RIP: 6EAC253F  EFlags: 00010202

EXCEPTION_ACCESS_VIOLATION
ADM_AudiocoderLavcodec::decodeToFloatPlanar(float**, unsigned int*)  [libADM_ad_lav.dll]

Deleting libADM_ad_faad.so (.dylib on macOS) from the plugins directory allows to reproduce the crash on Linux and macOS.

Mister_Oizo

  • Newbie
  • *
  • Posts: 6
Nice job on finding the culprit!  8) ;)

Let me know when it's fixed in nightly and/or official so I can update. Thanks!
« Last Edit: November 29, 2017, 02:29:00 PM by Mister_Oizo »

MeanAdmin

  • Administrator
  • Newbie
  • *****
  • Posts: 33
Please try the nightly

Mister_Oizo

  • Newbie
  • *
  • Posts: 6
Please try the nightly

It's not crashing anymore, but the other audio track is still not playing. It does play when the first track is disabled. Check attachment.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1535
Works for me, there is no need to disable the first track. Avidemux plays always only the track set as the first one, this is a design limitation, not a bug.