Author Topic: AppImage 2.7.0 pour Linux ne fonctionne pas  (Read 1285 times)

pdemong

  • Newbie
  • *
  • Posts: 5
AppImage 2.7.0 pour Linux ne fonctionne pas
« on: December 10, 2017, 08:09:13 AM »
Bonjour,
la dernière version 2.7.0 ne se lance pas sur Ubuntu 16.04 (64bits).
En lançant en ligne de commande, on parvient à avoir un message d'erreur :
Code: [Select]
$ ./avidemux_2.7.0.appImage
/tmp/.mount_aqzD7C/usr/bin/avidemux3_portable: error while loading shared libraries: libva-drm.so.1: cannot open shared object file: No such file or directory

Je ne sais pas trop comment le signaler, alors je poste ceci dans ce forum.
Patrick

pdemong

  • Newbie
  • *
  • Posts: 5
Re: AppImage 2.7.0 pour Linux ne fonctionne pas
« Reply #1 on: December 10, 2017, 08:20:32 AM »
Ah ben finalement il est possible de faire fonctionner la dernière version 2.7.0 d'avidemux.
Il faut par contre installer une librairie supplémentaire : libav-drm1
Code: [Select]
sudo apt-get install libva-drm1
Ensuite avidemux 2.7.0 se lance sans erreur.

C'est là qu'on voit les limites des AppImage vs le gestionnaire de paquets/dépendances APT ;)

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10958
Re: AppImage 2.7.0 pour Linux ne fonctionne pas
« Reply #2 on: December 10, 2017, 06:21:02 PM »
ah
Je vais le desactiver pour appImage


Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6052
Re: AppImage 2.7.0 pour Linux ne fonctionne pas
« Reply #3 on: December 11, 2017, 03:20:54 AM »
Update appImage 171210_113 : http://avidemux.org/nightly/appImage


pdemong

  • Newbie
  • *
  • Posts: 5
Re: AppImage 2.7.0 pour Linux ne fonctionne pas
« Reply #4 on: February 17, 2018, 06:34:15 AM »
Rebonjour, je viens de lire pour la mise à jour de l'AppImage, merci!

J'ai remarqué un autre problème : le module "joblist" (je ne sais pas comment l'appeler... planificateur de tâche?) ne semble pas inclus.
Bon alors je vais utiliser les sources du coup, et recompiler avec les options qu'il faut (--with-cli), mais ce serait cool d'avoir tout dans l'AppImage.

Autre remarque, et j'hésite à ouvrir un autre post pour cela : la méthode proposée dans le wiki contient une erreur.
Dans bootStrap.bash, l'option --enable-qt5 n'existe plus, puisque c'est le comportement par défaut. Ce qui fait qu'en suivant le wiki, on obtient un plantage de l'installation.
Donc si un modérateur pouvait mettre à jour le wiki (j'ai hésité à écrire directement à l'adresse free figurant en bas à gauche de la page d'accueil de avidemux  :) ), merci beaucoup en tout cas pour ce logiciel que j'adore!

pdemong

  • Newbie
  • *
  • Posts: 5
Re: AppImage 2.7.0 pour Linux ne fonctionne pas
« Reply #5 on: March 13, 2018, 08:48:12 PM »
J'ai finalement ouvert un autre topic : http://avidemux.org/smif/index.php/topic,18254.0.html