Author Topic: Can not process a VOB from original dvd  (Read 554 times)

damorsoft

  • Newbie
  • *
  • Posts: 1
Can not process a VOB from original dvd
« on: February 26, 2018, 03:45:52 PM »
I like to collect music videos, old DVDs are a great source.
This one The Carpenters collection, just will not open in AVIdemux, just a gray screen.
Here is the final VOB of the set, it is a decent size to move around.

https://www.dropbox.com/s/4h3xhoi9m1a1vvh/VTS_02_4.VOB?dl=0

I used ffmpeg to convert this VOB to an avi and all is well.
My guess is that avidemux is assuming a frame rate of 50 instead of 25.
Hand brake could convert it to an mp4 but then you have the 10 second keyframe issue.
I don't want the collection as a whole just some of my favorites that I can then add to my collection, usually as MKV.

feel free to email.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2062
Re: Can not process a VOB from original dvd
« Reply #1 on: February 26, 2018, 04:00:17 PM »
First of all, VOBs on a DVD are not supposed to be handled separately, they are not independent files but fragments of a single file, split at 1 GiB boundaries. Avidemux can play this VOB, but not display a frame after a seek to a keyframe. Maybe wrong frames are marked as keyframes.

Avidemux identifies the frame rate as 25 fps.

BTW, totally wrong section of the forum.

zakk

  • Hero Member
  • *****
  • Posts: 622
Re: Can not process a VOB from original dvd
« Reply #2 on: February 26, 2018, 05:22:20 PM »
Do you wish to compress ?

dosdan

  • Jr. Member
  • **
  • Posts: 93
Re: Can not process a VOB from original dvd
« Reply #3 on: February 26, 2018, 08:08:05 PM »
Hand brake could convert it to an mp4 but then you have the 10 second keyframe issue.

In HB and in many other frontends for X264 you can set extra parameters. In HB this is on the Video tab in the "Extra Options" box. Say you only want a max. GOP length of 25 frames i.e. a new key-frame every .5s @ 50fps. (Scene changes, when they occur, can produce a shorter GOP.) You would enter this parameter in the box:

--keyint 25


Dan.
« Last Edit: February 26, 2018, 08:14:01 PM by dosdan »