Author Topic: subtitle filter missing in avidemux 2.7.0  (Read 717 times)

mnatiello

  • Newbie
  • *
  • Posts: 7
subtitle filter missing in avidemux 2.7.0
« on: April 12, 2018, 04:13:14 PM »
Hi
I downloaded avidemux 2.7.0 from openSuSE Tumbleweed repository (linux 64).
The subtitle filter (and perhaps also others) is missing.
How can I solve this?
Thanks.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2017
Re: subtitle filter missing in avidemux 2.7.0
« Reply #1 on: April 12, 2018, 05:29:01 PM »
What does

Code: [Select]
rpm -qa | grep -i avidemux
report?

mnatiello

  • Newbie
  • *
  • Posts: 7
Re: subtitle filter missing in avidemux 2.7.0
« Reply #2 on: April 12, 2018, 07:53:17 PM »
Hi
I get:
avidemux3-2.7.0-5.2.x86_64
avidemux3-qt5-2.7.0-5.2.x86_64
avidemux3-cli-2.7.0-5.2.x86_64

There is nothing else to upload in Tumbleweed other than lang- and debugpackages.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2017
Re: subtitle filter missing in avidemux 2.7.0
« Reply #3 on: April 12, 2018, 08:36:23 PM »
Now I would like to find out which files belong to the first two packages:

Code: [Select]
rpm -ql avidemux3-2.7.0-5.2.x86_64
rpm -ql avidemux3-qt5-2.7.0-5.2.x86_64

mnatiello

  • Newbie
  • *
  • Posts: 7
Re: subtitle filter missing in avidemux 2.7.0 - resend
« Reply #4 on: April 12, 2018, 10:12:15 PM »
Thank you for helping me on this. It's two long lists. I attach the output.
It gave me an error when I simply copied the output, I send a tgz file instead

rpm -ql avidemux3-2.7.0-5.2.x86_64 > sv1
rpm -ql avidemux3-qt5-2.7.0-5.2.x86_64 > sv2
tar cvzf ans.tgz sv*

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2017
Re: subtitle filter missing in avidemux 2.7.0
« Reply #5 on: April 12, 2018, 11:03:37 PM »
Thanks, libADM_vf_ssa.so is indeed missing. The best option would be to build Avidemux from the git master yourself, the 2.7.0 release is getting old in the tooth.

Code: [Select]
zypper si -d avidemux3
(unsure about "avidemux3" as package name, maybe it should be "avidemux3-2.7.0" or even the complete string "avidemux3-2.7.0-5.2.x86_64") will install build dependencies for SuSE. Please ensure that git, the SuSE equivalent for "freetype-devel" and "fontconfig-devel" are also installed. Clone then the avidemux2 git repository

Code: [Select]
git clone https://github.com/mean00/avidemux2.git
followed by

Code: [Select]
cd avidemux2
bash bootStrap.bash --prefix=/usr/local

If all goes well, you will find the Avidemux binaries below avidemux2/install/usr/local. Remove the SuSE Avidemux packages and copy the contents of "local" over /usr/local.

mnatiello

  • Newbie
  • *
  • Posts: 7
Re: subtitle filter missing in avidemux 2.7.0
« Reply #6 on: April 13, 2018, 06:54:03 AM »
Hi.
It almost worked.
avidemux was compiled, I couldn't see any warnings or complains.
I copied the files to /usr/local but when running it complains about a library:
$ /usr/local/bin/avidemux3_qt5
/usr/local/bin/avidemux3_qt5: error while loading shared libraries: libADM_coreVideoCodec6.so: cannot open shared object file: No such file or directory
The library is present in /usr/local/lib64/:
-rwxr-xr-x 1 root 83232 Apr 13 08:23 /usr/local/lib64/libADM_coreVideoCodec6.so*
Any suggestion?

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2017
Re: subtitle filter missing in avidemux 2.7.0
« Reply #7 on: April 13, 2018, 07:18:31 AM »
Is /usr/local/lib64 listed in a .conf file in /etc/ld.so.conf.d/ ? If yes, run ldconfig as root or via sudo.

mnatiello

  • Newbie
  • *
  • Posts: 7
Re: subtitle filter missing in avidemux 2.7.0
« Reply #8 on: April 13, 2018, 07:47:52 AM »
I couldn't find /usr/local/lib64 anywhere in the .conf files
but I ran ldconfig anyway. It helped.
Now avidemux runs, and it appears to be my build
(dated today: 180413_f755326eaa44-fflibs 3.3.6)
It works better than before.
However, the subtitle filter is still empty.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2017
Re: subtitle filter missing in avidemux 2.7.0
« Reply #9 on: April 13, 2018, 08:03:44 AM »
No libADM_vf_ssa.so in /url/local/lib64/ADM_plugins6/videoFilters ? Install the devel package for libass then and rebuild plugins by running

Code: [Select]
bash bootStrap.bash --prefix=/usr/local --rebuild --without-core --without-qt --without-cli --with-system-libass
in the avidemux2 directory. Inspect the cmake messages and the content of /tmp/logbuildPluginsCommon if libADM_vf_ssa.so still doesn't get built.
« Last Edit: April 13, 2018, 08:06:38 AM by eumagga0x2a »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2017
Re: subtitle filter missing in avidemux 2.7.0
« Reply #10 on: April 13, 2018, 09:59:49 AM »
If the libass plugin doesn't get built on SuSE (this is what it looks like now), please redirect the output of bootStrap.bash (stdout and stderr) to a file, compress it and attach to your reply for examination.

mnatiello

  • Newbie
  • *
  • Posts: 7
Re: subtitle filter missing in avidemux 2.7.0
« Reply #11 on: April 13, 2018, 11:36:31 AM »
Hi
Thanks once again.
libass-devel is installed in my system.
No subtitles filter is present though, nor is libADM_vf_ssa.so built.
I can't find that string in logbuild nor in the output of the bash script.
The lib is not present  among avidemux libraries.
I attach the tarfile with the output and logbuild.
Thanks,
M. Natiello

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2017
Re: subtitle filter missing in avidemux 2.7.0
« Reply #12 on: April 13, 2018, 12:07:59 PM »
Quote
Code: [Select]
-- Checking for Fridibi (want 0.19)
-- **************************************
-- Found Fribidi
-- Compiler Flags: -I/usr/include/fribidi
-- Linker Flags  : -lfribidi
-- Fridibi version 1.0.1
-- Your version of cmake is too old, we need  0.19.*

-- Fribidi or feetype missing, skipping filter

I'll look into it once I get a chance.

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 2017
Re: subtitle filter missing in avidemux 2.7.0
« Reply #13 on: April 13, 2018, 06:07:12 PM »
Should be fixed by [cmake] Fix fribidi version check, consistently use the correct library name, please execute
Code: [Select]
git pull
in the "avidemux2" folder, delete the "install" folder with compilation products and run

Code: [Select]
bash bootStrap.bash --prefix=/usr/local --with-system-libass
Then check whether libADM_vf_ssa.so has been generated. If yes, copy the content of "install/usr/local" over "/usr/local" like before. You will probably have to rerun ldconfig.
« Last Edit: April 13, 2018, 06:08:53 PM by eumagga0x2a »

mnatiello

  • Newbie
  • *
  • Posts: 7
Re: subtitle filter missing in avidemux 2.7.0
« Reply #14 on: April 19, 2018, 03:23:40 PM »
Hi

I am very sorry I didn't answer. I missed your last mail. I was wondering if you had forgotten...
I recompiled. The subtitles plugin is now present. I have not checked yet that it works correctly,
but why shouldn't it? The new subtitle file I have has not exactly the same time-stamps as the
original. I hope there still exists a way to "stretch it" so that it fits.
I attach the outcome of the compilation, just in case.