AviDemux 2.7.5 Crashes on Import of DVB-C TS (h264-format) (macOS Catalina)

Started by avidemuxuser001, February 29, 2020, 11:27:56 AM

Previous topic - Next topic


Hey Guys,
I was wondering, if I am the only one to cut and recode TV recordings? Since upgrading from Mojave to Catalina, Avidemux seems to have issues, which I can reproduce.
Following conditions apply here:

- iMac18.3, 27"
- macOS Catalina 10.15.3
- AviDemux 2.7.5

- DVB-C Transport Stream (TS)
- h264 format

Process (see attached pictures):
- indexing of transport streams works
- crash occurs when timestamps are being checked (infinite loop?!)
- AviDemux needs to be killed in activity monitor then

Anybody else experiencing this behaviour? Or does anybody have hints, what to do?

Kind regards, Alex



Thanks for coming back so fast.

- I downloaded "Avidemux 2.7.5 200114-18h13m_e18a5e67d3b.dmg"
- I reinstalled
- I opened a TS (DVB-C) h264
- it crashes again.

Cross-Check on Win 10 / VMWare:
- same TS file can be opened without any issue

Ceteris paribus conditions:
- aswell on macOS as on Win10: tried to open from a SMB-network share as directly from the operating system's hard drive

Let me know, what I can do to determine the cause of this behaviour on macOS. BTW: I never experienced this issue on Mojave.

Kd rgds, Alex


I added another test:

Windows 10 / VMWare / Avidemux 2.7.5
- I can load the TS stream
- I changed the encapsulation to MP4 and saved it again (copy mode for video and audio streams)
- Saving works

Back on
macOS Catalina 10.15.3 / Avidemux 2.7.5
- I try to open the MP4 file
- It crashes again

For the moment, for me this indicates, that it is an issue concerning the macOS version only.

Let me know, what you think. And thanks again, Alex


According to your screenshot you have installed the nightly from November 24, 2019. Please re-test with the latest available nightly (from Jan. 14, 2020) by launching it from Terminal

/Applications/Avidemux_2.7.5.app/Contents/MacOS/Avidemux2.7 > ~/Desktop/admlog.txt 2>&1

Please don't forget to delete the *.idx2 file corresponding the MPEG-TS file you try to load prior to your test.

If the issue persists, please compress (zip or 7z) and attach the admlog.txt file generated on your desktop to your reply.


I am wondering, where you can identify which version I am running? The screenshot with the version number was from the Windows VM...

I did as you ordered ;-) and reinstalled 2.7.5 again...

The problem persists. AviDemux crashes. Find attached the desired log-file.

Thanks, Alex

P.S. Turning off hardware acceleration circumvents the problem for the moment and allows to load all TS files => It looks like, there is an issue with the hardware acceleration for h264 decoding...


Even as the log doesn't contain the info about the actual crash, I experience the same with field-encoded H.264 streams*, just unsure whether it started with Catalina or with some Catalina update. Apple has presumably broken the HW accelerated decoding for such content in Catalina, all applications are affected, even QuickTime (which just doesn't crash but lost the ability to play such streams).

As you noticed, disabling VideoToolbox is the only mitigation strategy for now.

*) No proof but sort of a clue:

[extractSPSInfo] 17:32:54-388  frameMbsOnlyFlag:0

in the log.


Thanks again.

I am still wondering, why some TS h264 indeed don't crash, while others do.

I am really considering going back to Mojave. In Ableton Live the mp4 support also has issues since Catalina.

Happy Sunday from Berlin, Alex



Regarding going back to Mojave, it might be that current Avidemux nightlies don't run on anything older than Catalina. This issue will be investigated soon.


Compatibility with older macOS releases starting with High Sierra has been restored from the 200313 nightly on.

The crash with interlaced H.264 streams (more precisely, with H.264 streams containing both field- and frame-encoded slices) and VideoToolbox hw accelerated decoder enabled has been worked around (the first picture after a switch is lost, however), please try a future Avidemux nightly for macOS.



so pleased I found this thread.  The apparently random (to me) crashing was driving me nuts.  Thanks for fixing it!