Avidemux Forum

Avidemux => Main version 2.6 => Topic started by: 3d420 on November 21, 2016, 08:07:14 PM

Title: Unable to load jpegs created in gimp.
Post by: 3d420 on November 21, 2016, 08:07:14 PM
I just started trying to use avidemux. It seems to load jpegs from my cameras just fine, but won't open jpegs I've exported from gimp. It gives this error message:
"Attempt to open /home/ogf/Desktop/frames1/1.JPEG failed!"
Then I click ok, and I get the message:
"Could not open the file"

What am I doing wrong?
Title: Re: Unable to load jpegs created in gimp.
Post by: mean on November 21, 2016, 08:17:17 PM
Version of avidemux ?
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 21, 2016, 08:27:35 PM
Version 2.5.4, running on linux mint 17.1 rebecca.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 21, 2016, 11:42:42 PM
Just tried it running on ubuntu with the same result.  :(
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 21, 2016, 11:44:36 PM
You should use the latest version (2.6.15). 2.5.x is a legacy application where development ceased years ago.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 22, 2016, 02:22:05 AM
I am unsure how to upgrade.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 22, 2016, 05:15:56 AM
Either build yourself, which is very easy on Linux, use the appImage provided by the author of Avidemux or the binaries provided by Jan Gruuthuse.
Title: Re: Unable to load jpegs created in gimp.
Post by: Jan Gruuthuse on November 22, 2016, 06:22:23 AM
No install just run, if not running check properties and allow to run.
universal app image, use latest: http://www.avidemux.org/nightly/appImage/

only 64-bit debs (ubuntu)
14.04 LTS based: http://avidemux.org/smif/index.php/topic,17277.0.html
16.04 LTS based: http://avidemux.org/smif/index.php/topic,17276.0.html

build yourself:
- Compiling Avidemux 2.6.x (http://www.avidemux.org/admWiki/doku.php?id=build:install_2.6)
- avidemux 2.6.# Compiling Avidemux on Ubuntu 16.04.1 LTS (http://avidemux.org/smif/index.php/topic,16750.0.html)
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 22, 2016, 06:31:04 PM
Build, don't build, run, allow , app image...
I have no idea what any of that means.
I am not a software developer. I just want to make videos. I used the mint software manager to install it, now I am looking for simple instructions to fix the problem.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 22, 2016, 07:23:44 PM
I looked in the mint update manager, but avidemux was not listed there.
Title: Re: Unable to load jpegs created in gimp.
Post by: Jan Gruuthuse on November 22, 2016, 09:29:02 PM
It is not in the update manager.
Ï not a developer either.
App is application, no installing.  Just download. Right click on it (properties), allow to run.

Debs are installables.

Building is making your own installables. 3 choices. Try the app. Double click once you allowed it to run.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 22, 2016, 10:35:27 PM
Ok. I went to the link you provided, and downloaded the latest file. Then I opened avidemux, and clicked on file: properties, and absolutely nothing happened.
Title: Re: Unable to load jpegs created in gimp.
Post by: Jan Gruuthuse on November 23, 2016, 05:36:25 AM
Not opening avidemux!
If you speak about the 1st option and downloaded the app. You right click on the downloaded app. And set there the allow to run option. When this done you run the app by clicking on the app. Got his app is avidemux and should open the this avidemux  and not the installed Avidemux.

Using the app: Avidemux Universal app (http://avidemux.org/smif/index.php/topic,17293.msg78061.html#msg78061)
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 23, 2016, 03:43:13 PM
I did exactly that.
I found the box, and clicked allow.
I restarted my computer.
I opened avidemux.
I tried to open the jpeg.
I got the same error messages.
After all that, I still have exactly the same problem.
Title: Re: Unable to load jpegs created in gimp.
Post by: Jan Gruuthuse on November 23, 2016, 04:06:58 PM
Then I opened avidemux, and clicked on file: properties, and absolutely nothing happened.

a little understatement above

I did exactly that.
I found the box, and clicked allow.
I restarted my computer.
I opened avidemux.
I tried to open the jpeg.
I got the same error messages.
After all that, I still have exactly the same problem.

Can you upload such a jpeg?
You can save the jpeg in Gimp as .png, is the png opening in avidemux (installed or app?)
jpg is still loading here in avidemux see screen shot.
Also attached a jpg for testing in Avidemux @ your side
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 23, 2016, 06:13:51 PM
Ok. I decided to start over. I uninstalled 2.5.4, and all other avidemux files.
I re downloaded the 161120_88.
I fixed the permission to allow.
I double click on the downloaded app.
And again, nothing happens. Avidemux does not even open now.
Title: Re: Unable to load jpegs created in gimp.
Post by: mean on November 23, 2016, 06:31:42 PM
You are running a 64bits os, right ?
 
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 23, 2016, 08:32:40 PM
Nope.
Linux Mint 17.1 "Rebecca" - MATE (32-bit)
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 23, 2016, 09:13:31 PM
So, I've deleted avidemux again, and I'm ready to start over.
Now what? Should I download a different app? Go back to my software manager? (that's how I ended up with 2.5 in the first place).
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 23, 2016, 09:19:51 PM
Can you upload such a jpeg?
I tried, but it was too big for the forum.
Quote
You can save the jpeg in Gimp as .png, is the png opening in avidemux (installed or app?)
I will try that once I have it installed again with the proper version. Right now I have nothing.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 23, 2016, 10:09:05 PM
Linux Mint 17.1 "Rebecca" - MATE (32-bit)

Due to a 32 bit version the only option you have is to build Avidemux from source.

edit: I've already mentioned that this is very easy, though some features might be not available because of your very outdated distribution.

Code: [Select]
sudo apt-get update
sudo apt-get install git
git clone https://github.com/mean00/avidemux2.git
cd avidemux2
bash createDebFromSourceUbuntu.bash

and have some coffee. Once the .deb packages are ready, the script will ask again for your user password to perform the installation.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 23, 2016, 11:01:53 PM
It asked for my password before anything, then downloaded a bunch of files, then stopped. It says "Reading package lists... Done".
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 23, 2016, 11:08:40 PM
edit: nevermind...

The first line updates the local package database. Now please run the second.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 23, 2016, 11:22:43 PM
I don't understand.  What should I do next?
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 23, 2016, 11:41:05 PM
You've apparently run only the first command out of five:

Code: [Select]
sudo apt-get update
This command requests the user passwort to update the package database. Once the command has exited, you get the prompt (usually it looks like

Code: [Select]
[your_username@hostname ~]$
pay attention to the "$" sign!) back. The second command

Code: [Select]
sudo apt-get install git
installs a tool which will download Avidemux source. The third command

Code: [Select]
git clone https://github.com/mean00/avidemux2.git
downloads the source into folder "avidemux2", the forth

Code: [Select]
cd avidemux2
changes directory into the folder "avidemux2" and the last one runs a script which installs build dependencies, compiles Avidemux and installs it.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 24, 2016, 12:49:39 AM
Ok. I see the folder. Now what?
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 24, 2016, 01:02:29 AM
Which command did you run last?
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 24, 2016, 01:46:35 AM
cd avidemux2
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 24, 2016, 01:57:58 AM
The run the last command in the list, please:

Code: [Select]
bash createDebFromSourceUbuntu.bash
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 24, 2016, 03:05:15 AM
Ok, I ran it. Now what?
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 24, 2016, 04:48:49 AM
 I chose this software because all the reviews said how easy it would be.  ::) Four days later, I have nothing.  ???
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 24, 2016, 07:01:29 AM
Ok, I ran it. Now what?

If the command finished with a success, you should be able to run Avidemux by executing

Code: [Select]
avidemux3_qt5
If the command finished with a failure, you should have posted the error message.
Title: Re: Unable to load jpegs created in gimp.
Post by: Jan Gruuthuse on November 24, 2016, 07:36:21 AM
Probably you still need to install the newly create debs:
Go into folder with debs:
Code: [Select]
cd ~/avidemux2/debsRemove developer debs:
Code: [Select]
rm --interactive=never *-dev.debInstall remaining debs
Code: [Select]
sudo dpkg -i *.deb
now you should either find:
Code: [Select]
/usr/bin/avidemux3_qt5 or
Code: [Select]
/usr/bin/avidemux3_qt4open terminal and try one of above, this should start avidemux.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 24, 2016, 08:09:21 AM
Probably you still need to install the newly create debs: [...]

No, no, no! If compilation was successful, the installation will be performed by the same script at line 13: https://github.com/mean00/avidemux2/blob/master/createDebFromSourceUbuntu.bash#L13 (https://github.com/mean00/avidemux2/blob/master/createDebFromSourceUbuntu.bash#L13) (unfortunately, the script will proceed with the installation even if the build returned an error, which should be fixed).

Quote
now you should either find:
Code: [Select]
/usr/bin/avidemux3_qt5 or
Code: [Select]
/usr/bin/avidemux3_qt4

Presumably only the first one (qt4 build requires the --enable-qt4 option passed to bootStrap.bash which is not the case here).
Title: Re: Unable to load jpegs created in gimp.
Post by: Jan Gruuthuse on November 24, 2016, 08:20:53 AM
If QT5 is not on the system? Or does the script install this one to?
If no QT5 then:
Code: [Select]
cd ~/avidemux2 && bash bootStrap.bash --deb --enable-qt4 --without-gtk --with-cli
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 24, 2016, 08:43:51 AM
The script installs Qt5, which amounts to an outdated version 5.2 on Mint Rebecca.

It looks for me like 3d420 were uncapable of handling any complexity, so please let us keep everything simple.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 24, 2016, 03:51:17 PM
It looks for me like 3d420 were uncapable of handling any complexity, so please let us keep everything simple.
Yes please!
I don't understand any of this, and your disagreement above tells me I am not alone.
Please give me complete instructions. If you don't tell me how to do it exactly, I will do it wrong. I have absolutely no experience in any of this.
After I ran the commands you gave me last night, I can't find any folder for avidemux anywhere, and my software manager does not list it. I finally went to sleep.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 24, 2016, 03:53:19 PM
I hope you see this as an opportunity to create a clear set of instructions. This kind of frustration is why people go back to windows.  :(
Title: Re: Unable to load jpegs created in gimp.
Post by: Jan Gruuthuse on November 24, 2016, 04:26:18 PM
Check If your CPU supports 64-bit, you could install a 64-bit OS Ubuntu LTS or Mint. 32-bit is a little dated these days.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 24, 2016, 04:42:28 PM
My computer is older than dated. It is definitely not 64 bit.
And now an avidemux folder has mysteriously appeared. How should I proceed?
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 24, 2016, 11:38:20 PM
And now an avidemux folder has mysteriously appeared. How should I proceed?

I have not a slightest idea, which "avidemux folder" you mean, but the question how to proceed has been answered in http://avidemux.org/smif/index.php/topic,17287.msg78103.html#msg78103 (http://avidemux.org/smif/index.php/topic,17287.msg78103.html#msg78103). In doubt try to run

Code: [Select]
avidemux3_qt5
in the terminal and in case no Avidemux window appears, post the error message shown in the terminal.


Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 12:21:53 AM
avidemux3_qt5: command not found
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 07:13:04 AM
This means, either the build of Avidemux (or just the part of Avidemux which provides the graphical interface) failed or we've got a Qt4-flavour of Avidemux (unlikely, but who knows) as Jan has suggested.

If

Code: [Select]
avidemux3_qt4
returns "avidemux3_qt4: command not found" as well, we have no other option as to track the failure and to see if anything can be done to avoid it (please note that I have very little time to guide you unless you get used to read what commands run in terminal tell you yourself).

If you have an "avidemux2" folder in your home directory, please look with a file manager into it if there are "deb" and "install" subfolders and if the former is empty, which of the "build*" folders exist.

If you don't have any of the "build*" (buildCli, buildPluginsCLI, buildPluginsQt5, buildQt5, buildCore, buildPluginsCommon, buildPluginsSettings) folders, you didn't even try to start building Avidemux. In this case you failed to follow step 5 (or even 4) of the instructions given in http://avidemux.org/smif/index.php/topic,17287.msg78085.html#msg78085 (http://avidemux.org/smif/index.php/topic,17287.msg78085.html#msg78085). Only in this case resume with

Code: [Select]
cd ~/avidemux2 && bash createDebFromSourceUbuntu.bash
If there are some "build*" folders but not the others, please post what

Code: [Select]
ls -d ~/avidemux2/build*
returns. This would allow to understand roughly which phase of the build failed. In this case, the next step would be to run

Code: [Select]
cd ~/avidemux2 && bash bootStrap.bash --deb 2>&1 | tee ~/adm-build.log
and once the build fails, compress and attach the "adm-build.log" text file (it may be too big to attach even if compressed). If it is impossible to attach the log, you'll have the choice either to open it (not compressed, of couse) in a text editor, find the place which describes the failure and post just that part, or upload it to some file hoster or the content to http://pastebin.com/ (http://pastebin.com/).

Please note that the command above only tries to build Avidemux, not to install the generated .deb packages on success yet.
Title: Re: Unable to load jpegs created in gimp.
Post by: Jan Gruuthuse on November 25, 2016, 07:27:30 AM
a successful build ends like this:
Quote
** Preparing debs **
Preparing packages
** debs directory ready **
total 10800
-rw-rw-r-- 1 jan jan    2460 nov 25 08:45 avidemux3-cli-2.6.15-161125-dev.deb
-rw-rw-r-- 1 jan jan 1594508 nov 25 08:45 avidemux3-cli-2.6.15-161125-runtime.deb
-rw-rw-r-- 1 jan jan  320956 nov 25 08:45 avidemux3-core-2.6.15-161125-dev.deb
-rw-rw-r-- 1 jan jan 3990972 nov 25 08:45 avidemux3-core-2.6.15-161125-runtime.deb
-rw-rw-r-- 1 jan jan   46998 nov 25 08:45 avidemux3-plugins-CLI-2.6.15-161125-plugins.deb
-rw-rw-r-- 1 jan jan 1520376 nov 25 08:45 avidemux3-plugins-COMMON-2.6.15-161125-plugins.deb
-rw-rw-r-- 1 jan jan  362862 nov 25 08:45 avidemux3-plugins-qt5-2.6.15-161125-plugins.deb
-rw-rw-r-- 1 jan jan    4810 nov 25 08:45 avidemux3-qt5-2.6.15-161125-dev.deb
-rw-rw-r-- 1 jan jan 3187314 nov 25 08:45 avidemux3-qt5-2.6.15-161125-runtime.deb
-rw-rw-r-- 1 jan jan    1946 nov 25 08:45 avidemux3-settings-2.6.15-161125-settings.deb
** ALL DONE **
** The installable packages are in the debs folder **
Installing avidemux...
Selecting previously unselected package avidemux3-cli-dev.
(Reading database ... 248023 files and directories currently installed.)
Preparing to unpack avidemux3-cli-2.6.15-161125-dev.deb ...
Unpacking avidemux3-cli-dev (2.6.15-161125) ...
Preparing to unpack avidemux3-cli-2.6.15-161125-runtime.deb ...
Unpacking avidemux3-cli-runtime (2.6.15-161125) over (2.6.15-161124) ...
Selecting previously unselected package avidemux3-core-dev.
Preparing to unpack avidemux3-core-2.6.15-161125-dev.deb ...
Unpacking avidemux3-core-dev (2.6.15-161125) ...
Preparing to unpack avidemux3-core-2.6.15-161125-runtime.deb ...
Unpacking avidemux3-core-runtime (2.6.15-161125) over (2.6.15-161124) ...
Preparing to unpack avidemux3-plugins-CLI-2.6.15-161125-plugins.deb ...
Unpacking avidemux3-plugins-cli-plugins (2.6.15-161125) over (2.6.15-161124) ...
Preparing to unpack avidemux3-plugins-COMMON-2.6.15-161125-plugins.deb ...
Unpacking avidemux3-plugins-common-plugins (2.6.15-161125) over (2.6.15-161124) ...
Preparing to unpack avidemux3-plugins-qt5-2.6.15-161125-plugins.deb ...
Unpacking avidemux3-plugins-qt5-plugins (2.6.15-161125) over (2.6.15-161124) ...
Selecting previously unselected package avidemux3-qt5-dev.
Preparing to unpack avidemux3-qt5-2.6.15-161125-dev.deb ...
Unpacking avidemux3-qt5-dev (2.6.15-161125) ...
Preparing to unpack avidemux3-qt5-2.6.15-161125-runtime.deb ...
Unpacking avidemux3-qt5-runtime (2.6.15-161125) over (2.6.15-161124) ...
Preparing to unpack avidemux3-settings-2.6.15-161125-settings.deb ...
Unpacking avidemux3-settings-settings (2.6.15-161125) over (2.6.15-161124) ...
Setting up avidemux3-core-dev (2.6.15-161125) ...
Setting up avidemux3-core-runtime (2.6.15-161125) ...
Setting up avidemux3-plugins-cli-plugins (2.6.15-161125) ...
Setting up avidemux3-plugins-common-plugins (2.6.15-161125) ...
Setting up avidemux3-plugins-qt5-plugins (2.6.15-161125) ...
Setting up avidemux3-qt5-dev (2.6.15-161125) ...
Setting up avidemux3-qt5-runtime (2.6.15-161125) ...
Setting up avidemux3-settings-settings (2.6.15-161125) ...
Setting up avidemux3-cli-dev (2.6.15-161125) ...
Setting up avidemux3-cli-runtime (2.6.15-161125) ...
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 03:37:21 PM
 avidemux3_qt4
No command 'avidemux3_qt4' found, did you mean:
 Command 'avidemux2_qt4' from package 'avidemux-qt' (multiverse)
avidemux3_qt4: command not found
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 03:40:18 PM
Here is a screenshot of the contents of the avidemux2 folder in my home folder...
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 03:50:07 PM
I apologize for taking up your time. From my perspective, I have spent four days trying to make this work using only the instructions I have gotten here. I have watched as you argue over how I should proceed, while not understanding what the argument is even about. Please don't expect me to understand something that is COMPLETELY NEW to me. I am proud of the fact that I was able to find the terminal. I understand this is hard for you too, but all I wanted to do is open a jpeg file. I had avidemux installed. I was able to load most files without any problem. Now I have only a file in my home folder that I don't understand, and a help forum that thinks I'm a jerk for asking them to actually help.
Is this how all noobs are helped?
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 04:35:37 PM
As you can see in the screenshot, there is a buildCore folder, and a foreignBuilds folder. The install folder is empty.
Title: Re: Unable to load jpegs created in gimp.
Post by: Jan Gruuthuse on November 25, 2016, 04:58:02 PM
Arguing? Providing information to you and each other. Figuring out what is going on. Eager to get this working on your computer.
in terminal:
Code: [Select]
bash --versionshould have some reply like
Quote
GNU bash, version ....

When you got reply that bash is installed, still in terminal:
Code: [Select]
cd ~/avidemux2
Code: [Select]
dirresponse should be:
Code: [Select]
addons      bootStrapHaikuOS.bash     createDebFromSourceUbuntu.bash
appImage      bootStrapOsx.bash        createRpmFromSourceFedora.bash
AUTHORS      bootStrapOsx_EC.bash      debs
autononreg      bootStrapOsx_qt5.bash     Doxyfile
avidemux      bootStrapOsx_Sierra.bash  foreignBuilds
avidemux2.desktop      bootStrapOsx_SL.bash      install
avidemux_core      buildCli        License.txt
avidemux_icon.png      buildCore        License.txt.in
avidemux_plugins      buildPluginsCLI        makeAppImage.sh
bootStrap.bash      buildPluginsCommon        man
bootStrapCrossMac106.sh      buildPluginsQt4        myOwnPlugins
bootStrapCrossMingw_w32Qt5_clang.sh  buildPluginsSettings      README
bootStrapCrossMingw_w32Qt5_mxe.sh    buildQt4        scripts
bootStrapCrossMingw_w32Qt5.sh      cmake        update_license.sh
bootStrapCrossMingw_w64Qt5.sh      COPYING

so you're now in the correct folder, still in terminal:
Code: [Select]
bash createDebFromSourceUbuntu.bashplenty of code should be scrolling along and should end similar to a successful build ends like this (http://avidemux.org/smif/index.php/topic,17287.msg78118.html#msg78118)







Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 05:04:15 PM
This means the build failed in early stages (maybe even just in the configuration part), i.e. we should proceed with

Code: [Select]
cd ~/avidemux2 && bash bootStrap.bash --deb 2>&1 | tee ~/adm-build.log
part to see actual error messages.

Please don't expect me to understand something that is COMPLETELY NEW to me. I am proud of the fact that I was able to find the terminal. I understand this is hard for you too, but all I wanted to do is open a jpeg file. I had avidemux installed. I was able to load most files without any problem. Now I have only a file in my home folder that I don't understand, and a help forum that thinks I'm a jerk for asking them to actually help.
Is this how all noobs are helped?

I'm sorry, but you receive opulent luxurious support just now. Please understand that we all started where you are now and evolved thanks to our own efforts while working in science, arts or whatever. Don't expect any sympathy for refusal to invest some time, effort and thought to learn something entirely new to you.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 05:16:52 PM
I appreciate your assistance. Please forgive my not understanding everything.
Here is my result.
bash createDebFromSourceUbuntu.bash
This will install all the necessary packages and build avidemux, it will take 20 mn or so
Please enter your password
[sudo] password for ogf:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libx265-dev
Compiling avidemux
bootStrap.bash: line 149: cmake: command not found
CMAKE Version :
Build configuration :
******************* :
Build type :
Release build
    Core will be built
     Gtk will be skipped
    Qt5 will be built
    Cli will be built
    Plugins will be built
**BootStrapping avidemux **
Top dir : /home/ogf/avidemux2
Fake installation directory=/home/ogf/avidemux2/install
Cleaning packages
** CORE **
Building buildCore from ../avidemux_core with EXTRA=<>, DEBUG=<>
bootStrap.bash: line 56: cmake: command not found
** Failed at cmakeZ**
Installing avidemux...
createDebFromSourceUbuntu.bash: line 13: cd: debs: No such file or directory
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 06:06:10 PM
This means some build dependencies are missing. Please first try to install cmake by running

Code: [Select]
sudo apt-get update
sudo apt-get install cmake

and post the output you get in the terminal from these two commands.

libx265-dev is only needed for being able to encode videos using the modern h265 codec. If your hardware is so old that it can't* run a 64 bit Linux distribution, then a missing x265 encoder is your last concern.

*) Would you mind actually posting the output of

Code: [Select]
lscpu
to learn the capabilities of the CPU please?
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 06:12:46 PM
sudo apt-get update
[sudo] password for ogf:
Ign http://packages.linuxmint.com rebecca InRelease
Ign http://extra.linuxmint.com rebecca InRelease                               
Hit http://packages.linuxmint.com rebecca Release.gpg                         
Hit http://extra.linuxmint.com rebecca Release.gpg                             
Ign http://ppa.launchpad.net trusty InRelease                                 
Ign http://archive.canonical.com trusty InRelease                             
Ign http://archive.ubuntu.com trusty InRelease                                 
Hit http://packages.linuxmint.com rebecca Release                             
Hit http://extra.linuxmint.com rebecca Release                                 
Hit http://ppa.launchpad.net trusty Release.gpg                               
Get:1 http://archive.ubuntu.com trusty-updates InRelease [65.9 kB]             
Hit http://packages.linuxmint.com rebecca/main i386 Packages                   
Hit http://extra.linuxmint.com rebecca/main i386 Packages                     
Hit http://ppa.launchpad.net trusty Release                                   
Hit http://packages.linuxmint.com rebecca/upstream i386 Packages               
Hit http://ppa.launchpad.net trusty/main Sources                               
Hit http://packages.linuxmint.com rebecca/import i386 Packages                 
Hit http://archive.canonical.com trusty Release.gpg                           
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://archive.canonical.com trusty Release                               
Hit http://archive.ubuntu.com trusty Release.gpg                               
Get:2 http://archive.ubuntu.com trusty-updates/main i386 Packages [880 kB]     
Get:3 http://security.ubuntu.com trusty-security InRelease [65.9 kB]           
Ign http://extra.linuxmint.com rebecca/main Translation-en_US                 
Ign http://extra.linuxmint.com rebecca/main Translation-en                     
Hit http://archive.canonical.com trusty/partner i386 Packages                 
Hit http://archive.canonical.com trusty/partner Translation-en                 
Get:4 http://security.ubuntu.com trusty-security/main i386 Packages [516 kB]   
Ign http://ppa.launchpad.net trusty/main Translation-en_US                     
Get:5 http://security.ubuntu.com trusty-security/restricted i386 Packages [13.1 kB]
Ign http://ppa.launchpad.net trusty/main Translation-en                       
Get:6 http://security.ubuntu.com trusty-security/universe i386 Packages [144 kB]
Get:7 http://security.ubuntu.com trusty-security/multiverse i386 Packages [4,289 B]
Hit http://security.ubuntu.com trusty-security/main Translation-en             
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en       
Hit http://security.ubuntu.com trusty-security/restricted Translation-en       
Ign http://packages.linuxmint.com rebecca/import Translation-en_US             
Hit http://security.ubuntu.com trusty-security/universe Translation-en       
Ign http://packages.linuxmint.com rebecca/import Translation-en               
Ign http://packages.linuxmint.com rebecca/main Translation-en_US
Ign http://packages.linuxmint.com rebecca/main Translation-en
Ign http://packages.linuxmint.com rebecca/upstream Translation-en_US
Ign http://packages.linuxmint.com rebecca/upstream Translation-en
Get:8 http://archive.ubuntu.com trusty-updates/restricted i386 Packages [16.2 kB]
Get:9 http://archive.ubuntu.com trusty-updates/universe i386 Packages [389 kB]
Get:10 http://archive.ubuntu.com trusty-updates/multiverse i386 Packages [14.5 kB]
Get:11 http://archive.ubuntu.com trusty-updates/main Translation-en [445 kB]   
Get:12 http://archive.ubuntu.com trusty-updates/multiverse Translation-en [7,340 B]
Get:13 http://archive.ubuntu.com trusty-updates/restricted Translation-en [3,842 B]
Get:14 http://archive.ubuntu.com trusty-updates/universe Translation-en [205 kB]
Hit http://archive.ubuntu.com trusty Release                                   
Hit http://archive.ubuntu.com trusty/main i386 Packages                       
Hit http://archive.ubuntu.com trusty/restricted i386 Packages                 
Hit http://archive.ubuntu.com trusty/universe i386 Packages                   
Hit http://archive.ubuntu.com trusty/multiverse i386 Packages                 
Hit http://archive.ubuntu.com trusty/main Translation-en                       
Hit http://archive.ubuntu.com trusty/multiverse Translation-en                 
Hit http://archive.ubuntu.com trusty/restricted Translation-en                 
Hit http://archive.ubuntu.com trusty/universe Translation-en                   
Ign http://archive.ubuntu.com trusty/main Translation-en_US                   
Ign http://archive.ubuntu.com trusty/multiverse Translation-en_US             
Ign http://archive.ubuntu.com trusty/restricted Translation-en_US             
Ign http://archive.ubuntu.com trusty/universe Translation-en_US               
Fetched 2,770 kB in 15s (178 kB/s)                                             
Reading package lists... Done
ogf@freekbox:~/avidemux2$ sudo apt-get install cmake
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  avidemux-common libavidemux0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  cmake-data libcurl3
Suggested packages:
  codeblocks eclipse
The following NEW packages will be installed:
  cmake cmake-data libcurl3
0 upgraded, 3 newly installed, 0 to remove and 175 not upgraded.
Need to get 3,492 kB of archives.
After this operation, 17.1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libcurl3 i386 7.35.0-1ubuntu2.10 [175 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty/main cmake-data all 2.8.12.2-0ubuntu3 [676 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ trusty/main cmake i386 2.8.12.2-0ubuntu3 [2,641 kB]
Fetched 3,492 kB in 3s (1,106 kB/s)
Selecting previously unselected package libcurl3:i386.
(Reading database ... 174339 files and directories currently installed.)
Preparing to unpack .../libcurl3_7.35.0-1ubuntu2.10_i386.deb ...
Unpacking libcurl3:i386 (7.35.0-1ubuntu2.10) ...
Selecting previously unselected package cmake-data.
Preparing to unpack .../cmake-data_2.8.12.2-0ubuntu3_all.deb ...
Unpacking cmake-data (2.8.12.2-0ubuntu3) ...
Selecting previously unselected package cmake.
Preparing to unpack .../cmake_2.8.12.2-0ubuntu3_i386.deb ...
Unpacking cmake (2.8.12.2-0ubuntu3) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libcurl3:i386 (7.35.0-1ubuntu2.10) ...
Setting up cmake-data (2.8.12.2-0ubuntu3) ...
Setting up cmake (2.8.12.2-0ubuntu3) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
ogf@freekbox:~/avidemux2$ lscpu
Architecture:          i686
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 15
Stepping:              6
CPU MHz:               1000.000
BogoMIPS:              4324.52
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              4096K
ogf@freekbox:~/avidemux2$ lscpu
Architecture:          i686
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 15
Stepping:              6
CPU MHz:               2167.000
BogoMIPS:              4324.52
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              4096K
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 06:27:59 PM
Thanks, a good catch: you must uninstall avidemux-common and libavidemux0 from the outdated ubuntu-provided package. Try the earlier command to build avidemux again.

You CPU is fully 64 bit compatible. I'd recommend you install a more up-to-date 64 bit Linux distribution.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 06:32:16 PM
Try the earlier command to build avidemux again.
This one?

ls -d ~/avidemux2/build*
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 07:50:11 PM
No, that one just lists some content from the avidemux2 folder. The next one would be right, but we should first remove the libx265-dev entry which fails on Mint Rebecca and causes the subsequent failure of everything. Please open the createDebFromSourceUbuntu.bash file in a text editor (e.g. gedit; not LibreOffice Writer or such) and delete the offending entry, save the file and only then run

Code: [Select]
cd ~/avidemux2 && bash bootStrap.bash --deb 2>&1 | tee ~/adm-build.log
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 07:56:25 PM
cd ~/avidemux2 && bash bootStrap.bash --deb 2>&1 | tee ~/adm-build.log
CMAKE Version : 2.8.12
Cmake version >=2.8.7 doesnt need fakeroot
Build configuration :
******************* :
Build type :
Release build
    Core will be built
     Gtk will be skipped
    Qt5 will be built
    Cli will be built
    Plugins will be built
**BootStrapping avidemux **
Top dir : /home/ogf/avidemux2
Fake installation directory=/home/ogf/avidemux2/install
Cleaning packages
** CORE **
Building buildCore from ../avidemux_core with EXTRA=<>, DEBUG=<>
-- The C compiler identification is GNU 4.8.4
-- The CXX compiler identification is unknown
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.

#########################################
Configure for avidemux core libs Started
#########################################

-- [BUILD] EXTRA Cflags:
-- [BUILD] EXTRA CXXflags:
-- [BUILD] EXTRA LDflags:
-- [BUILD] Compiler CMAKE_CXX_COMPILER-NOTFOUND
-- [BUILD] Linker   /usr/bin/ld
-- Top Source dir is /home/ogf/avidemux2/avidemux_core/..

CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.

-- Checking Compiler support
-- *************************
CMake Error at /usr/share/cmake-2.8/Modules/CMakeCXXInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
CMake Error at /usr/share/cmake-2.8/Modules/CMakeCXXInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
CMake Error at /usr/share/cmake-2.8/Modules/CMakeCXXInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
CMake Error at /usr/share/cmake-2.8/Modules/CMakeCXXInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
CMake Error at /home/ogf/avidemux2/cmake/admDetermineSystem.cmake:78 (MESSAGE):
  CPU not supported
Call Stack (most recent call first):
  /home/ogf/avidemux2/cmake/admMainChecks.cmake:73 (INCLUDE)
  CMakeLists.txt:28 (include)


-- Configuring incomplete, errors occurred!
See also "/home/ogf/avidemux2/buildCore/CMakeFiles/CMakeOutput.log".
See also "/home/ogf/avidemux2/buildCore/CMakeFiles/CMakeError.log".
** Failed at cmakeZ**
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 08:02:46 PM
I'm sorry, I meant running

Code: [Select]
cd ~/avidemux2 && bash createDebFromSourceUbuntu.bash 2>&1 | tee ~/adm-build.log
(edited... struggling with a tiny smartphone display)
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 08:29:49 PM
-- Configuring done
-- Generating done
-- Build files have been written to: /home/ogf/avidemux2/buildQt5
** Failed at make, result in /tmp/logbuildQt5**
Installing avidemux...
createDebFromSourceUbuntu.bash: line 13: cd: debs: No such file or directory
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 09:48:45 PM
Great, at least the core libs have been built. Now it is the Qt5 interface which fails. We'll investigate this in a few minutes. Meanwhile you would help a lot if you compress (.tar.bz2) and attach the file logbuildQt5 from the /tmp folder.

Please note that this is only possible if you haven't rebooted since that build attempt: all files in /tmp get usually deleted during a shutdown/reboot sequence.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 09:52:53 PM
Quote
compress (.tar.bz2) and attach the file logbuildQt5 from the /tmp folder.

I have not rebooted, but I have no idea how to do what you suggest.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 10:07:39 PM
The command line way to do this would be

Code: [Select]
tar -cvjf ~/logbuildQt5.tar.bz2 /tmp/logbuildQt5
and attach the "logbuildQt5.tar.bz2" file from your home directory.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 10:12:51 PM
The command line way to do this would be

Code: [Select]
tar -cvjf ~/logbuildQt5.tar.bz2 /tmp/logbuildQt5
and attach the "logbuildQt5.tar.bz2" file from your home directory.
I understand the first part, but how do I 'attach the "logbuildQt5.tar.bz2" file from your home directory.'?
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 10:26:36 PM
While writing your reply, please pay attention to "Attachments and other options" link below the text input. Click on it.

Meanwhile, I would like to find out which build dependencies are installed and which are missing:

Code: [Select]
dpkg -l gcc g++ make cmake pkg-config libpng12-dev fakeroot yasm libsqlite3-dev  build-essential  qttools5-dev-tools qtbase5-dev libaften-dev libmp3lame-dev libx264-dev  libfaad-dev libfaac-dev libvdpau-dev libx265-dev libopus-dev libvorbis-dev libogg-dev libfribidi-dev libfontconfig1-dev libxv-dev libpulse-dev libdca-dev
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 10:45:10 PM
By the way, I'll have very little time for Avidemux support tomorrow. It would be preferable to solve the build problem today.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 10:56:03 PM
dpkg -l gcc g++ make cmake pkg-config libpng12-dev fakeroot yasm libsqlite3-dev  build-essential  qttools5-dev-tools qtbase5-dev libaften-dev libmp3lame-dev libx264-dev  libfaad-dev libfaac-dev libvdpau-dev libx265-dev libopus-dev libvorbis-dev libogg-dev libfribidi-dev libfontconfig1-dev libxv-dev libpulse-dev libdca-dev
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
ii  build-essentia 11.6ubuntu6  i386         Informational list of build-essen
ii  cmake          2.8.12.2-0ub i386         cross-platform, open-source make
ii  fakeroot       1.20-3ubuntu i386         tool for simulating superuser pri
ii  g++            4:4.8.2-1ubu i386         GNU C++ compiler
ii  gcc            4:4.8.2-1ubu i386         GNU C compiler
ii  libaften-dev   0.0.8+git201 i386         audio AC3 encoder - development f
ii  libdca-dev:i38 0.0.5-6ubunt i386         decoding library for DTS Coherent
ii  libfaac-dev:i3 1.28-6       i386         AAC audio encoder (development)
ii  libfaad-dev:i3 2.7-8        i386         freeware Advanced Audio Decoder -
ii  libfontconfig1 2.11.0-0ubun i386         generic font configuration librar
ii  libfribidi-dev 0.19.6-1     i386         Development files for FreeBidi li
ii  libmp3lame-dev 3.99.5+repac i386         MP3 encoding library (development
ii  libogg-dev:i38 1.3.1-1ubunt i386         Ogg bitstream library development
ii  libopus-dev    1.1-0ubuntu1 i386         Opus codec library development fi
ii  libpng12-dev   1.2.50-1ubun i386         PNG library - development
ii  libpulse-dev:i 1:4.0-0ubunt i386         PulseAudio client development hea
ii  libsqlite3-dev 3.8.2-1ubunt i386         SQLite 3 development files
ii  libvdpau-dev:i 0.7-1ubuntu0 i386         Video Decode and Presentation API
ii  libvorbis-dev: 1.3.2-1.3ubu i386         The Vorbis General Audio Compress
ii  libx264-dev:i3 2:0.142.2389 i386         development files for libx264
ii  libxv-dev:i386 2:1.0.10-1   i386         X11 Video extension library (deve
ii  make           3.81-8.2ubun i386         An utility for Directing compilat
ii  pkg-config     0.26-1ubuntu i386         manage compile and link flags for
ii  qtbase5-dev:i3 5.2.1+dfsg-1 i386         Qt 5 base development files
ii  qttools5-dev-t 5.2.1-8build i386         Qt 5 development tools
ii  yasm           1.2.0-1ubunt i386         modular assembler with multiple s
dpkg-query: no packages found matching libx265-dev
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 10:57:31 PM
tar -cvjf ~/logbuildQt5.tar.bz2 /tmp/logbuildQt5
tar: Removing leading `/' from member names
/tmp/logbuildQt5
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 11:07:32 PM
Thank you, all the build dependencies from the script (except libx265, but this doesn't matter) are there, the build fails at

Code: [Select]
In file included from /home/ogf/avidemux2/avidemux/qt4/ADM_openGL/src/ADM_openGl.cpp:6:0:
/home/ogf/avidemux2/avidemux/qt4/ADM_openGL/src/../include/ADM_openGl.h:40:29: fatal error: QtOpenGL/QtOpenGL: No such file or directory
 #include <QtOpenGL/QtOpenGL>
                             ^
compilation terminated.

where the compiler can't find the file /usr/include/qt5/QtOpenGL/QtOpenGL which belongs to package libqt5opengl5-dev which is missing in the script! Please proceed with

Code: [Select]
sudo apt-get install libqt5opengl5-dev
then run

Code: [Select]
cd ~/avidemux2 && bash bootStrap.bash --deb --rebuild 2>&1 | tee ~/adm-build.log
(edit: added "--deb" option)
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 11:12:13 PM
Actually, you've found a bug in the script  :)
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 11:21:24 PM
[ 81%] Built target ADM_UI_Cli6
make -f common/ADM_videoFilter2/src/CMakeFiles/ADM_internalVideoFilter6.dir/build.make common/ADM_videoFilter2/src/CMakeFiles/ADM_internalVideoFilter6.dir/depend
make[2]: Entering directory `/home/ogf/avidemux2/buildCli'
cd /home/ogf/avidemux2/buildCli && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /home/ogf/avidemux2/avidemux/cli /home/ogf/avidemux2/avidemux/common/ADM_videoFilter2/src /home/ogf/avidemux2/buildCli /home/ogf/avidemux2/buildCli/common/ADM_videoFilter2/src /home/ogf/avidemux2/buildCli/common/ADM_videoFilter2/src/CMakeFiles/ADM_internalVideoFilter6.dir/DependInfo.cmake --color=
make[2]: Leaving directory `/home/ogf/avidemux2/buildCli'
make -f common/ADM_videoFilter2/src/CMakeFiles/ADM_internalVideoFilter6.dir/build.make common/ADM_videoFilter2/src/CMakeFiles/ADM_internalVideoFilter6.dir/build
make[2]: Entering directory `/home/ogf/avidemux2/buildCli'
make[2]: Nothing to be done for `common/ADM_videoFilter2/src/CMakeFiles/ADM_internalVideoFilter6.dir/build'.
make[2]: Leaving directory `/home/ogf/avidemux2/buildCli'
/usr/bin/cmake -E cmake_progress_report /home/ogf/avidemux2/buildCli/CMakeFiles  66 67 68 69
[ 85%] Built target ADM_internalVideoFilter6
make -f common/ADM_script2/src/CMakeFiles/ADM_script6.dir/build.make common/ADM_script2/src/CMakeFiles/ADM_script6.dir/depend
make[2]: Entering directory `/home/ogf/avidemux2/buildCli'
cd /home/ogf/avidemux2/buildCli && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /home/ogf/avidemux2/avidemux/cli /home/ogf/avidemux2/avidemux/common/ADM_script2/src /home/ogf/avidemux2/buildCli /home/ogf/avidemux2/buildCli/common/ADM_script2/src /home/ogf/avidemux2/buildCli/common/ADM_script2/src/CMakeFiles/ADM_script6.dir/DependInfo.cmake --color=
make[2]: Leaving directory `/home/ogf/avidemux2/buildCli'
make -f common/ADM_script2/src/CMakeFiles/ADM_script6.dir/build.make common/ADM_script2/src/CMakeFiles/ADM_script6.dir/build
make[2]: Entering directory `/home/ogf/avidemux2/buildCli'
make[2]: Nothing to be done for `common/ADM_script2/src/CMakeFiles/ADM_script6.dir/build'.
make[2]: Leaving directory `/home/ogf/avidemux2/buildCli'
/usr/bin/cmake -E cmake_progress_report /home/ogf/avidemux2/buildCli/CMakeFiles  76
[ 86%] Built target ADM_script6
make -f ADM_userInterfacesCli/ADM_shell/CMakeFiles/ADM_shellCli.dir/build.make ADM_userInterfacesCli/ADM_shell/CMakeFiles/ADM_shellCli.dir/depend
make[2]: Entering directory `/home/ogf/avidemux2/buildCli'
cd /home/ogf/avidemux2/buildCli && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /home/ogf/avidemux2/avidemux/cli /home/ogf/avidemux2/avidemux/cli/ADM_userInterfaces/ADM_shell /home/ogf/avidemux2/buildCli /home/ogf/avidemux2/buildCli/ADM_userInterfacesCli/ADM_shell /home/ogf/avidemux2/buildCli/ADM_userInterfacesCli/ADM_shell/CMakeFiles/ADM_shellCli.dir/DependInfo.cmake --color=
make[2]: Leaving directory `/home/ogf/avidemux2/buildCli'
make -f ADM_userInterfacesCli/ADM_shell/CMakeFiles/ADM_shellCli.dir/build.make ADM_userInterfacesCli/ADM_shell/CMakeFiles/ADM_shellCli.dir/build
make[2]: Entering directory `/home/ogf/avidemux2/buildCli'
make[2]: Nothing to be done for `ADM_userInterfacesCli/ADM_shell/CMakeFiles/ADM_shellCli.dir/build'.
make[2]: Leaving directory `/home/ogf/avidemux2/buildCli'
/usr/bin/cmake -E cmake_progress_report /home/ogf/avidemux2/buildCli/CMakeFiles  77
[ 87%] Built target ADM_shellCli
make -f CMakeFiles/avidemux3_cli.dir/build.make CMakeFiles/avidemux3_cli.dir/depend
make[2]: Entering directory `/home/ogf/avidemux2/buildCli'
cd /home/ogf/avidemux2/buildCli && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /home/ogf/avidemux2/avidemux/cli /home/ogf/avidemux2/avidemux/cli /home/ogf/avidemux2/buildCli /home/ogf/avidemux2/buildCli /home/ogf/avidemux2/buildCli/CMakeFiles/avidemux3_cli.dir/DependInfo.cmake --color=
make[2]: Leaving directory `/home/ogf/avidemux2/buildCli'
make -f CMakeFiles/avidemux3_cli.dir/build.make CMakeFiles/avidemux3_cli.dir/build
make[2]: Entering directory `/home/ogf/avidemux2/buildCli'
make[2]: Nothing to be done for `CMakeFiles/avidemux3_cli.dir/build'.
make[2]: Leaving directory `/home/ogf/avidemux2/buildCli'
/usr/bin/cmake -E cmake_progress_report /home/ogf/avidemux2/buildCli/CMakeFiles  88 89 90 91 92 93 94 95 96 97 98 99 100
[100%] Built target avidemux3_cli
make[1]: Leaving directory `/home/ogf/avidemux2/buildCli'
/usr/bin/cmake -E cmake_progress_start /home/ogf/avidemux2/buildCli/CMakeFiles 0
make -f CMakeFiles/Makefile2 preinstall
make[1]: Entering directory `/home/ogf/avidemux2/buildCli'
make[1]: Nothing to be done for `preinstall'.
make[1]: Leaving directory `/home/ogf/avidemux2/buildCli'
Install the project...
/usr/bin/cmake -P cmake_install.cmake
-- Install configuration: "Release"
-- Installing: /home/ogf/avidemux2/install/usr/bin/avidemux3_cli
-- Removed runtime path from "/home/ogf/avidemux2/install/usr/bin/avidemux3_cli"
-- Installing: /home/ogf/avidemux2/install/usr/include/avidemux/2.6/cli/config.h
-- Installing: /home/ogf/avidemux2/install/usr/include/avidemux/2.6/cli/ADM_UIs/DIA_flyDialogCli.h
-- Installing: /home/ogf/avidemux2/install/usr/include/avidemux/2.6/cli/ADM_UIs/ADM_UI_Cli6_export.h
-- Installing: /home/ogf/avidemux2/install/usr/lib/libADM_render6_cli.so
-- Removed runtime path from "/home/ogf/avidemux2/install/usr/lib/libADM_render6_cli.so"
-- Installing: /home/ogf/avidemux2/install/usr/lib/libADM_UI_Cli6.so
-- Removed runtime path from "/home/ogf/avidemux2/install/usr/lib/libADM_UI_Cli6.so"
 Installing cli
** Plugins **
Building buildPluginsCommon from ../avidemux_plugins with EXTRA=<-DPLUGIN_UI=COMMON>, DEBUG=<>
-- The C compiler identification is GNU 4.8.4
-- The CXX compiler identification is GNU 4.8.4
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done

#####################################
Plugins Configure Started
#####################################

-- Checking for avidemux development files ..
-- Checking for avidemux include folder (i.e. CMAKE_INSTALL_PREFIX/include/avidemux/2.6, looking in /home/ogf/avidemux2/install//usr/include/avidemux/2.6
-- Found avidemux include folder. good.
-- Checking for cmake subfolder
-- Found cmake subfolder.good.
-- Cmake module path = /home/ogf/avidemux2/install//usr/include/avidemux/2.6/cmake;/home/ogf/avidemux2/install//usr/include/avidemux/2.6/cmake;
-- [BUILD] EXTRA Cflags:
-- [BUILD] EXTRA CXXflags:
-- [BUILD] EXTRA LDflags:
-- [BUILD] Compiler /usr/bin/c++
-- [BUILD] Linker   /usr/bin/ld
-- Top Source dir is

-- Checking Compiler support
-- *************************
-- Checking if compiler supports x86 32-bit - Yes
-- Check if the system is big endian
-- Searching 16 bit integer
-- Looking for sys/types.h
-- Looking for sys/types.h - found
-- Looking for stdint.h
-- Looking for stdint.h - found
-- Looking for stddef.h
-- Looking for stddef.h - found
-- Check size of unsigned short
-- Check size of unsigned short - done
-- Using unsigned short
-- Check if the system is big endian - little endian

-- CMAKE_INSTALL_PREFIX: /usr
-- AVIDEMUX_INSTALL_DIR: /usr
-- FAKEROOT                   : /home/ogf/avidemux2/install/
-- AVIDEMUX_BIN_DIR           : /usr/bin
-- AVIDEMUX_LIB_DIR           : /usr/lib
-- AVIDEMUX_INCLUDE_DIR       : /usr/include
-- AVIDEMUX_SEARCH_INCLUDE_DIR: /home/ogf/avidemux2/install//usr/include
-- AVIDEMUX_SEARCH_LIB_DIR    : /home/ogf/avidemux2/install//usr/lib

-- Checking for SCM
-- ****************
-- Seems to be git or git-svn...
-- Getting git-svn version from /home/ogf/avidemux2/avidemux_plugins
-- Top dir is </home/ogf/avidemux2
/home/ogf/avidemux2/avidemux_plugins>
-- <4f1eb5a4a7f><161125>==> 161125_4f1eb5a4a7f

-- Checking for pkg-config
-- ***********************
-- Found PkgConfig: /usr/bin/pkg-config (found version "0.26")
-- Found pkg-config

-- Checking for pthreads
-- *********************
-- Found pthreads

-- Checking for zlib
-- *****************
-- Found ZLIB: /usr/lib/i386-linux-gnu/libz.so (found version "1.2.8")
-- Found zlib

-- Checking system headers
-- ***********************
-- Looking for gettimeofday
-- Looking for gettimeofday - found
-- Looking for include file inttypes.h
-- Looking for include file inttypes.h - found

-- AVFORMAT : 57, Major :
-- AVCODEC  : 57, Major :
-- AVUTIL   : 55, Major :
-- POSTPRC  : 54, Major :
-- SWSCALE  : 4, Major :

-- CMAKE_INSTALL_PREFIX: /usr
-- AVIDEMUX_INSTALL_DIR: /usr
-- FAKEROOT                   : /home/ogf/avidemux2/install/
-- AVIDEMUX_BIN_DIR           : /usr/bin
-- AVIDEMUX_LIB_DIR           : /usr/lib
-- AVIDEMUX_INCLUDE_DIR       : /usr/include
-- AVIDEMUX_SEARCH_INCLUDE_DIR: /home/ogf/avidemux2/install//usr/include
-- AVIDEMUX_SEARCH_LIB_DIR    : /home/ogf/avidemux2/install//usr/lib
-- Plugin UI : COMMON

-- Checking for FAAD
-- *****************
-- Found faad.h
-- Found faad library
-- Could not find faacDecInit in /usr/lib/i386-linux-gnu/libfaad.so
-- Change Dir: /home/ogf/avidemux2/buildPluginsCommon/CMakeFiles/CMakeTmp

Run Build Command:/usr/bin/make "cmTryCompileExec1361144314/fast"
/usr/bin/make -f CMakeFiles/cmTryCompileExec1361144314.dir/build.make CMakeFiles/cmTryCompileExec1361144314.dir/build
make[1]: Entering directory `/home/ogf/avidemux2/buildPluginsCommon/CMakeFiles/CMakeTmp'
/usr/bin/cmake -E cmake_progress_report /home/ogf/avidemux2/buildPluginsCommon/CMakeFiles/CMakeTmp/CMakeFiles 1
Building C object CMakeFiles/cmTryCompileExec1361144314.dir/CheckFunctionExists.c.o
/usr/bin/cc  -DCHECK_FUNCTION_EXISTS=faacDecInit -fmessage-length=0 -fmessage-length=0    -I"/usr/include" -o CMakeFiles/cmTryCompileExec1361144314.dir/CheckFunctionExists.c.o   -c /home/ogf/avidemux2/install/usr/include/avidemux/2.6/cmake/cmake_compile_check/CheckFunctionExists.c
Linking C executable cmTryCompileExec1361144314
/usr/bin/cmake -E cmake_link_script CMakeFiles/cmTryCompileExec1361144314.dir/link.txt --verbose=1
/usr/bin/cc   -fmessage-length=0 -fmessage-length=0     CMakeFiles/cmTryCompileExec1361144314.dir/CheckFunctionExists.c.o  -o cmTryCompileExec1361144314 -rdynamic -lfaad
CMakeFiles/cmTryCompileExec1361144314.dir/CheckFunctionExists.c.o: In function `main':
CheckFunctionExists.c:(.text+0x7): undefined reference to `faacDecInit'
collect2: error: ld returned 1 exit status
make[1]: *** [cmTryCompileExec1361144314] Error 1
make[1]: Leaving directory `/home/ogf/avidemux2/buildPluginsCommon/CMakeFiles/CMakeTmp'
make: *** [cmTryCompileExec1361144314/fast] Error 2

-- Found NeAACDecInit in /usr/lib/i386-linux-gnu/libfaad.so
-- Found FAAD
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libfaad.so
-- (-DOLD_FAAD_PROTO) required

-- Checking for LIBVORBIS
-- *******************
-- Found vorbis/codec.h
-- Found vorbis library
-- Found vorbis_synthesis_init in /usr/lib/i386-linux-gnu/libvorbis.so
-- Found LIBVORBIS
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libvorbis.so

-- Checking for libdca
-- *******************
-- Trying libdca 0.5
-- Found dca.h
-- Found dca library
-- Found dca_init in /usr/lib/i386-linux-gnu/libdca.so
-- Found libdca
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libdca.so

-- Checking for opencore-amrwb
-- ***************************
Could not find opencore-amrwb/dec_if.h
Could not find opencore-amrwb

-- Checking for opencore-amrnb
-- ***************************
Could not find opencore-amrnb/interf_dec.h
Could not find opencore-amrnb

-- Checking for OPUS
-- *****************
-- Found opus/opus.h
-- Found opus library
-- Found opus_decoder_init in /usr/lib/i386-linux-gnu/libopus.so
-- Found LIBOPUS
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libopus.so
-- Checking for ALSA
-- *****************
-- Looking for snd_seq_create_simple_port in asound
-- Looking for snd_seq_create_simple_port in asound - not found
-- ALSA not found

-- Checking for aRts
-- *****************
Could not find aRts

-- Checking for ESD
-- ****************
Could not find esd.h
Could not find ESD

-- Checking for JACK
-- *****************
Could not find jack/jack.h
Could not find JACK

-- Checking for OSS
-- ****************
-- Found sys/soundcard.h
-- Found OSS
-- Compiler Flags: /usr/include/i386-linux-gnu
-- Linker Flags  :

-- Checking for PULSEAUDIOSIMPLE
-- *****************************
-- checking for module 'libpulse-simple'
--   found libpulse-simple, version 4.0
-- Found PulseAudio Simple: pulse-simple;pulse
-- HACK : we need both libpulse and libpulse-simple when using -W-l,-z,defs

-- Checking for Vpx
-- *****************
Could not find vpx/vpx_decoder.h
Could not find Vpx

-- Checking for Aften
-- ******************
-- Found aften/aften.h
-- Found aften library
-- Found aften_encode_init in /usr/lib/libaften.so
-- Found Aften
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/libaften.so

-- Checking for TWOLAME
-- *****************
Could not find twolame.h
Could not find TWOLAME

-- Checking for LAME
-- *****************
-- Found lame/lame.h
-- Found mp3lame library
-- Found lame_init in /usr/lib/i386-linux-gnu/libmp3lame.so
-- Found LAME
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libmp3lame.so

-- Checking for DCAENC
-- *******************
Could not find dcaenc.h
Could not find DCAENC

-- Checking for FAAC
-- *****************
-- Found faac.h
-- Found faac library
-- Found faacEncClose in /usr/lib/i386-linux-gnu/libfaac.so
-- Found FAAC
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libfaac.so

-- Checking for FDK_AAC
-- *****************
Could not find fdk-aac/aacenc_lib.h
Could not find FDK_AAC


-- Checking for Vorbis
-- *******************
-- Found vorbis/vorbisenc.h
-- Found vorbis library
-- Found vorbis_info_init in /usr/lib/i386-linux-gnu/libvorbis.so
-- Found vorbisenc library
-- Found vorbis_encode_init in /usr/lib/i386-linux-gnu/libvorbisenc.so
-- Found Vorbis
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libvorbis.so /usr/lib/i386-linux-gnu/libvorbisenc.so

-- Checking for VAPOURSYNTH
-- ***********************
-- checking for module 'vapoursynth-script'
--   package 'vapoursynth-script' not found

-- Checking for Xvid
-- *****************
Could not find xvid.h
Could not find Xvid

-- Checking for x264
-- *****************
-- Found x264.h
--   core version: 142
-- Found x264.h
-- Found x264 library
-- Found x264_encoder_open_142 in /usr/lib/i386-linux-gnu/libx264.so
-- Found x264
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libx264.so

-- x264 plugin activated.
-- Checking for x265
-- *****************
Could not find x265.h
Could not find x265_config.h
--   No working version found
Could not find x265

-- x265 disabled.
-- Checking for FreeType2
-- **********************
-- checking for module 'freetype2'
--   found freetype2, version 17.1.11
-- Found FreeType2
-- Compiler Flags: -I/usr/include/freetype2
-- Linker Flags  : -lfreetype

-- Checking for libiconv
-- *********************
-- Found iconv.h
-- Cound not find iconv library
Could not find libiconv
-- libiconv is probably not needed

-- Checking for FontConfig
-- ***********************
-- checking for module 'fontconfig'
--   found fontconfig, version 2.11.0
-- Found FontConfig
-- Compiler Flags: -I/usr/include/freetype2
-- Linker Flags  : -lfontconfig -lfreetype

-- Checking for Fridibi (want 0.19)
-- **************************************
-- checking for module 'fribidi'
--   found fribidi, version 0.19.6
-- Found Fribidi
-- Compiler Flags: -I/usr/include/fribidi
-- Linker Flags  : -lfribidi
-- Fridibi version 0.19.6

-- Yasm found as /usr/bin/yasm
-- The ASM_YASM compiler identification is unknown
-- Found assembler: /usr/bin/yasm

**************************
***  Optional Library  ***
***      Summary       ***
**************************
*** Video Encoder      ***
    Xvid           No
    x264           Yes
    x265           No
*** Scripting          ***
    TinyPy         Yes
*** Miscellaneous      ***
    VapourSynth    No
    FreeType2      Yes
    FontConfig     Yes
    FRIBIDI        Yes
    FontConfig     Yes
*** Audio Encoder      ***
    Aften          Yes
    TWOLAME        No
    LAME           Yes
    DCAENC         No
    FAAC           Yes
    FDK_AAC        No
    Vorbis         Yes
*** Video Decoder      ***
    libvpx         No
*** Audio Device       ***
    ALSA           No
    aRts           No
    ESD            No
    JACK           No
    OSS            Yes
    PulseAudio     Yes
*** Audio Decoder      ***
    FAAD           Yes
    Vorbis         Yes
    libdca         Yes
    opencore-amrwb No
    opencore-amrnb No
    Opus           Yes
*** User Interface     ***
    Common         Yes
    GTK+           No
    Qt 4           No
    CLI            No
**************************
***   Release Build    ***
**************************

-- Packager=deb, valid choices= {deb,rpm,tgz,none}
-- Checking if we have USE_FAAD set
--       yes
-- Checking if we have USE_VORBIS set
--       yes
-- Checking if we have USE_LIBOPUS set
--       yes
-- Checking if we have USE_LAME set
--       yes
-- Checking if we have USE_FAAC set
--       yes
-- Checking if we have USE_AFTEN set
--       yes
-- Checking if we have USE_XVID set
--       no

-- Configuring done
-- Generating done
CMake Warning:
  Manually-specified variables were not used by the project:

    ENABLE_QT5


-- Build files have been written to: /home/ogf/avidemux2/buildPluginsCommon
** Failed at make, result in /tmp/logbuildPluginsCommon**
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 11:25:39 PM
Big progress! Please run

Code: [Select]
tar -cvjf ~/logbuildPluginsCommon.tar.bz2 /tmp/logbuildPluginsCommon
and attach logbuildPluginsCommon.tar.bz2.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 11:27:19 PM
tar -cvjf ~/logbuildPluginsCommon.tar.bz2 /tmp/logbuildPluginsCommon
tar: Removing leading `/' from member names
/tmp/logbuildPluginsCommon
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 11:38:11 PM
This time the problem is rather serious:

Code: [Select]
/usr/bin/c++  -fPIC  -fmessage-length=0 -fmessage-length=0 -O3 -DNDEBUG   -shared -Wl,-soname,libADM_ae_lav_aac.so -o libADM_ae_lav_aac.so CMakeFiles/ADM_ae_lav_aac.dir/audioencoder_lavcodec.cpp.o  -L/home/ogf/avidemux2/install/usr/lib -Wl,--as-needed -Wl,-z,defs -lstdc++ /home/ogf/avidemux2/install//usr/lib/libADM6avcodec.so.57 /home/ogf/avidemux2/install//usr/lib/libADM6avutil.so.55 -lADM_core6 -lADM_coreUI6 -lADM_coreAudio6 -lADM_coreAudioEncoder6 -lADM_coreUtils6 -lm -Wl,-rpath,/home/ogf/avidemux2/install/usr/lib:
/usr/lib/i386-linux-gnu/libc_nonshared.a(stack_chk_fail_local.oS): In function `__stack_chk_fail_local':
(.text+0x10): undefined reference to `__stack_chk_fail'
collect2: error: ld returned 1 exit status
make[2]: *** [ADM_audioEncoders/lavcodec/libADM_ae_lav_aac.so] Error 1

Investigating what can be done here.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 11:47:10 PM
Thanks.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 25, 2016, 11:47:58 PM
Okay, please try the following (untested, of course): in the "avidemux2" folder go into the subfolder "cmake", open the file admAsNeeded.cmake in gedit (or in an equivalent text editor) and replace at the line 13

Code: [Select]
TARGET_LINK_LIBRARIES( ${name} "-Wl,-z,defs")
with

Code: [Select]
TARGET_LINK_LIBRARIES( ${name} "-lc,-Wl,-z,defs")
save the file and re-run

Code: [Select]
cd ~/avidemux2 && bash bootStrap.bash --deb --rebuild 2>&1 | tee ~/adm-build.log
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 25, 2016, 11:57:52 PM
cd ~/avidemux2 && bash bootStrap.bash --deb --rebuild 2>&1 | tee ~/adm-build.log
CMAKE Version : 2.8.12
Cmake version >=2.8.7 doesnt need fakeroot
Build configuration :
******************* :
Build type :
Release build
    Core will be built
     Gtk will be skipped
    Qt5 will be built
    Cli will be built
    Plugins will be built
**BootStrapping avidemux **
Top dir : /home/ogf/avidemux2
Fake installation directory=/home/ogf/avidemux2/install
Cleaning packages
** CORE **
Building buildCore from ../avidemux_core with EXTRA=<>, DEBUG=<>

#########################################
Configure for avidemux core libs Started
#########################################

-- [BUILD] EXTRA Cflags:
-- [BUILD] EXTRA CXXflags:
-- [BUILD] EXTRA LDflags:
-- [BUILD] Compiler /usr/bin/c++
-- [BUILD] Linker   /usr/bin/ld
-- Top Source dir is /home/ogf/avidemux2/avidemux_core/..

-- Checking Compiler support
-- *************************
-- Checking if compiler supports x86 32-bit - Yes

-- CMAKE_INSTALL_PREFIX: /usr
-- AVIDEMUX_INSTALL_DIR: /usr
-- FAKEROOT                   : /home/ogf/avidemux2/install/
-- AVIDEMUX_BIN_DIR           : /usr/bin
-- AVIDEMUX_LIB_DIR           : /usr/lib
-- AVIDEMUX_INCLUDE_DIR       : /usr/include
-- AVIDEMUX_SEARCH_INCLUDE_DIR: /home/ogf/avidemux2/install//usr/include
-- AVIDEMUX_SEARCH_LIB_DIR    : /home/ogf/avidemux2/install//usr/lib

-- Checking for SCM
-- ****************
-- Seems to be git or git-svn...
-- Getting git-svn version from /home/ogf/avidemux2/avidemux_core
-- Top dir is </home/ogf/avidemux2
/home/ogf/avidemux2/avidemux_core>
-- <4f1eb5a4a7f><161125>==> 161125_4f1eb5a4a7f

-- Checking for pkg-config
-- ***********************
-- Found pkg-config

-- Checking for pthreads
-- *********************
-- Found pthreads

-- Checking for zlib
-- *****************
-- Found zlib

-- Checking for gettext
-- ********************
Could not find Gettext
-- libintl not required for gettext support

-- Checking for SDL>=2 (only for windows)
-- **************************************
Disabled per request

-- Checking for XVideo
-- *******************
-- Found XVideo

-- Checking for execinfo
-- *********************
-- Found execinfo
-- execinfo not required

-- Checking for VDPAU
-- *******************
-- Found VDPAU

-- Checking for LIBVA
-- *******************
-- LibVA cflags=<>
Could not find LIBVA

-- Checking for NVENC
-- *****************
--  nvenc header not Found

-- Checking for ftello
-- ********************
-- ftello present

-- Checking for sqlite
-- *******************
-- Found SQLite

-- ADM_coreConfig.h generated

-- Using native unix setup
-- Creating /home/ogf/avidemux2/buildCore/ffmpeg
-- Configuring FFmpeg
-- Configuring done, processing
-- AVFORMAT : 57, Major :
-- AVCODEC  : 57, Major :
-- AVUTIL   : 55, Major :
-- POSTPRC  : 54, Major :
-- SWSCALE  : 4, Major :

-- AVFORMAT : 57, Major :
-- AVCODEC  : 57, Major :
-- AVUTIL   : 55, Major :
-- POSTPRC  : 54, Major :
-- SWSCALE  : 4, Major :

-- Patching Linux config.mak
patching file config.mak
Hunk #1 succeeded at 110 with fuzz 2 (offset 51 lines).

**************************
***  Optional Library  ***
***      Summary       ***
**************************
*** Video Encoder      ***
    NVENC          No
*** Miscellaneous      ***
    gettext        Yes
    SDL            No
    XVideo         Yes
    VDPAU          Yes
    LIBVA          No
**************************
***   Release Build    ***
**************************

-- Packager=deb, valid choices= {deb,rpm,tgz,none}

-- Configuring done
-- Generating done
-- Build files have been written to: /home/ogf/avidemux2/buildCore
** Failed at make, result in /tmp/logbuildCore**
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 12:01:55 AM
Please attach the admAsNeeded.cmake file you've edited and logbuildCore.tar.bz2 generated by

Code: [Select]
tar -cvjf ~/logbuildCore.tar.bz2 /tmp/logbuildCore
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 12:07:59 AM
tar -cvjf ~/logbuildCore.tar.bz2 /tmp/logbuildCore
tar: Removing leading `/' from member names
/tmp/logbuildCore
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 12:13:53 AM
Probably error on my part. Please revert the changes to admAsNeeded.cmake and replace

Code: [Select]
TARGET_LINK_LIBRARIES( ${name} "-Wl,--as-needed")
at the line 3 with

Code: [Select]
TARGET_LINK_LIBRARIES( ${name} "-lc,-Wl,--as-needed")
then retry to build Avidemux.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 12:19:17 AM
cd ~/avidemux2 && bash bootStrap.bash --deb --rebuild 2>&1 | tee ~/adm-build.log
CMAKE Version : 2.8.12
Cmake version >=2.8.7 doesnt need fakeroot
Build configuration :
******************* :
Build type :
Release build
    Core will be built
     Gtk will be skipped
    Qt5 will be built
    Cli will be built
    Plugins will be built
**BootStrapping avidemux **
Top dir : /home/ogf/avidemux2
Fake installation directory=/home/ogf/avidemux2/install
Cleaning packages
** CORE **
Building buildCore from ../avidemux_core with EXTRA=<>, DEBUG=<>

#########################################
Configure for avidemux core libs Started
#########################################

-- [BUILD] EXTRA Cflags:
-- [BUILD] EXTRA CXXflags:
-- [BUILD] EXTRA LDflags:
-- [BUILD] Compiler /usr/bin/c++
-- [BUILD] Linker   /usr/bin/ld
-- Top Source dir is /home/ogf/avidemux2/avidemux_core/..

-- Checking Compiler support
-- *************************
-- Checking if compiler supports x86 32-bit - Yes

-- CMAKE_INSTALL_PREFIX: /usr
-- AVIDEMUX_INSTALL_DIR: /usr
-- FAKEROOT                   : /home/ogf/avidemux2/install/
-- AVIDEMUX_BIN_DIR           : /usr/bin
-- AVIDEMUX_LIB_DIR           : /usr/lib
-- AVIDEMUX_INCLUDE_DIR       : /usr/include
-- AVIDEMUX_SEARCH_INCLUDE_DIR: /home/ogf/avidemux2/install//usr/include
-- AVIDEMUX_SEARCH_LIB_DIR    : /home/ogf/avidemux2/install//usr/lib

-- Checking for SCM
-- ****************
-- Seems to be git or git-svn...
-- Getting git-svn version from /home/ogf/avidemux2/avidemux_core
-- Top dir is </home/ogf/avidemux2
/home/ogf/avidemux2/avidemux_core>
-- <4f1eb5a4a7f><161125>==> 161125_4f1eb5a4a7f

-- Checking for pkg-config
-- ***********************
-- Found pkg-config

-- Checking for pthreads
-- *********************
-- Found pthreads

-- Checking for zlib
-- *****************
-- Found zlib

-- Checking for gettext
-- ********************
Could not find Gettext
-- libintl not required for gettext support

-- Checking for SDL>=2 (only for windows)
-- **************************************
Disabled per request

-- Checking for XVideo
-- *******************
-- Found XVideo

-- Checking for execinfo
-- *********************
-- Found execinfo
-- execinfo not required

-- Checking for VDPAU
-- *******************
-- Found VDPAU

-- Checking for LIBVA
-- *******************
-- LibVA cflags=<>
Could not find LIBVA

-- Checking for NVENC
-- *****************
--  nvenc header not Found

-- Checking for ftello
-- ********************
-- ftello present

-- Checking for sqlite
-- *******************
-- Found SQLite

-- ADM_coreConfig.h generated

-- Using native unix setup
-- Creating /home/ogf/avidemux2/buildCore/ffmpeg
-- Configuring FFmpeg
-- Configuring done, processing
-- AVFORMAT : 57, Major :
-- AVCODEC  : 57, Major :
-- AVUTIL   : 55, Major :
-- POSTPRC  : 54, Major :
-- SWSCALE  : 4, Major :

-- AVFORMAT : 57, Major :
-- AVCODEC  : 57, Major :
-- AVUTIL   : 55, Major :
-- POSTPRC  : 54, Major :
-- SWSCALE  : 4, Major :

-- Patching Linux config.mak
patching file config.mak
Hunk #1 succeeded at 110 with fuzz 2 (offset 51 lines).

**************************
***  Optional Library  ***
***      Summary       ***
**************************
*** Video Encoder      ***
    NVENC          No
*** Miscellaneous      ***
    gettext        Yes
    SDL            No
    XVideo         Yes
    VDPAU          Yes
    LIBVA          No
**************************
***   Release Build    ***
**************************

-- Packager=deb, valid choices= {deb,rpm,tgz,none}

-- Configuring done
-- Generating done
-- Build files have been written to: /home/ogf/avidemux2/buildCore
** Failed at make, result in /tmp/logbuildCore**
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 12:21:03 AM
 tar -cvjf ~/logbuildCore.tar.bz2 /tmp/logbuildCore
tar: Removing leading `/' from member names
/tmp/logbuildCore
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 12:25:59 AM
Could you please actually attach logbuildCore.tar.bz2? I don't need the messages tar prints into the terminal.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 12:29:53 AM
Sorry.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 12:41:45 AM
Thanks. Maybe the last attempt for tonight: Please revert the changes to admAsNeeded.cmake (delete "-lc," added there), then try to build Avidmux using

Code: [Select]
export LDFLAGS="-lc -Wl,--as-needed"
cd ~/avidemux2 && bash bootStrap.bash --deb --rebuild 2>&1 | tee ~/adm-build.log

If this fails too (it will probably fail, because the linker seems not to understand the "-lc" option), then we'll continue tomorrow or on Sunday at the latest.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 12:48:38 AM
Just my stupid error, it should have been

Code: [Select]
TARGET_LINK_LIBRARIES( ${name} "-lc -Wl,--as-needed")
(with a space instead of a comma). Nevermind, please proceed as explained in my last reply.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 12:53:11 AM

-- Installing: /home/ogf/avidemux2/install/usr/lib/libADM_UI_Cli6.so
-- Removed runtime path from "/home/ogf/avidemux2/install/usr/lib/libADM_UI_Cli6.so"
 Installing cli
** Plugins **
Building buildPluginsCommon from ../avidemux_plugins with EXTRA=<-DPLUGIN_UI=COMMON>, DEBUG=<>

#####################################
Plugins Configure Started
#####################################

-- Checking for avidemux development files ..
-- Checking for avidemux include folder (i.e. CMAKE_INSTALL_PREFIX/include/avidemux/2.6, looking in /home/ogf/avidemux2/install//usr/include/avidemux/2.6
-- Found avidemux include folder. good.
-- Checking for cmake subfolder
-- Found cmake subfolder.good.
-- Cmake module path = /home/ogf/avidemux2/install//usr/include/avidemux/2.6/cmake;/home/ogf/avidemux2/install//usr/include/avidemux/2.6/cmake;
-- [BUILD] EXTRA Cflags:
-- [BUILD] EXTRA CXXflags:
-- [BUILD] EXTRA LDflags:-lc -Wl,--as-needed
-- [BUILD] Compiler /usr/bin/c++
-- [BUILD] Linker   /usr/bin/ld
-- Top Source dir is

-- Checking Compiler support
-- *************************
-- Checking if compiler supports x86 32-bit - Yes

-- CMAKE_INSTALL_PREFIX: /usr
-- AVIDEMUX_INSTALL_DIR: /usr
-- FAKEROOT                   : /home/ogf/avidemux2/install/
-- AVIDEMUX_BIN_DIR           : /usr/bin
-- AVIDEMUX_LIB_DIR           : /usr/lib
-- AVIDEMUX_INCLUDE_DIR       : /usr/include
-- AVIDEMUX_SEARCH_INCLUDE_DIR: /home/ogf/avidemux2/install//usr/include
-- AVIDEMUX_SEARCH_LIB_DIR    : /home/ogf/avidemux2/install//usr/lib

-- Checking for SCM
-- ****************
-- Seems to be git or git-svn...
-- Getting git-svn version from /home/ogf/avidemux2/avidemux_plugins
-- Top dir is </home/ogf/avidemux2
/home/ogf/avidemux2/avidemux_plugins>
-- <4f1eb5a4a7f><161125>==> 161125_4f1eb5a4a7f

-- Checking for pkg-config
-- ***********************
-- Found pkg-config

-- Checking for pthreads
-- *********************
-- Found pthreads

-- Checking for zlib
-- *****************
-- Found zlib

-- AVFORMAT : 57, Major :
-- AVCODEC  : 57, Major :
-- AVUTIL   : 55, Major :
-- POSTPRC  : 54, Major :
-- SWSCALE  : 4, Major :

-- CMAKE_INSTALL_PREFIX: /usr
-- AVIDEMUX_INSTALL_DIR: /usr
-- FAKEROOT                   : /home/ogf/avidemux2/install/
-- AVIDEMUX_BIN_DIR           : /usr/bin
-- AVIDEMUX_LIB_DIR           : /usr/lib
-- AVIDEMUX_INCLUDE_DIR       : /usr/include
-- AVIDEMUX_SEARCH_INCLUDE_DIR: /home/ogf/avidemux2/install//usr/include
-- AVIDEMUX_SEARCH_LIB_DIR    : /home/ogf/avidemux2/install//usr/lib
-- Plugin UI : COMMON

-- Checking for FAAD
-- *****************
-- Could not find faacDecInit in /usr/lib/i386-linux-gnu/libfaad.so
--
-- Found NeAACDecInit in /usr/lib/i386-linux-gnu/libfaad.so
-- Found FAAD
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libfaad.so

-- Checking for LIBVORBIS
-- *******************
-- Found LIBVORBIS
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libvorbis.so

-- Checking for libdca
-- *******************
-- Trying libdca 0.5
-- Found libdca
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libdca.so

-- Checking for opencore-amrwb
-- ***************************
Could not find opencore-amrwb

-- Checking for opencore-amrnb
-- ***************************
Could not find opencore-amrnb

-- Checking for OPUS
-- *****************
-- Found LIBOPUS
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libopus.so
-- Checking for ALSA
-- *****************
-- ALSA not found

-- Checking for aRts
-- *****************
Could not find aRts

-- Checking for ESD
-- ****************
Could not find ESD

-- Checking for JACK
-- *****************
Could not find JACK

-- Checking for OSS
-- ****************
-- Found OSS
-- Compiler Flags: /usr/include/i386-linux-gnu
-- Linker Flags  :

-- Checking for PULSEAUDIOSIMPLE
-- *****************************
-- HACK : we need both libpulse and libpulse-simple when using -W-l,-z,defs

-- Checking for Vpx
-- *****************
Could not find Vpx

-- Checking for Aften
-- ******************
-- Found Aften
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/libaften.so

-- Checking for TWOLAME
-- *****************
Could not find TWOLAME

-- Checking for LAME
-- *****************
-- Found LAME
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libmp3lame.so

-- Checking for DCAENC
-- *******************
Could not find DCAENC

-- Checking for FAAC
-- *****************
-- Found FAAC
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libfaac.so

-- Checking for FDK_AAC
-- *****************
Could not find FDK_AAC


-- Checking for Vorbis
-- *******************
-- Found Vorbis
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libvorbis.so /usr/lib/i386-linux-gnu/libvorbisenc.so

-- Checking for VAPOURSYNTH
-- ***********************
-- checking for module 'vapoursynth-script'
--   package 'vapoursynth-script' not found

-- Checking for Xvid
-- *****************
Could not find Xvid

-- Checking for x264
-- *****************
--   core version: 142
-- Found x264
-- Compiler Flags: /usr/include
-- Linker Flags  : /usr/lib/i386-linux-gnu/libx264.so

-- x264 plugin activated.
-- Checking for x265
-- *****************
--   No working version found
Could not find x265

-- x265 disabled.
-- Checking for FreeType2
-- **********************
-- Found FreeType2
-- Compiler Flags: -I/usr/include/freetype2
-- Linker Flags  : -lfreetype

-- Checking for libiconv
-- *********************
Could not find libiconv
-- libiconv is probably not needed

-- Checking for FontConfig
-- ***********************
-- Found FontConfig
-- Compiler Flags: -I/usr/include/freetype2
-- Linker Flags  : -lfontconfig -lfreetype

-- Checking for Fridibi (want 0.19)
-- **************************************
-- Found Fribidi
-- Compiler Flags: -I/usr/include/fribidi
-- Linker Flags  : -lfribidi
-- Fridibi version 0.19.6

-- Yasm found as /usr/bin/yasm

**************************
***  Optional Library  ***
***      Summary       ***
**************************
*** Video Encoder      ***
    Xvid           No
    x264           Yes
    x265           No
*** Scripting          ***
    TinyPy         Yes
*** Miscellaneous      ***
    VapourSynth    No
    FreeType2      Yes
    FontConfig     Yes
    FRIBIDI        Yes
    FontConfig     Yes
*** Audio Encoder      ***
    Aften          Yes
    TWOLAME        No
    LAME           Yes
    DCAENC         No
    FAAC           Yes
    FDK_AAC        No
    Vorbis         Yes
*** Video Decoder      ***
    libvpx         No
*** Audio Device       ***
    ALSA           No
    aRts           No
    ESD            No
    JACK           No
    OSS            Yes
    PulseAudio     Yes
*** Audio Decoder      ***
    FAAD           Yes
    Vorbis         Yes
    libdca         Yes
    opencore-amrwb No
    opencore-amrnb No
    Opus           Yes
*** User Interface     ***
    Common         Yes
    GTK+           No
    Qt 4           No
    CLI            No
**************************
***   Release Build    ***
**************************

-- Packager=deb, valid choices= {deb,rpm,tgz,none}
-- Checking if we have USE_FAAD set
--       yes
-- Checking if we have USE_VORBIS set
--       yes
-- Checking if we have USE_LIBOPUS set
--       yes
-- Checking if we have USE_LAME set
--       yes
-- Checking if we have USE_FAAC set
--       yes
-- Checking if we have USE_AFTEN set
--       yes
-- Checking if we have USE_XVID set
--       no

-- Configuring done
-- Generating done
-- Build files have been written to: /home/ogf/avidemux2/buildPluginsCommon
** Failed at make, result in /tmp/logbuildPluginsCommon**
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 12:58:18 AM
The build failed in PluginsCommon, you should have generated and attached a new logbuildPluginsCommon.tar.bz2 file, not the log for buildCore.

edit: I mean, please run

Code: [Select]
tar -cvjf ~/logbuildPluginsCommon.tar.bz2 /tmp/logbuildPluginsCommon
and attach the logbuildPluginsCommon.tar.bz2 file, I'd like to have a look.

You've correctly exported LDFLAGS, if this didn't change the reason why the build failed, we'll stop for now and continue tomorrow or on Sunday. You've already contributed a lot to Avidemux simply by showing where things don't work.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 01:11:38 AM
I hope this is right.
Thanks for that edit, I was stumped.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 01:21:07 AM
Yes, and it is the same error, unfortunately  :(

Could you please just test the following change to CMakeLists.txt in the folder avidemux2/avidemux_plugins/ADM_audioEncoders/lavcodec: Insert a line

Code: [Select]
TARGET_LINK_LIBRARIES(ADM_ae_lav_${_ext} "c")
just after the line

Code: [Select]
TARGET_LINK_LIBRARIES(ADM_ae_lav_${_ext}  ADM_libavcodec ADM_libavutil)
save the file and rerun

Code: [Select]
cd ~/avidemux2 && bash bootStrap.bash --deb --rebuild 2>&1 | tee ~/adm-build.log
The build will fail, but it should fail at another location this time.

edit: this means, I'd like to have a look at a new logbuildPluginsCommon.tar.bz2 after the build fails!

edit: to be on safe grounds, please delete the folder buildPluginsCommon prior to the compilation attempt.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 01:30:24 AM
When I go to CMakeLists.txt in the folder avidemux2/avidemux_plugins/ADM_audioEncoders/lavcodec: I get another directory, not the text you described.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 01:33:55 AM
Found it.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 01:35:09 AM
I see, the colon after the directory name was confusing. Good that you've sorted this out.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 01:39:33 AM
** ALL DONE **
** The installable packages are in the debs folder **
ogf@freekbox:~/avidemux2$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 01:40:57 AM
Good, you've successfully built a 32bit Avidemux  :)
Now please install the .debs by running

Code: [Select]
cd ~/avidemux2/debs && sudo dpkg -i *.deb
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 01:42:40 AM
cd ~/avidemux2/debs && sudo dpkg -i *.deb
[sudo] password for ogf:
Selecting previously unselected package avidemux3-cli-dev.
(Reading database ... 180930 files and directories currently installed.)
Preparing to unpack avidemux3-cli-2.6.15-161125-dev.deb ...
Unpacking avidemux3-cli-dev (2.6.15-161125) ...
Selecting previously unselected package avidemux3-cli-runtime.
Preparing to unpack avidemux3-cli-2.6.15-161125-runtime.deb ...
Unpacking avidemux3-cli-runtime (2.6.15-161125) ...
Selecting previously unselected package avidemux3-core-dev.
Preparing to unpack avidemux3-core-2.6.15-161125-dev.deb ...
Unpacking avidemux3-core-dev (2.6.15-161125) ...
Selecting previously unselected package avidemux3-core-runtime.
Preparing to unpack avidemux3-core-2.6.15-161125-runtime.deb ...
Unpacking avidemux3-core-runtime (2.6.15-161125) ...
Selecting previously unselected package avidemux3-plugins-cli-plugins.
Preparing to unpack avidemux3-plugins-CLI-2.6.15-161125-plugins.deb ...
Unpacking avidemux3-plugins-cli-plugins (2.6.15-161125) ...
Selecting previously unselected package avidemux3-plugins-common-plugins.
Preparing to unpack avidemux3-plugins-COMMON-2.6.15-161125-plugins.deb ...
Unpacking avidemux3-plugins-common-plugins (2.6.15-161125) ...
Selecting previously unselected package avidemux3-plugins-qt5-plugins.
Preparing to unpack avidemux3-plugins-qt5-2.6.15-161125-plugins.deb ...
Unpacking avidemux3-plugins-qt5-plugins (2.6.15-161125) ...
Selecting previously unselected package avidemux3-qt5-dev.
Preparing to unpack avidemux3-qt5-2.6.15-161125-dev.deb ...
Unpacking avidemux3-qt5-dev (2.6.15-161125) ...
Selecting previously unselected package avidemux3-qt5-runtime.
Preparing to unpack avidemux3-qt5-2.6.15-161125-runtime.deb ...
Unpacking avidemux3-qt5-runtime (2.6.15-161125) ...
Selecting previously unselected package avidemux3-settings-settings.
Preparing to unpack avidemux3-settings-2.6.15-161125-settings.deb ...
Unpacking avidemux3-settings-settings (2.6.15-161125) ...
Setting up avidemux3-core-dev (2.6.15-161125) ...
Setting up avidemux3-core-runtime (2.6.15-161125) ...
Setting up avidemux3-plugins-cli-plugins (2.6.15-161125) ...
Setting up avidemux3-plugins-common-plugins (2.6.15-161125) ...
Setting up avidemux3-plugins-qt5-plugins (2.6.15-161125) ...
Setting up avidemux3-qt5-dev (2.6.15-161125) ...
Setting up avidemux3-qt5-runtime (2.6.15-161125) ...
Setting up avidemux3-settings-settings (2.6.15-161125) ...
Setting up avidemux3-cli-dev (2.6.15-161125) ...
Setting up avidemux3-cli-runtime (2.6.15-161125) ...
ogf@freekbox:~/avidemux2/debs$
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 01:47:24 AM
Now please run

Code: [Select]
sudo ldconfig
as a precaution, then you should be able to start Avidemux with

Code: [Select]
avidemux3_qt5
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 01:52:15 AM
SUCCESS!
It opens the jpegs now.
Will I have to open it from the terminal every time? Or will it appear in my menu?
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 01:56:44 AM
You can make an avidemux.desktop file (an application starter) like

Code: [Select]
[Desktop Entry]
Name=Avidemux Video Editor (Qt5)
Comment=Graphical video editing tool - Qt5 interface
Icon=totem
Exec=/usr/bin/avidemux3_qt5
MimeType=video/mpeg;video/quicktime;video/x-msvideo;video/x-anim;audio/x-mp3;audio/x-mp2;
Terminal=false
Type=Application
Categories=AudioVideo;AudioVideoEditing;
X-Desktop-File-Install-Version=0.23
StartupWMClass=avidemux3_qt5

and put it into ~/.local/share/applications (instead of "totem" you can choose another icon of your liking).
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 26, 2016, 02:02:32 AM
Lol. You lost me again.
Where do I find '~/.local/share/applications'?
Title: Re: Unable to load jpegs created in gimp.
Post by: Jan Gruuthuse on November 26, 2016, 06:39:32 AM
Is a hidden folder. In the file manager menu: View -> click on Show hidden files. It should now have a v in front of Show hidden files.

OR

In the addressbar copy paste this:
Code: [Select]
/home/ogf/.local/share/applications this should you bring in the wanted folder.

btw folks nice work, beyond my knowledge.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 26, 2016, 02:58:13 PM
In the addressbar copy paste this:
Code: [Select]
/home/ogf/.local/share/applications this should you bring in the wanted folder.

Entering

Code: [Select]
~/.local/share/applications
into the location bar in a filemanager works just as well, "~" gets expanded to the value of $HOME environmental variable.

#####################

3d420, might I ask you a favour? If you have not yet deleted the avidemux2 folder in your home directory, could you please test if

Code: [Select]
cd ~/avidemux2
rm -r build* install
bash bootStrap.bash

still results in a successful build? The reason I ask you this is that we didn't check if omitting a global export of LDFLAGS still allows the build to succeed.
Title: Re: Unable to load jpegs created in gimp.
Post by: 3d420 on November 27, 2016, 03:35:07 AM
3d420, might I ask you a favour? If you have not yet deleted the avidemux2 folder in your home directory, could you please test if

Code: [Select]
cd ~/avidemux2
rm -r build* install
bash bootStrap.bash

still results in a successful build? The reason I ask you this is that we didn't check if omitting a global export of LDFLAGS still allows the build to succeed.
Sorry I didn't have time today. I can run a test build for you on Monday if you still want it.
Title: Re: Unable to load jpegs created in gimp.
Post by: eumagga0x2a on November 27, 2016, 03:09:46 PM
Thank you, but there is no need to run a test build anymore: I've setup 32 bit versions of (L)ubuntu 16.04 and 14.04.5 in gnome-boxes to be able to test everything myself (which turned out to be very helpful, immediately catching two stupid errors in my changes ;D).