Avidemux Forum

Avidemux => Main version 2.6 => Topic started by: dav2708 on December 15, 2018, 09:07:52 PM

Title: Audio Distortions When Joining Multiple Clips
Post by: dav2708 on December 15, 2018, 09:07:52 PM
Hi Guys.
I like to join and edit multiple clips from different sources but run into trouble with the audio streams.
I usually re-encode all the clips to xvid 4 and the audios to Mp3.
When I edit and join them, the audio becomes severely muffled and distorted in some of the joined clip segments. Some parts are normal and others not.
I thought by making them all mp3's it would solve  the problem but alas no.
I can't figure out why the audio streams are seemingly incompatible even through I have changed them all to Mp3?
Title: Re: Audio Distortions When Joining Multiple Clips
Post by: eumagga0x2a on December 15, 2018, 09:29:51 PM
When appending videos, the number of audio tracks, the channel layout and sampling frequency must match. The output codec doesn't matter.

Just in case: does audio sound fine when playing individual files? In doubt please try the latest nightly (https://avidemux.org/nightly/) matching your operating system.
Title: Re: Audio Distortions When Joining Multiple Clips
Post by: dav2708 on December 15, 2018, 09:45:11 PM
Yes, individually the audios are fine but when attempting to join them, they distort from one to the next.
 As you said I may need to look at the sampling frequency etc to see if they match and if not sort out how to make them the same.