Update to Current Release 2.5

Started by Fontman, May 15, 2012, 03:57:26 AM

Previous topic - Next topic


I'm keen to know when a formal update, or some available fix, is likely to occur regarding the out-of-sync audio and AC3 (AC3 and MP2 encoding fix). I'm migrating to Kubuntu, rather than using Windows, and while I can find some sort of update for Windows, I'm unable to locate an update or deb for Kubuntu 10.10

I noticed that there is a link for a later release for Ubuntu/Kubuntu 12.04 and this raises several questions:

Why are these releases specific to a particular version of Ubuntu/Kubuntu?

Why is this release only available from the Rapidshare site, that requires some kind of paid membership?

Later versions than 2.5 are seemingly all over the place for Windows.

It's a pain to have to convert Kaffeine generated videos to AVI in order to initiate a workaround.

Thanks in advance...

Jan Gruuthuse

Kubuntu would be based on Ubuntu 10.10 (Maverick Meerkat). If you are running 32-bit Kubutu, this could be useful to you: maverick32

QuoteWhy are these releases specific to a particular version of Ubuntu/Kubuntu?
There is no 64-bit. I'm on 64-bit and switched to the 5 year supported 12.04 LTS and still have a boot able 11.10 64-bit and still compile these. As they are there I can share these to others who need these. the kernel and libraries used in 11.10 and 12.04 have changes and interact a little different.

I compile 2.5, but its not building Distributable Packages, so there is nothing to pass on here

If none of the above helps, check these out: Building & compiling Avidemux
Simple article: Installing Avidemux 2.5.x for Linux
Simple article: Installing Avidemux 2.6.x for Linux


Thanks Jan;

I do have a 32-bit Maverick on an old HP DC5100 running Kaffeine, so I'll update that one. I've tried virtually all of the other video editing software for Ubuntu/Linux and they either won't load, don't work, have some restriction, or they are unusable. I'll have the check out the compiling links although I'm not a proficient programmer, I can get to understand many processes.

Thanks for your time, this is a great program, and I would donate to it if possible, but it seems the official position is "No donation at this time, just say it if it makes your life easier". Well it makes my life easier, thanks again.


I tried the core package for Maverick, and it unfortunately failed. I realize you are probably rather busy, but does this appear to be my problem or the package?

Selecting previously deselected package avidemux3-core.
(Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 105820 files and directories currently installed.)
Unpacking avidemux3-core (from .../avidemux3-core-2.6.0-r7943-Linux.deb) ...
dpkg: error processing /home/kh2/Downloads/avidemux3-core-2.6.0-r7943-Linux.deb (--install):
unable to create `/usr/include/avidemux/2.6/libavutil/avconfig.h.dpkg-new' (while processing `./usr/include/avidemux/2.6/libavutil/avconfig.h'): No such file or directory
dpkg-deb (subprocess): data: internal gzip write error: Broken pipe
dpkg-deb (subprocess): failed in write on buffer copy for failed to write to pipe in copy: Broken pipe
dpkg-deb: subprocess <decompress> returned error exit status 2
Errors were encountered while processing:

Any thoughts?

Jan Gruuthuse

see reply of mean below. (thnx)


It is a bug of old version of cmake

sudo mkdir /usr/include/avidemux/2.6
sudo mkdir /usr/include/avidemux/2.6/libavutil

and so on each time you got a "no such file or directory error"


Thanks, I was able to eventually install the package, the common plugins and, as there was no GTK, I installed the qt4 package. I then ran avidemux3_qt4 from the /usr/bin/ folder as there was no icon or entry in the kick-off menu (or search). I loaded an mpg file, but there was no audio. Audio is fine in VLC. Any thoughts?

Jan Gruuthuse

I did make a short cut on the desktop and assigned this desktop icon to it (attachment).
When you press (Display file information (audio/video format, resolution etc.)) what does it say about the audio?
If it says nothing: What is mediaInfo telling you about the audio? http://mediainfo.sourceforge.net/en

As temporary measure: drag and drop the video file in audacity and export the audio track. This audio track can be used to exchange or add new audio track in avidemux.
source video working, audio track problem?

Upload a 10 to 20 MB sample video to upload site like rapidshare or similar with same type of audio track causing this problem and provide the uplink to it.


Thanks for the icon, I added this to the kick-off menu.

The audio is AC3, stereo, 192bps

I have uploaded a video and extracted audio to (be there for a week):



By the way, in the program Edit | Preferences, I only have Dummy and OSS as my AudioDevice. Choosing OSS yields "Trouble initializing audio device" Otherwise the default is Dummy. Choosing Stereo or Pro  Logic for Local Playback Downmixing, does nothing. Internal Analog Stereo is my system default sound device.


Jan Gruuthuse

You should either have alsa or pulse audio installed, avidemux should find these. Believe pulse would be for later ubuntu (11.10 and 12.04 LTS)

Jan Gruuthuse

Audio is present in the mpg clip and plays fine in avidemux 2.6. It finds the 2 audio tracks. Once you sorted out the audio in maverick, should be OK. See attachments.


check you have libpulse-dev installed


Thanks, I thought the issue was the audio setup from the options I had. Maverick and Pulse do not seem to mix very well, without opening the drains, and even though I gave it a lengthy shot by installing backends and libraries, it is not too much of an issue considering the audio is self contained and in sync after edits now.

I sincerely appreciate the assistance given here, I record mostly using Maverick32, so the newer version of Avidemux has made life so much easier, as well as the transition away from MS Windows.