Author Topic: Schwierigkeiten beim Schneiden von Video  (Read 19820 times)

Nürnberg-User

  • Newbie
  • *
  • Posts: 3
Schwierigkeiten beim Schneiden von Video
« on: June 04, 2012, 09:31:57 AM »
Hallo, mein System; Win 7 Prof 64 Bit, Rechner AMD Phenom 9750 Quad Core, 4 GB Arbeitsspeicher

Ich habe verschiedene Versionen von Avidemux getestet. Mit der Version 2.5.6 habe ich wenn ich Werbung aus meinen mpeg Datei herausschneide Tonversatz, auch die Werte die mir das Program für "Shift in __ ms" auswirft beheben den Versatz nicht wirklich.

Mit der Version 2.6.0 (r7997) stürzt das Programm beim Speicher des geschnittenen Videos ab.
Aber es gibt in der zwar nicht vollständigen Video-Datei keinen Tonversatz.

Wecher Fehler liegt hier vor ? Die Video und Ton-Datei befinden sich beim Speicher nur im Copy-Modus.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Schwierigkeiten beim Schneiden von Video
« Reply #1 on: June 04, 2012, 10:23:59 AM »
Verwenden Sie Zone Alarm? Zone Alarm abschalten und deinstallieren.
Wenn keine Zone Alarm: versuchen Sie es mit 32-Bit statt 64-Bit-Version.
War dies nicht erfolgreich: überlegen sie ein Dual-Boot mit Ubuntu als zweites Betriebsystem auf eine verwisslebare Festplatte mit bios boot.
« Last Edit: June 04, 2012, 01:20:22 PM by Jan Gruuthuse »

hinterwaeldler

  • Newbie
  • *
  • Posts: 31
Re: Schwierigkeiten beim Schneiden von Video
« Reply #2 on: June 04, 2012, 11:56:12 PM »
hallo und wilkommen im forum

durch die bezeichnung "werbung herausschneiden" tippe ich auf einen mitschnitt auf basis von einer tvkarte (falls nicht bitte korrigieren). in diesem falle wuerde es sich um einen mpeg-ts stream handeln.in diesem fall, musst du zunaechst der versatz zwischen audio und video korrigieren lassen.
dieser veraendert sich (zumindest bei mir) im laufe der zeit.
fuer die korrektur benutze ich daher vor der weiteren bearbeitung folgendes tool:  http://project-x.sourceforge.net/
dabei gilt es darauf zu achten, ob es sich bei tonmaterial um einen ac3 sound handelt. zumindest als ich das ganze das letzte mal gechnitten hatte, musste ich dabei darauf achten, dass das erste frame (project x beruecksichtigt nur keyframes) im film befindet. grund hierfuer ist ein wechsel der kanal anzahl, zwischen werbung und film (werbung ist, soweit ich bisher gesehen habe in stereo).
anschliessen sollte der ton und das video getrennt vorliegen. diese lassen sich anschliessen in avidemux laden:
1) video laden (bei der dateiendung bin ich mir gerade nicht sicher)
2) im menu punkt audio laesst sich der audio strom anschliessend wieder einfuegen

nun sollte der ton syncron sein. die einzelnen bereiche ohne werbung kannst du nun nach belieben speichern oder weiter verarbeiten.
wichtig hierbei: nicht direkt schneiden!!!!
grund: das video und der ton sind nun getrennt und das schneiden wirkt sich nur auf das video aus

ohne erneutes codieren ist an dieser stelle kein frame genaues "schneiden" (in form von auswahl der bereiche moegliche).
den grund hierfuer kannst du hier nachlesen: http://de.wikipedia.org/wiki/P-Frame

daher waere mir auch kein einfacherer weg mit einem anderen tool bekannt.

zu der frage mit version 2.6, diese ist noch sehr experimentel und hat so einige macken

hoff ich konnte dir damit helfen und du hast noch viel spass mit avidemux

Nürnberg-User

  • Newbie
  • *
  • Posts: 3
Re: Schwierigkeiten beim Schneiden von Video
« Reply #3 on: June 05, 2012, 07:04:42 AM »
Hallo, herzlichen Dank für die Antworten,
zur Erklärung: Die Aufnahmen werden über eine TV Karte HVR-4400 mit der Software WinTV 7 angefertigt. Die Software konvertiert nach der Aufnahme eine .mpg Datei.
Diese .mpg Datei ist noch vollkommen Lippen-synchron, allerdings mit Werbung durchsetzt.

Jetzt „Avidemux 2.6.0 (r7990) 32bit“
Schnittpunkte alle gesetzt. Beim Speichern ( bei ca. 70% ) bricht das Programm mit der Fehlermeldung „Too short – The Video has been saved but seems to be incomplete“
ab. Die bis dahin gespeicherte Datei lässt sich auch anschauen und ist vollkommen Lippen-synchron trotz das schon 2 Werbeblöcke ausgeschnitten wurden.

Zone-Alarm verwende ich nicht.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Schwierigkeiten beim Schneiden von Video
« Reply #4 on: June 05, 2012, 09:05:04 AM »
WinTV 7 aufnahme ist in transport stream format (.TS extension). Avidemux 2.6 kann Diese Aufnahmen direkt verarbeiten. Zuerst schneiden dann fertige video speichern mit Video: copy, Audio: Copy und Output Format: MP4
Entweder erhalten sie das TS-Fomat: Output Format: Mpeg-TS muxer und danach konvertieren nach mpg.
« Last Edit: June 05, 2012, 09:09:15 AM by Jan Gruuthuse »

Nürnberg-User

  • Newbie
  • *
  • Posts: 3
Re: Schwierigkeiten beim Schneiden von Video
« Reply #5 on: June 08, 2012, 09:50:09 AM »
Hallo, Danke für die Antwort. Habe den Rat befolgt und die nächste Aufnahme von der Fernsehkarte im TS Format belassen zum Schneiden. Leider auch hier kein Erfolg, nur neue Fehlermeldungen. Woran liegt Es ?
Ist die Hardware falsch ? Treiber ? Gibt es ein Testprogramm für den Rechner was laufen müsste um den Fehler einzugrenzen ? ich weiß es hört sich nach User-Fehler an, aber ganz ungeschickt stelle ich mich mit Sicherheit nicht an, nur einen ansonsten "Sehr gut laufenden Rechner" noch ein zusätzliches neues Betriebssystem aufzubürden wie Ubunto kann doch nicht die Lößung sein,......

Wann ist die Fertigstellung der Version 2.6 für 64 bit Win 7 Prof.  angepeilt ?

hinterwaeldler

  • Newbie
  • *
  • Posts: 31
Re: Schwierigkeiten beim Schneiden von Video
« Reply #6 on: June 20, 2012, 10:42:16 PM »
war nicht direkt als rat gemeint, dass du es im ts format belassen sollst.
eigentlich bezog sich das darauf, dass dein quellmaterial im ts format vorhanden ist.

wen jan recht hat, kann der ts stream mittlerweile ohne vorarbeit (syncronitaet zwischen bild und ton) verarbeitet werden.
allerdings scheint dies nur bei version 2.6 der fall zu sein (2.5.6 erzeugt asyncorone daten bei mir)

Ich habe verschiedene Versionen von Avidemux getestet. Mit der Version 2.5.6 habe ich wenn ich Werbung aus meinen mpeg Datei herausschneide Tonversatz, auch die Werte die mir das Program für "Shift in __ ms" auswirft beheben den Versatz nicht wirklich.

moeglichkeit 1) project x (sycronitaet) + avidemux 2.5.6 (schneiden + ??)
moeglichkeit 2) bei der fehlermeldung too short mal die diskussionen ueber den entwicklungsstand verfolgen, da hab ich zumindest ein paar mal was gesehen wegen der too short fehlermeldung + die fehlermeldung hier posten (inklusive stderr, liegt bei win glaub ich in einer datei im avidemux ordner)

zum thema fertigstellung: ich tipp darauf, dass es noch min einige monate dauern wird. zumindest sah der quellcode an einigen stellen noch alles andere als fertig aus

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Schwierigkeiten beim Schneiden von Video
« Reply #7 on: June 21, 2012, 06:24:30 AM »
wen jan recht hat, kann der ts stream mittlerweile ohne vorarbeit (syncronitaet zwischen bild und ton) verarbeitet werden.
allerdings scheint dies nur bei version 2.6 der fall zu sein (2.5.6 erzeugt asyncorone daten bei mir)
Dass tut es (2.6).
Der Hauptunterschied 2.5 ist Frame-orientiert. 2.6 ist zeit basiert, kann nicht genau frame schneiden.
2.5 funktioniert nicht mit HD-TV wie von öffentlich-rechtlichen Rundfunkanstalten angeboten. MPEG-TS HD. Manchmal nutzt man 2.5 dann wieder 2.6.

logitechmaus

  • Newbie
  • *
  • Posts: 4
Re: Schwierigkeiten beim Schneiden von Video
« Reply #8 on: July 15, 2012, 12:28:38 PM »
Hallo,

erst einmal Dank für diese Information,

1) technotrend S835 HD
2) Comag SL40 HD
3) Terratec Cinergy S2 PCI HD
4) Avidemux 2.56 64bit
5) CPU Intel 6750
6) win7 (klar 64bit)

suchte schon seit wochen eine einfache Möglichkeit die PVR aufnahmen vom Receiver technotrend S835 HD
Comag SL40 HD auf eine einfache weise zu bearbeiten.
1) Bei den ts Aufnahmen den Anfang und das Ende vom Video zu entfernen, zum Teil auch die Werbung in der Mitte zu entfernen.
2) der Zeitaufwand soll so gering wie möglich sein.

1) technotrend S835 HD
die aufnahmen erfolgt in ts Form,
mit MediaInfo die Information erhalten -444ms (Info bei Text Einstellung)
in Avidemux habe ich die doppelte Zeit also Delay: -888ms eingestellt
avi  und MPeg-Ts ausprobiert, Ok , bin mit der Qualität zufrieden.
avi 882.666 kB und ts 912.173 kB

den Comag SL40HD werde ich jetzt ausprobieren,

Avidemux ist bisher die schnellste Software mit der ich die videos in ts und mpeg bearbeiten kann.

Frage:
wie kann ich mit Avidemux z.B. eine mpeg-Datei von ca. 8GByte splitten  für DVD und Festplatte (da USB-Festplatte mit FAT 32 formatiert ist)

Danke an alle die hier gepostet haben.

logitechmaus



 



Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: Schwierigkeiten beim Schneiden von Video
« Reply #9 on: July 15, 2012, 01:11:58 PM »
Frage:
wie kann ich mit Avidemux z.B. eine mpeg-Datei von ca. 8GByte splitten  für DVD und Festplatte (da USB-Festplatte mit FAT 32 formatiert ist)
Es tut mir leid. Ich habe keine Ahnung von splitten. Ich benutze nur USB FAT32-Harddisks zum Aufzeichnen. Für die Wiedergabe benutze ich eine DLNA-unterstützte Network Attached Storage oder NTFS-formatierte USB-Festplatte / Stick direkt auf dem TV-Gerät.

logitechmaus

  • Newbie
  • *
  • Posts: 4
Re: Schwierigkeiten beim Schneiden von Video
« Reply #10 on: July 15, 2012, 03:24:31 PM »
Hallo.
Danke für die schnelle Info,

habe gerade festgestellt das Avidemux unter Punkt 2 und 3  keine HD Datein ts verarbeiten kann, es folgt immer  eine Crash-Anzeige von Avidemux. werde heute abend auch Punkt 1 unter HD prüfen.
1) technotrend S835 HD
2) Comag SL40 HD
3) Terratec Cinergy S2 PCI HD, Software TerraTec Home Cinema Classic:6.27.04.999 (TERRATEC Build)
4) Terratec Cinergy 600 TV, Software V5.118, über SVHS und Video Eingang für externe Geräte (Receiver)
5) Avidemux 2.56 64bit, win7

mfg
logitechmaus
« Last Edit: July 15, 2012, 03:39:18 PM by logitechmaus »

zakk

  • Hero Member
  • *****
  • Posts: 623
Re: Schwierigkeiten beim Schneiden von Video
« Reply #11 on: July 15, 2012, 04:45:26 PM »
@logitekmaus: Sie brauchen Avidemux 2.6, funktionniert jetzt ziemlich gut mit HD.