Author Topic: Avidemux-cli: Wie kann ich 2pass-Methode mit Durchschnittlichen Bitrate aufrufen  (Read 6149 times)

walt63

  • Newbie
  • *
  • Posts: 2
Hallo zusammen,

ich benutze Avidemux-cli unter Linux.

Mein Ziel ist, aus dem Script eine mpg-Datei in eine avi-Datei möglichst kompakt umzuwandeln.
Deshalb möchte ich 2Durchlauf-Modus anwenden.
Am besten gefällt mir die Methode mit der definierten durchschnittlichen Bitrate.

Ich habe folgendes ausprobiert:

avidemux --info --audio-bitrate 128 --audio-codec MP3 --video-codec Xvid --video-conf 2pass=1500,mbr=1500 --autoindex --load "$NAME".mpg --save "$NAME".avi --output-format AVI

Dabei habe ich mit "2pass=1500" so was wie 1500 MB Datei-Größe angegeben, obwohl ich es nicht möchte.

Im Avidemux-Qt kann ich einfach die Durchchschnittliche Bitrate (1500) angeben.

Fazit: Avidemux-cli generiert eine Avi-Datei. Die ist aber deutlich größer als eine, die mit Avidemux-Qt generiert wurde.

Was mache ich falsch ?


Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Command line usage:
Quote
--video-conf 2pass=1500,mbr=1500
|oder
--video-conf    cq=q | cbr=br | 2pass=xx

Code: [Select]
--video-conf 2pass=1500
Probieren Sie es aus. Selbst nicht getestet.

walt63

  • Newbie
  • *
  • Posts: 2
Command line usage:
Quote
--video-conf 2pass=1500,mbr=1500
|oder
--video-conf    cq=q | cbr=br | 2pass=xx

Code: [Select]
--video-conf 2pass=1500
Probieren Sie es aus. Selbst nicht getestet.

Vielen Dank, Jan.

Ich habe Ihren Vorschlag getestet: es kommt eine Datei mit ca. 1,6 GB

Es gibt bei Avidemux-Qt für den Xvid folgend Auswahlmöglichkeiten:

1. konstante Bitrate(1 Durchlauf) --> cbr=br
2. konstante Quantisierung(1 Durchlauf) --> cq=q
3. feste Videogröße( 2 Durchläufe) --> 2pass=xx
4. durchschnittliche Bitrate(2 Durchläufe) --> ??? anscheinend im cli nicht umgesetzt ???

Also verwende ich momentan cbr=1500 und bearbeite schliesslich das avi-File mit Avidemux-Qt (Option 4)

douche

  • Full Member
  • ***
  • Posts: 100
Bin über diesen weitgehend undokumentierten Parameter gestolpert:

--video-conf 2passbitrate=1500


Schien zu funktionieren. Das war avidemux 2.5.6 (nicht _cli) unter Windows.

hth, nemo