September 19, 2020, 06:06:19 pm

News:

--


Compiling Avidemux v2.5.6 on Windows

Started by pulkitw, July 04, 2012, 06:57:21 am

Previous topic - Next topic

pulkitw

July 04, 2012, 06:57:21 am Last Edit: July 04, 2012, 07:10:45 am by pulkitw
Hi, i am a newbie trying to compile avidemux v2.5.6. following the guide  http://sourceforge.net/projects/avidemux-mswin/files/misc/

While building avidemux i am getting pkg-config not found while i have copied the same in MSYS\local folder. I tried after updating the pkg-config with its new version but still the problem persists.
How should i proceed further?


gruntster

Is MSYS\local\bin in your path environment variable?  If you run "export" in MSYS shell, do you see /usr/local/bin in PATH?

pulkitw

July 04, 2012, 07:15:34 am #2 Last Edit: July 04, 2012, 07:33:25 am by pulkitw
gruntster, Yes usr/local/bin is there in the path.


gruntster

Executing "pkg-config" works?

Also CMake 2.8.8 has a bug detecting pkg-config (http://www.cmake.org/Bug/view.php?id=13125).

You'll need to either revert back to CMake 2.8.7, patch CMake 2.8.8 or patch Avidemux.

CMake 2.8.8 patch: http://cmake.org/gitweb?p=cmake.git;a=commitdiff;h=3ea850a5023060b84dcc0e6f0098c32c28b15807
Avidemux patch: http://svn.berlios.de/wsvn/avidemux?op=comp&compare%5B%5D=/@7892&compare%5B%5D=/@7893

pulkitw

gruntster, I did revert back to CMake2.8.7.
pkg-config has worked :) now i am getting another error, dxva2 not detected while i have downloaded the file "dxva2api.h" as said in the guide.


when i re-run the command w/o deleting the CMakeCache.txt, the configuration is complete but Qt is not detected when i have installed qt-win-opensource-4.6.1-mingw.exe as mentioned in the guide.




p.s : i did not download the following files to the MinGW folder and skipped the patch process as well
http://avidemux.razorbyte.com.au/misc/_ming_mac.h.diff
http://avidemux.razorbyte.com.au/misc/basetyps.h.diff
http://avidemux.razorbyte.com.au/misc/objbase.h.diff
as the link was not available and i could not find it after googling as well. So i am proceeding w/o these files.

pulkitw

gruntster, Also if i assume everything is going fine and run the "make" command
i encounter this :



gruntster

Based on your screen grab, it looks like you've installed MSYS coreutils 5.97-3.  If that's the case, you'll also need the coreutils-5.97-3-msys-1.0.13-ext package (which includes pr.exe).

This may also fix the dxva issue, otherwise try moving the header file to the MSYS/local/include folder.

As for the Qt issue, if you run "export" again, is the QTDIR variable set correctly?

It also looks like the version of MinGW you're using is probably too old but we can tackle that once you have the CMake process sorted.

pulkitw

Moving the header file to MSYS/local/include worked :)

As for Qt issue, QTDIR was not set correctly so I changed it in MSYS\etc\profile but still in exports it shows the old one. :|

And i have installed mingw-w32-bin_i686-mingw_20111219.

gruntster

You'll need to close MSYS and reopen it for your profile changes to take effect.

I'd recommend using niXman's MinGW builds: http://sourceforge.net/projects/mingwbuilds/files/windows-host/4.7.1/release/

pulkitw

oh, my bad :)
& i'll try with MinGW you recommended.. :)

pulkitw

I have unzipped the niXman's built, and tried to run "make" i got a dialog box with error "libgmp-3.dll is missing from your computer try reinstalling the program"



log :


Should i try someother version of MinGW ?

gruntster

Are you using GCC 4.7.1?  libgmp-3.dll is usually a requirement for older versions of GCC.  Are you sure you've not ended up with a mix of versions?  Did you perform a clean build with the new MinGW (i.e. started with an empty build folder)?

gruntster

Otherwise you could try Ruben's MinGW builds (http://sourceforge.net/projects/mingw-w64/files/Toolchains%20targetting%20Win32/Personal%20Builds/rubenvb/release/).  I don't use them because they're not multilib but they're about the only other reliable MinGW-w64 builds available at the moment.

pulkitw

Yes, i did not end up with mix of versions and i did not start with empty build folder but i ran the cmake command again.
I started fresh now, I have unzipped the gtk+ dependencies in the mingw folder.

While running cmake command i used to get these errors but the configuring used to be complete, but this time its the opposite.


gruntster

Quote from: gruntster on July 04, 2012, 09:53:41 am
Based on your screen grab, it looks like you've installed MSYS coreutils 5.97-3.  If that's the case, you'll also need the coreutils-5.97-3-msys-1.0.13-ext package (which includes pr.exe).


You did grab this package, right?