April 13, 2021, 12:20:22 AM

News:

--


Video with 2.6.3 runs too fast

Started by dorpm, March 31, 2013, 09:26:04 PM

Previous topic - Next topic

dorpm

With 2.6.3 the videos are running too fast meanwhile the audio seems to be ok. This problem appeared after upgrading from 2.6.2 to 2.6.3.

I am running avidemux on a Ubuntu 12.04 64bit. Is there a way to revert to 2.6.2?

Florian

Jan Gruuthuse

April 01, 2013, 06:30:07 AM #1 Last Edit: April 01, 2013, 06:34:18 AM by Jan Gruuthuse
Yes you can: start ubuntu software center. In top right hand corner you have the search field. enter there avidemux3, software center should now show the installed avidemux3 parts that you could uninstall.
Try r8524 see if this improves the situation.
If not can you give more detail what videos appear to be running fast?
source video codec and its fps
used encoding video codec and set fps?
These info could give a clue what is going on for developer(s)

dorpm

April 01, 2013, 03:27:40 PM #2 Last Edit: April 01, 2013, 04:17:39 PM by dorpm
I use avidemux for cutting HD videos which are recorded with a DVB-S adapter. The only thing I do is to start "avidemux3_gtk", then I select "copy" for "video output" and set the "A" and "B" markers to cut off the unnecessary part at the beginning and the end. With this settings I get an avi-file. This worked fine up to version 2.6.2 but with 2.6.3 the video runs too fast. I cannot say how many fps are set because I don't change these settings.

With r8524 there is also no improvement.

Florian

mean

Could you share a sample of your dvb-s stream + the settings you are using ?

Jan Gruuthuse

avidemux3_gtk, have you tried with avidemux3_qt. Are you using your own builds? GTK is no longer in debs I upload.

dorpm

Not so easy. The dvb-s file is about 16GB but I will attach a screenshot of the settings.

BTW: I have recognized that it works fine when I set the videooutput to xvid4. But the the re-encoding takes hours...

@Jan: In Ubuntu I only have "avidemux3_gtk" or with the debs from r8524 "avidemux3_qt4". But obviously there is no difference.

Florian

mean

And if you output to mpegTS ?
My guess is that the source is field interlaced

Jan Gruuthuse

@mean: 1HD germany should be 720p?

@dorpm: that is not so obvious: gtk development in avidemux is on ice.
see if you can cut: Cut TS sample
or just make a 5 second recording

dorpm

Unfortunately there is no "mpegTS" output (see attached screenshot).

At http://www.shaun.bplaced.net/misc/sample.ts you can find a dvb-s sample.

Florian

mean

Use avidemux 2.6.3 or a nightly
That is probably already fixed
http://avidemux.org/nightly

dorpm

I currently use 2.6.3 and on nightly there is no 64 bit for linux.  ;)

Florian

Jan Gruuthuse


mean

Mpeg TS (or PS) is in the output format pulldown menu
use it instead of avi for testing

dorpm

Oh sorry I was a little bit blind. Now I have found the "output format" option below the "video format". Setting it to "Mpeg TS Muxer" solves the isue. Thanks a lot.  :) :) :)

Florian

Jan Gruuthuse

Yeah is only avi issue, the effect is more like watching the old charlie chaplin slapsticks:
The soldiers are not walking but rather kind of jumping instead.
20 MB download: http://rapidshare.com/files/2095002499/test8528.avi