Author Topic: Cut file then problem with end time in mediaplayer but not in vlc  (Read 1706 times)

starcraft04

  • Newbie
  • *
  • Posts: 3
Hi all,

I trim a video which is in h264 and the smaller video is only 5 minutes. The problem is that when I open it after in Mediaplayer classic, the end time is showing like 8 hours. So when I seek, it crashes. And if I open it in Windows media player, it doesn't show the video, only the sound. But when I open it with VLC, it runs just fine.

Could you please help me in finding where I could tweak something so that I don't have this problem anymore?

I am using Windows 8 64 bit with Avidemux 2.6.6 32 bits (maybe that's the problem) and I am only doing a copy video, copy audio, selecting the part I want to have and then save. I use the lavcodec and AVI Muxer.

Thanks,

John.

starcraft04

  • Newbie
  • *
  • Posts: 3
Re: Cut file then problem with end time in mediaplayer but not in vlc
« Reply #1 on: October 21, 2013, 09:04:14 PM »
After a lot of testing, I have seen that this is because in the output I have to select MP4.

Now it works fine when I select this instead of AVI.

Hope this will help other people :).

John.

AQUAR

  • Hero Member
  • *****
  • Posts: 1077
Re: Cut file then problem with end time in mediaplayer but not in vlc
« Reply #2 on: October 22, 2013, 12:52:02 AM »
AVI is simply not the best container for holding AVC video.
And it does not work with some of the advanced AVC options.

MKV is a good general purpose media container.