Author Topic: 2.6.9. can´t encode FRAPS files and no connection to avs proxy  (Read 6361 times)

El_Butcho

  • Newbie
  • *
  • Posts: 4
Hi @all,

downloaded the new Avidemux 2.6.9 because of the x265-support and discovered that i cannot encode files that were recorded with FRAPS. As soon as the encoding process starts Avidemux freezes.
So I tried to connect to AVS Proxy GUI to get my frames (used avsproxy in the nightly builds because the nightly build could not open Fraps files) but I get an error message "Cannot find a demuxer for ADM_AVS_PROXY" (and yes, avsproxy is running  ;) ). Tried it on two different machines (Win 7 64-Bit and Win 7 32-Bit) but no luck. The nightly build instead works like a charm with the avsproxy gui.

Please correct me if i am wrong but it also seems that the avsproxy GUI isn´t included in the installer anymore? I had to use the old one from the 2.6.8 install.

So for the moment i stick with the nightly build and just want to bring this to your attention. Maybe it´s a nasty little bug in the 2.6.9 release.  ;D
« Last Edit: May 27, 2015, 03:33:51 PM by El_Butcho »

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10971
It's just a packaging issue
Thanks for reporting it


El_Butcho

  • Newbie
  • *
  • Posts: 4
No Problem. You´re welcome.

Maybe any idea on the crash with fraps files? Doesn´t seem like a problem with the installer.  ;D

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10971
i would need a sample video

El_Butcho

  • Newbie
  • *
  • Posts: 4
Here´s a 15 sec capture with Fraps 3.5.7. It also includes the settings file i use to encode to x265.

http://www.gfx-maniac.de/tmp/fraps_test.zip

Sorry for the filesize...nearly uncompressed fraps footage, you know  :o :)

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10971
Both problem fixed, build in progress (64 bits)

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
nice job, working here:

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Could there be a kind of index counter issue?:
Code: [Select]
[lavc] Probably pseudo black frame...
[decompressImage] NoPicture
 [DecodeNextPicture]  Decoding error for frame 913, not necessarily a problem
 Percent:75
[lavc] Probably pseudo black frame...
[decompressImage] NoPicture
 [DecodeNextPicture]  Decoding error for frame 915, not necessarily a problem
 [lavc] Probably pseudo black frame...
[decompressImage] NoPicture
 [DecodeNextPicture]  Decoding error for frame 916, not necessarily a problem
 Percent:75
 [DecodeNextPicture]  getFrame failed for frame 918
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 919
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 920
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 921
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 922
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 923
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 924
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 925
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 926
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 927
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 928
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 929
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 930
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 931
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 932
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 933
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 934
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 935
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 936
  [nextPictureInternal]  Next picture failed
  [DecodeNextPicture]  getFrame failed for frame 937
  [nextPictureInternal]  Next picture failed
  [nextPictureInternal]  nextPictureInternal Failed
  [nextPictureInternal]  while looking for 15283333 us, 15283 ms
 ReadIndex:320, WriteIndex:328
Edcache content[0]: PTS : 14966666 us14966 ms
Edcache content[1]: PTS : 15016666 us15016 ms
Edcache content[2]: PTS : 15033333 us15033 ms
Edcache content[3]: PTS : 15100000 us15100 ms
Edcache content[4]: PTS : 15116666 us15116 ms
Edcache content[5]: PTS : 15200000 us15200 ms
Edcache content[6]: PTS : 15233333 us15233 ms
Edcache content[7]: PTS : 15283333 us15283 ms
 [nextPicture]  Cannot get next picture. Last segment
  [getNextFrameAs]  [Bridge] Base did not get an image
  [runAction]  Video Thread, no more data
  [runAction]  Exiting video thread loop
 Percent:76
Percent:76
Percent:76
Percent:77
Percent:77
Percent:78
Percent:78
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:78
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:78
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:79
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:79
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:79
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:79
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:80
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:80
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:80
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:81
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:81
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:81
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:81
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:82
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:82
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image
  [encode]  Flushing delayed frames
 Percent:82
 [getNextFrameAs]  Audio thread stopped, no more data
  [encode]  [x265] Cannot get next image

still some time to run.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Hmmm, endresult was not good here. 21 minutes encoding. Plenty frames got scrambled: download 55 MB:

attached terminal output from avidemux 2.6.9 a082314    [Core/editor] Handle properly not coded frame (fraps).



« Last Edit: May 31, 2015, 05:34:37 AM by Jan Gruuthuse »

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10971
works fine here
???

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Your correct: plays fine in avidemux 2.6.9
My bad  :-[  VLC 2.1.6 issue combined with ubuntu 14.0.2:
Quote
unmet dependencies:
 libdvdnav-dev : Depends: libdvdnav4 (= 4.2.1-3) but 5.0.0-1~ubuntu14.04.1~ppa1 is to be installed
 libdvdread-dev : Depends: libdvdread4 (= 4.2.1-2ubuntu1) but 5.0.0-1ubuntu1~ubuntu14.04.1~ppa1 is to be installed
see if I can figure this out

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
I only have corrupt video with the included tinypy settings file from fraps_test.zip, takes over 21 minutes.
When converting default settings from avidemux and rencoding to x265 all is ok (less then 3 minutes).
Corrupt Video:
Code: [Select]
General
Unique ID                                : 6165170739689039301523165234798723702 (0x4A35E62BA95FB754AB613239EF70276)
Complete name                            : /home/jan/Videos/testtinpy.mkv
Format                                   : Matroska
Format version                           : Version 4 / Version 2
File size                                : 51.9 MiB
Duration                                 : 15s 800ms
Overall bit rate                         : 27.5 Mbps
Writing application                      : Lavf56.25.101
Writing library                          : Lavf56.25.101

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Codec ID                                 : V_MPEGH/ISO/HEVC
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Variable
Original frame rate                      : 60.000 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Writing library                          : x265 1.5+1-32d72a0285e0:[Linux][GCC 4.8.2][64 bit]
Encoding settings                        : wpp / ctu=64 / tu-intra-depth=1 / tu-inter-depth=1 / me=4 / subme=7 / merange=64 / no-rect / no-amp / max-merge=2 / temporal-mvp / no-early-skip / no-fast-cbf / rdpenalty=0 / no-tskip / tskip-fast / strong-intra-smoothing / no-lossless / no-cu-lossless / no-constrained-intra / no-fast-intra / open-gop / interlace=0 / keyint=250 / min-keyint=25 / scenecut=40 / rc-lookahead=60 / bframes=16 / bframe-bias=0 / b-adapt=1 / ref=16 / weightp / weightb / aq-mode=2 / aq-strength=1,00 / cbqpoffs=0 / crqpoffs=0 / rd=3 / psy-rd=1,00 / psy-rdoq=0,00 / signhide / lft / sao / no-sao-non-deblock / b-pyramid / cutree / rc=crf / crf=20,0 / qcomp=0,60 / qpmin=0 / qpmax=51 / qpstep=4 / ipratio=1,40 / pbratio=1,30
Default                                  : Yes
Forced                                   : No

Audio
ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : A_AAC
Duration                                 : 15s 800ms
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Compression mode                         : Lossy
Default                                  : Yes
Forced                                   : No
Good Videon, default settings X265:
Code: [Select]
General
Unique ID                                : 153200923817331484880934315869122323755 (0x73416CB7177DFC0BF65B2491D04BE52B)
Complete name                            : /home/jan/Videos/test2.mkv
Format                                   : Matroska
Format version                           : Version 4 / Version 2
File size                                : 54.2 MiB
Duration                                 : 15s 366ms
Overall bit rate                         : 29.6 Mbps
Writing application                      : Lavf56.25.101
Writing library                          : Lavf56.25.101

Video
ID                                       : 1
Format                                   : HEVC
Format/Info                              : High Efficiency Video Coding
Format profile                           : Main@L4.1
Codec ID                                 : V_MPEGH/ISO/HEVC
Width                                    : 1 920 pixels
Height                                   : 1 080 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Variable
Original frame rate                      : 60.000 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Writing library                          : x265 1.5+1-32d72a0285e0:[Linux][GCC 4.8.2][64 bit]
Encoding settings                        : wpp / ctu=64 / tu-intra-depth=1 / tu-inter-depth=1 / me=3 / subme=5 / merange=16 / no-rect / no-amp / max-merge=2 / temporal-mvp / early-skip / no-fast-cbf / rdpenalty=0 / no-tskip / tskip-fast / strong-intra-smoothing / no-lossless / no-cu-lossless / no-constrained-intra / no-fast-intra / open-gop / interlace=0 / keyint=250 / min-keyint=25 / scenecut=40 / rc-lookahead=40 / bframes=3 / bframe-bias=0 / b-adapt=1 / ref=3 / weightp / weightb / aq-mode=2 / aq-strength=1,00 / cbqpoffs=0 / crqpoffs=0 / rd=3 / psy-rd=1,00 / psy-rdoq=0,00 / signhide / lft / sao / no-sao-non-deblock / b-pyramid / cutree / rc=crf / crf=20,0 / qcomp=0,60 / qpmin=0 / qpmax=51 / qpstep=4 / ipratio=1,40 / pbratio=1,30
Default                                  : Yes
Forced                                   : No

Audio
ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : A_AAC
Duration                                 : 15s 366ms
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Compression mode                         : Lossy
Language                                 : unknown
Default                                  : Yes
Forced                                   : No

« Last Edit: May 31, 2015, 10:38:51 AM by Jan Gruuthuse »