Author Topic: MPEG4 AVC (x264) in latest builds  (Read 7876 times)

quantumchaos451

  • Newbie
  • *
  • Posts: 9
MPEG4 AVC (x264) in latest builds
« on: June 16, 2015, 08:14:37 AM »
In 2.6.8 (150131 build) there were three options for Mpeg4, namely:
Mpeg4 ASP (ff)
Mpeg4 ASP (xvid4)
Mpeg4 AVC (x264)

In the latest builds of 2.6.9 (150606) the last option has disappeared and we now have:
Mpeg4 ASP (ff)
Mpeg4 ASP (xvid4)
and the new option
H264 (ff/nvidia)

Is there any particular reason why the Mpeg4  AVC (x264) has gone? It's still the one I use most frequently but would also like to be able to play with the new x265 as well, which I currently can't do without uninstalling the latest and reverting back to the 150131 build.

Thanks

mean

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10974
Re: MPEG4 AVC (x264) in latest builds
« Reply #1 on: June 16, 2015, 02:27:12 PM »
maybe a packaging issue

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6053
Re: MPEG4 AVC (x264) in latest builds
« Reply #2 on: June 16, 2015, 02:27:23 PM »
That would be strange? certain you did not overlook? Did just check the latest:

Avidemux v2.6.10 (150610_329d81eb49b) ubuntu 14.04.2 64-bit
« Last Edit: June 16, 2015, 02:30:31 PM by Jan Gruuthuse »

quantumchaos451

  • Newbie
  • *
  • Posts: 9
Re: MPEG4 AVC (x264) in latest builds
« Reply #3 on: June 16, 2015, 08:52:55 PM »
This is with 150610 build:

quantumchaos451

  • Newbie
  • *
  • Posts: 9
Re: MPEG4 AVC (x264) in latest builds
« Reply #4 on: June 17, 2015, 01:14:08 AM »
Extra info:

scott@alpha:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 15.04
Release:        15.04
Codename:       vivid

scott@alpha:~$ uname -a
Linux alpha 3.19.0-21-generic #21-Ubuntu SMP Sun Jun 14 18:31:11 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

scott@alpha:~$ dpkg -l | grep avidemux
ii  avidemux-cli                                  1:2.5.4-0ubuntu14                                     amd64        a free video editor - command line version
ii  avidemux-common                               1:2.5.4-0ubuntu14                                     all          a free video editor - Internationalization files
ii  avidemux-plugins-cli                          1:2.5.4-0ubuntu14                                     amd64        a free video editor - CLI plugins
ii  avidemux-plugins-common                       1:2.5.4-0ubuntu14                                     amd64        a free video editor - common files for plugins
ii  avidemux-plugins-qt                           1:2.5.4-0ubuntu14                                     amd64        a free video editor - Qt plugins
ii  avidemux-qt                                   1:2.5.4-0ubuntu14                                     amd64        a free video editor - QT version
ii  avidemux3-cli-runtime                         2.6.10-150610                                         amd64        Simple video editor,main program, command line version
ii  avidemux3-core-runtime                        2.6.10-150610                                         amd64        Simple video editor,core libraries
ii  avidemux3-plugins-cli-plugins                 2.6.10-150610                                         amd64        Simple video editor, plugins (CLI
ii  avidemux3-plugins-common-plugins              2.6.10-150610                                         amd64        Simple video editor, plugins (COMMON
ii  avidemux3-plugins-qt4-plugins                 2.6.10-150610                                         amd64        Simple video editor, plugins (QT4
ii  avidemux3-qt4-runtime                         2.6.10-150610                                         amd64        Simple video editor,main program qt4 version
ii  avidemux3-settings-settings                   2.6.10-150610                                         amd64        Simple video editor, settings
ii  libavidemux0                                  1:2.5.4-0ubuntu14                                     amd64        a free video editor - shared libraries

To revert to a build that does give me the Mpeg4 AVC option (eg 150131) requires me to just install the avidemux debs, nothing else.

My guess would be if it hasn't been removed is that it is looking for a particular version of a library which I don't have and hence not showing.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6053
Re: MPEG4 AVC (x264) in latest builds
« Reply #5 on: June 17, 2015, 05:05:43 AM »
You do have x264 installed?
Code: [Select]
x264 --version
Code: [Select]
x264 0.146.2538 121396c
built on Jun 11 2015, gcc: 4.8.2
x264 configuration: --bit-depth=8 --chroma-format=all
libx264 configuration: --bit-depth=8 --chroma-format=all
x264 license: GPL version 2 or later

and the library?
Code: [Select]
dpkg -l libx264*
Code: [Select]
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name              Version       Architecture  Description
+++-=================-=============-=============-========================================
ii  libx264-142:amd64 3:0.142.2491+ amd64         x264 video coding library
ii  libx264-dev:amd64 3:0.142.2491+ amd64         development files for libx264

if you need to build x264: Build x264 ubuntu 14.04.1 amd64
« Last Edit: June 17, 2015, 05:09:41 AM by Jan Gruuthuse »

quantumchaos451

  • Newbie
  • *
  • Posts: 9
Re: MPEG4 AVC (x264) in latest builds
« Reply #6 on: June 17, 2015, 05:54:38 AM »
scott@alpha:~$ x264 --version
x264 0.142.2495 6a301b6
(libswscale 3.0.0)
(libavformat 56.1.0)
(ffmpegsource 2.20.0.0)
built on Mar  4 2015, gcc: 4.9.2
configuration: --bit-depth=8 --chroma-format=all
x264 license: GPL version 2 or later
libswscale/libavformat/ffmpegsource license: GPL version 2 or later


scott@alpha:~$ dpkg -l libx264*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                      Version                   Architecture              Description
+++-=========================================-=========================-=========================-=======================================================================================
ii  libx264-123:amd64                         2:0.123.2189+git35cf912-1 amd64                     x264 video coding library
ii  libx264-142:amd64                         2:0.142.2495+git6a301b6-1 amd64                     x264 video coding library

quantumchaos451

  • Newbie
  • *
  • Posts: 9
Re: MPEG4 AVC (x264) in latest builds
« Reply #7 on: June 17, 2015, 08:56:45 AM »
Maybe this will help - attached output from starting avidemux3 from the command line:

Interestingly it doesn't vdpau even though it's installed.

scott@alpha:~/tmp/avidemux$ dpkg -l | grep libvd
ii  libvdpau-va-gl1:amd64                         0.3.4-2                                    amd64        VDPAU driver with OpenGL/VAAPI backend
ii  libvdpau1:amd64                               1.0-0ubuntu0~ppa0~vivid                    amd64        Video Decode and Presentation API for Unix (libraries)

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6053
Re: MPEG4 AVC (x264) in latest builds
« Reply #8 on: June 17, 2015, 10:48:30 AM »
vdpau requires preferable a nvidia gpu and the required driver for that video card.
Code: [Select]
vdpauinfo
Code: [Select]
display: :0   screen: 0
API version: 1
Information string: NVIDIA VDPAU Driver Shared Library  349.16  Tue Apr  7 23:46:22 PDT 2015

Video surface:

name   width height types
-------------------------------------------
420     4096  4096  NV12 YV12
422     4096  4096  UYVY YUYV

Decoder capabilities:

name               level macbs width height
-------------------------------------------
MPEG1                 0 65536  4080  4080
MPEG2_SIMPLE          3 65536  4080  4080
MPEG2_MAIN            3 65536  4080  4080
H264_MAIN            41 65536  4096  4096
H264_HIGH            41 65536  4096  4096
VC1_SIMPLE            1  8190  2048  2048
VC1_MAIN              2  8190  2048  2048
VC1_ADVANCED          4  8190  2048  2048
MPEG4_PART2_SP        3  8192  2048  2048
MPEG4_PART2_ASP       5  8192  2048  2048
DIVX4_QMOBILE         0  8192  2048  2048
DIVX4_MOBILE          0  8192  2048  2048
DIVX4_HOME_THEATER    0  8192  2048  2048
DIVX4_HD_1080P        0  8192  2048  2048
DIVX5_QMOBILE         0  8192  2048  2048
DIVX5_MOBILE          0  8192  2048  2048
DIVX5_HOME_THEATER    0  8192  2048  2048
DIVX5_HD_1080P        0  8192  2048  2048
...

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6053
Re: MPEG4 AVC (x264) in latest builds
« Reply #9 on: June 17, 2015, 10:53:32 AM »
Quote
[initGUI]  OpenGL enabled at built time, checking if we should run it..
[initGUI]  OpenGL not activated, not initialized
Probing for VDPAU...
Unable to load [libvdpau.so]: libvdpau.so: cannot open shared object file: No such file or directory
[init]  Cannot load libvdpau.so
VDPAU not available
Probing for LIBVA...
[init]  [LIBVA] Initializing LibVA library ...
[displayXError]  LibVA Error : <vaInitialize(ADM_coreLibVA::display,&majv,&minv):unknown libva error>
[init]  VA: init failed
LIBVA not available
either those are not installed/not found/not supported by hardware/...
Perhaps you are running this on a virtual system?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6053
Re: MPEG4 AVC (x264) in latest builds
« Reply #10 on: June 17, 2015, 01:40:10 PM »
also wondering about x264 --version:
Quote
x264 0.146.2538 121396c
libx264 configuration: --bit-depth=8 --chroma-format=all
versus
Quote
x264 0.142.2495 6a301b6
(libswscale 3.0.0)
(libavformat 56.1.0)
(ffmpegsource 2.20.0.0)
have you followed the link build x264 in Reply #5?

quantumchaos451

  • Newbie
  • *
  • Posts: 9
Re: MPEG4 AVC (x264) in latest builds
« Reply #11 on: June 18, 2015, 09:38:23 AM »
OK. Tracked down the various issues.

vdpau was not being found because it appears the nvidia driver hadn't installed properly. It was loaded according to lsmod but reinstalled it and vdpauinfo started to give me some info.

The x264 version was the issue why Mpeg4 AVC (x264) was not displaying. Built the version from git and now it's showing.

Thanks for all your help and pointers in the right direction.

P.S. No, it's not a virtual machine.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6053
Re: MPEG4 AVC (x264) in latest builds
« Reply #12 on: June 18, 2015, 10:29:37 AM »
P.S. No, it's not a virtual machine.
Just did ask: Virtual computers don't allow (sometimes) direct hardware access.