Author Topic: No sound will playing video in Avidemux :(  (Read 3833 times)

shukero

  • Newbie
  • *
  • Posts: 6
No sound will playing video in Avidemux :(
« on: March 16, 2016, 11:55:50 PM »
Hi everyone,

I just switched from a nightly build of Avidemux (2.6.9) to the current x64 2.6.12 and I found out that I do not have any audio when I play the video in the video editor itself. However; when I play the video outside of avidemux; the sound is there. Please help!

See youtube video below: (WARNING! some swearing involved in the video)
https://youtu.be/kwavUBT3d8A

Someone please help! I love editing my videos on AviDemux!

On a separate note, does anyone know if there are any plans in the works for audio editing in the program scheduled for future releases?

Thanks!
~Mike

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: No sound will playing video in Avidemux :(
« Reply #1 on: March 17, 2016, 05:44:26 AM »
Can you upload the video with audio issue to web service? Need to check if problem is with that type of video?
Is avidemux using the same audio device / audio chain as the windows media player. If I remember correctly audio behaviour can be modified in windows through filters?
See preferences marked in screen shot greenish.
Also wonder why audio peak indicator hangs at peak audio see the bottom right hand corner marked in screen shot reddish.

ps:- Use a free dropbox account, mega or similar webservice (free public access, without registration to download your uploaded video) thank you.



shukero

  • Newbie
  • *
  • Posts: 6
Re: No sound will playing video in Avidemux :(
« Reply #2 on: March 17, 2016, 11:15:18 AM »
Can you upload the video with audio issue to web service? Need to check if problem is with that type of video?
Is avidemux using the same audio device / audio chain as the windows media player. If I remember correctly audio behaviour can be modified in windows through filters?
See preferences marked in screen shot greenish.
Also wonder why audio peak indicator hangs at peak audio see the bottom right hand corner marked in screen shot reddish.

ps:- Use a free dropbox account, mega or similar webservice (free public access, without registration to download your uploaded video) thank you.

Thank you! I went into my audio options and that was it! The audio option was set to "Dummy" instead of Win32. As soon as I changed it to win32 it now works perfectly :)

Thank you VERY VERY MUCH!

~Mike

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6060
Re: No sound will playing video in Avidemux :(
« Reply #3 on: March 17, 2016, 12:02:39 PM »
You're welcome.

On a separate note, does anyone know if there are any plans in the works for audio editing in the program scheduled for future releases?
Don't think any changes are expected soon audio wise.

Check Out Menu -> Audio -> Select Track -> Audio Tracks Configuration -> each track (upto 4) -> dropdown menus
- [copy]
- [Configure]
- [Filters]

If still needed more:
Possible work flow: edit video footage, once this is complete.
drag and drop completed video onto audacity, with for windows the audacity additional FFmpeg import/export library
this will extract audio track
do what ever you want to do audiowise
export audio back to the needed format wanted for avidemux.
add or replace the edited audio track.
« Last Edit: March 17, 2016, 12:27:42 PM by Jan Gruuthuse »