Author Topic: Unable to load jpegs created in gimp.  (Read 14662 times)

3d420

  • Jr. Member
  • **
  • Posts: 53
Re: Unable to load jpegs created in gimp.
« Reply #45 on: November 25, 2016, 03:40:18 PM »
Here is a screenshot of the contents of the avidemux2 folder in my home folder...

3d420

  • Jr. Member
  • **
  • Posts: 53
Re: Unable to load jpegs created in gimp.
« Reply #46 on: November 25, 2016, 03:50:07 PM »
I apologize for taking up your time. From my perspective, I have spent four days trying to make this work using only the instructions I have gotten here. I have watched as you argue over how I should proceed, while not understanding what the argument is even about. Please don't expect me to understand something that is COMPLETELY NEW to me. I am proud of the fact that I was able to find the terminal. I understand this is hard for you too, but all I wanted to do is open a jpeg file. I had avidemux installed. I was able to load most files without any problem. Now I have only a file in my home folder that I don't understand, and a help forum that thinks I'm a jerk for asking them to actually help.
Is this how all noobs are helped?

3d420

  • Jr. Member
  • **
  • Posts: 53
Re: Unable to load jpegs created in gimp.
« Reply #47 on: November 25, 2016, 04:35:37 PM »
As you can see in the screenshot, there is a buildCore folder, and a foreignBuilds folder. The install folder is empty.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 6051
Re: Unable to load jpegs created in gimp.
« Reply #48 on: November 25, 2016, 04:58:02 PM »
Arguing? Providing information to you and each other. Figuring out what is going on. Eager to get this working on your computer.
in terminal:
Code: [Select]
bash --versionshould have some reply like
Quote
GNU bash, version ....

When you got reply that bash is installed, still in terminal:
Code: [Select]
cd ~/avidemux2
Code: [Select]
dirresponse should be:
Code: [Select]
addons      bootStrapHaikuOS.bash     createDebFromSourceUbuntu.bash
appImage      bootStrapOsx.bash        createRpmFromSourceFedora.bash
AUTHORS      bootStrapOsx_EC.bash      debs
autononreg      bootStrapOsx_qt5.bash     Doxyfile
avidemux      bootStrapOsx_Sierra.bash  foreignBuilds
avidemux2.desktop      bootStrapOsx_SL.bash      install
avidemux_core      buildCli        License.txt
avidemux_icon.png      buildCore        License.txt.in
avidemux_plugins      buildPluginsCLI        makeAppImage.sh
bootStrap.bash      buildPluginsCommon        man
bootStrapCrossMac106.sh      buildPluginsQt4        myOwnPlugins
bootStrapCrossMingw_w32Qt5_clang.sh  buildPluginsSettings      README
bootStrapCrossMingw_w32Qt5_mxe.sh    buildQt4        scripts
bootStrapCrossMingw_w32Qt5.sh      cmake        update_license.sh
bootStrapCrossMingw_w64Qt5.sh      COPYING

so you're now in the correct folder, still in terminal:
Code: [Select]
bash createDebFromSourceUbuntu.bashplenty of code should be scrolling along and should end similar to a successful build ends like this







« Last Edit: November 25, 2016, 04:59:49 PM by Jan Gruuthuse »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Unable to load jpegs created in gimp.
« Reply #49 on: November 25, 2016, 05:04:15 PM »
This means the build failed in early stages (maybe even just in the configuration part), i.e. we should proceed with

Code: [Select]
cd ~/avidemux2 && bash bootStrap.bash --deb 2>&1 | tee ~/adm-build.log
part to see actual error messages.

Please don't expect me to understand something that is COMPLETELY NEW to me. I am proud of the fact that I was able to find the terminal. I understand this is hard for you too, but all I wanted to do is open a jpeg file. I had avidemux installed. I was able to load most files without any problem. Now I have only a file in my home folder that I don't understand, and a help forum that thinks I'm a jerk for asking them to actually help.
Is this how all noobs are helped?

I'm sorry, but you receive opulent luxurious support just now. Please understand that we all started where you are now and evolved thanks to our own efforts while working in science, arts or whatever. Don't expect any sympathy for refusal to invest some time, effort and thought to learn something entirely new to you.

3d420

  • Jr. Member
  • **
  • Posts: 53
Re: Unable to load jpegs created in gimp.
« Reply #50 on: November 25, 2016, 05:16:52 PM »
I appreciate your assistance. Please forgive my not understanding everything.
Here is my result.
bash createDebFromSourceUbuntu.bash
This will install all the necessary packages and build avidemux, it will take 20 mn or so
Please enter your password
[sudo] password for ogf:
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libx265-dev
Compiling avidemux
bootStrap.bash: line 149: cmake: command not found
CMAKE Version :
Build configuration :
******************* :
Build type :
Release build
    Core will be built
     Gtk will be skipped
    Qt5 will be built
    Cli will be built
    Plugins will be built
**BootStrapping avidemux **
Top dir : /home/ogf/avidemux2
Fake installation directory=/home/ogf/avidemux2/install
Cleaning packages
** CORE **
Building buildCore from ../avidemux_core with EXTRA=<>, DEBUG=<>
bootStrap.bash: line 56: cmake: command not found
** Failed at cmakeZ**
Installing avidemux...
createDebFromSourceUbuntu.bash: line 13: cd: debs: No such file or directory

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Unable to load jpegs created in gimp.
« Reply #51 on: November 25, 2016, 06:06:10 PM »
This means some build dependencies are missing. Please first try to install cmake by running

Code: [Select]
sudo apt-get update
sudo apt-get install cmake

and post the output you get in the terminal from these two commands.

libx265-dev is only needed for being able to encode videos using the modern h265 codec. If your hardware is so old that it can't* run a 64 bit Linux distribution, then a missing x265 encoder is your last concern.

*) Would you mind actually posting the output of

Code: [Select]
lscpu
to learn the capabilities of the CPU please?

3d420

  • Jr. Member
  • **
  • Posts: 53
Re: Unable to load jpegs created in gimp.
« Reply #52 on: November 25, 2016, 06:12:46 PM »
sudo apt-get update
[sudo] password for ogf:
Ign http://packages.linuxmint.com rebecca InRelease
Ign http://extra.linuxmint.com rebecca InRelease                               
Hit http://packages.linuxmint.com rebecca Release.gpg                         
Hit http://extra.linuxmint.com rebecca Release.gpg                             
Ign http://ppa.launchpad.net trusty InRelease                                 
Ign http://archive.canonical.com trusty InRelease                             
Ign http://archive.ubuntu.com trusty InRelease                                 
Hit http://packages.linuxmint.com rebecca Release                             
Hit http://extra.linuxmint.com rebecca Release                                 
Hit http://ppa.launchpad.net trusty Release.gpg                               
Get:1 http://archive.ubuntu.com trusty-updates InRelease [65.9 kB]             
Hit http://packages.linuxmint.com rebecca/main i386 Packages                   
Hit http://extra.linuxmint.com rebecca/main i386 Packages                     
Hit http://ppa.launchpad.net trusty Release                                   
Hit http://packages.linuxmint.com rebecca/upstream i386 Packages               
Hit http://ppa.launchpad.net trusty/main Sources                               
Hit http://packages.linuxmint.com rebecca/import i386 Packages                 
Hit http://archive.canonical.com trusty Release.gpg                           
Hit http://ppa.launchpad.net trusty/main i386 Packages                         
Hit http://archive.canonical.com trusty Release                               
Hit http://archive.ubuntu.com trusty Release.gpg                               
Get:2 http://archive.ubuntu.com trusty-updates/main i386 Packages [880 kB]     
Get:3 http://security.ubuntu.com trusty-security InRelease [65.9 kB]           
Ign http://extra.linuxmint.com rebecca/main Translation-en_US                 
Ign http://extra.linuxmint.com rebecca/main Translation-en                     
Hit http://archive.canonical.com trusty/partner i386 Packages                 
Hit http://archive.canonical.com trusty/partner Translation-en                 
Get:4 http://security.ubuntu.com trusty-security/main i386 Packages [516 kB]   
Ign http://ppa.launchpad.net trusty/main Translation-en_US                     
Get:5 http://security.ubuntu.com trusty-security/restricted i386 Packages [13.1 kB]
Ign http://ppa.launchpad.net trusty/main Translation-en                       
Get:6 http://security.ubuntu.com trusty-security/universe i386 Packages [144 kB]
Get:7 http://security.ubuntu.com trusty-security/multiverse i386 Packages [4,289 B]
Hit http://security.ubuntu.com trusty-security/main Translation-en             
Hit http://security.ubuntu.com trusty-security/multiverse Translation-en       
Hit http://security.ubuntu.com trusty-security/restricted Translation-en       
Ign http://packages.linuxmint.com rebecca/import Translation-en_US             
Hit http://security.ubuntu.com trusty-security/universe Translation-en       
Ign http://packages.linuxmint.com rebecca/import Translation-en               
Ign http://packages.linuxmint.com rebecca/main Translation-en_US
Ign http://packages.linuxmint.com rebecca/main Translation-en
Ign http://packages.linuxmint.com rebecca/upstream Translation-en_US
Ign http://packages.linuxmint.com rebecca/upstream Translation-en
Get:8 http://archive.ubuntu.com trusty-updates/restricted i386 Packages [16.2 kB]
Get:9 http://archive.ubuntu.com trusty-updates/universe i386 Packages [389 kB]
Get:10 http://archive.ubuntu.com trusty-updates/multiverse i386 Packages [14.5 kB]
Get:11 http://archive.ubuntu.com trusty-updates/main Translation-en [445 kB]   
Get:12 http://archive.ubuntu.com trusty-updates/multiverse Translation-en [7,340 B]
Get:13 http://archive.ubuntu.com trusty-updates/restricted Translation-en [3,842 B]
Get:14 http://archive.ubuntu.com trusty-updates/universe Translation-en [205 kB]
Hit http://archive.ubuntu.com trusty Release                                   
Hit http://archive.ubuntu.com trusty/main i386 Packages                       
Hit http://archive.ubuntu.com trusty/restricted i386 Packages                 
Hit http://archive.ubuntu.com trusty/universe i386 Packages                   
Hit http://archive.ubuntu.com trusty/multiverse i386 Packages                 
Hit http://archive.ubuntu.com trusty/main Translation-en                       
Hit http://archive.ubuntu.com trusty/multiverse Translation-en                 
Hit http://archive.ubuntu.com trusty/restricted Translation-en                 
Hit http://archive.ubuntu.com trusty/universe Translation-en                   
Ign http://archive.ubuntu.com trusty/main Translation-en_US                   
Ign http://archive.ubuntu.com trusty/multiverse Translation-en_US             
Ign http://archive.ubuntu.com trusty/restricted Translation-en_US             
Ign http://archive.ubuntu.com trusty/universe Translation-en_US               
Fetched 2,770 kB in 15s (178 kB/s)                                             
Reading package lists... Done
ogf@freekbox:~/avidemux2$ sudo apt-get install cmake
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  avidemux-common libavidemux0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  cmake-data libcurl3
Suggested packages:
  codeblocks eclipse
The following NEW packages will be installed:
  cmake cmake-data libcurl3
0 upgraded, 3 newly installed, 0 to remove and 175 not upgraded.
Need to get 3,492 kB of archives.
After this operation, 17.1 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu/ trusty-updates/main libcurl3 i386 7.35.0-1ubuntu2.10 [175 kB]
Get:2 http://archive.ubuntu.com/ubuntu/ trusty/main cmake-data all 2.8.12.2-0ubuntu3 [676 kB]
Get:3 http://archive.ubuntu.com/ubuntu/ trusty/main cmake i386 2.8.12.2-0ubuntu3 [2,641 kB]
Fetched 3,492 kB in 3s (1,106 kB/s)
Selecting previously unselected package libcurl3:i386.
(Reading database ... 174339 files and directories currently installed.)
Preparing to unpack .../libcurl3_7.35.0-1ubuntu2.10_i386.deb ...
Unpacking libcurl3:i386 (7.35.0-1ubuntu2.10) ...
Selecting previously unselected package cmake-data.
Preparing to unpack .../cmake-data_2.8.12.2-0ubuntu3_all.deb ...
Unpacking cmake-data (2.8.12.2-0ubuntu3) ...
Selecting previously unselected package cmake.
Preparing to unpack .../cmake_2.8.12.2-0ubuntu3_i386.deb ...
Unpacking cmake (2.8.12.2-0ubuntu3) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up libcurl3:i386 (7.35.0-1ubuntu2.10) ...
Setting up cmake-data (2.8.12.2-0ubuntu3) ...
Setting up cmake (2.8.12.2-0ubuntu3) ...
Processing triggers for libc-bin (2.19-0ubuntu6.9) ...
ogf@freekbox:~/avidemux2$ lscpu
Architecture:          i686
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 15
Stepping:              6
CPU MHz:               1000.000
BogoMIPS:              4324.52
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              4096K
ogf@freekbox:~/avidemux2$ lscpu
Architecture:          i686
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                2
On-line CPU(s) list:   0,1
Thread(s) per core:    1
Core(s) per socket:    2
Socket(s):             1
Vendor ID:             GenuineIntel
CPU family:            6
Model:                 15
Stepping:              6
CPU MHz:               2167.000
BogoMIPS:              4324.52
Virtualization:        VT-x
L1d cache:             32K
L1i cache:             32K
L2 cache:              4096K
ogf@freekbox:~/avidemux2$

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Unable to load jpegs created in gimp.
« Reply #53 on: November 25, 2016, 06:27:59 PM »
Thanks, a good catch: you must uninstall avidemux-common and libavidemux0 from the outdated ubuntu-provided package. Try the earlier command to build avidemux again.

You CPU is fully 64 bit compatible. I'd recommend you install a more up-to-date 64 bit Linux distribution.

3d420

  • Jr. Member
  • **
  • Posts: 53
Re: Unable to load jpegs created in gimp.
« Reply #54 on: November 25, 2016, 06:32:16 PM »
Try the earlier command to build avidemux again.
This one?

ls -d ~/avidemux2/build*

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Unable to load jpegs created in gimp.
« Reply #55 on: November 25, 2016, 07:50:11 PM »
No, that one just lists some content from the avidemux2 folder. The next one would be right, but we should first remove the libx265-dev entry which fails on Mint Rebecca and causes the subsequent failure of everything. Please open the createDebFromSourceUbuntu.bash file in a text editor (e.g. gedit; not LibreOffice Writer or such) and delete the offending entry, save the file and only then run

Code: [Select]
cd ~/avidemux2 && bash bootStrap.bash --deb 2>&1 | tee ~/adm-build.log

3d420

  • Jr. Member
  • **
  • Posts: 53
Re: Unable to load jpegs created in gimp.
« Reply #56 on: November 25, 2016, 07:56:25 PM »
cd ~/avidemux2 && bash bootStrap.bash --deb 2>&1 | tee ~/adm-build.log
CMAKE Version : 2.8.12
Cmake version >=2.8.7 doesnt need fakeroot
Build configuration :
******************* :
Build type :
Release build
    Core will be built
     Gtk will be skipped
    Qt5 will be built
    Cli will be built
    Plugins will be built
**BootStrapping avidemux **
Top dir : /home/ogf/avidemux2
Fake installation directory=/home/ogf/avidemux2/install
Cleaning packages
** CORE **
Building buildCore from ../avidemux_core with EXTRA=<>, DEBUG=<>
-- The C compiler identification is GNU 4.8.4
-- The CXX compiler identification is unknown
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.

#########################################
Configure for avidemux core libs Started
#########################################

-- [BUILD] EXTRA Cflags:
-- [BUILD] EXTRA CXXflags:
-- [BUILD] EXTRA LDflags:
-- [BUILD] Compiler CMAKE_CXX_COMPILER-NOTFOUND
-- [BUILD] Linker   /usr/bin/ld
-- Top Source dir is /home/ogf/avidemux2/avidemux_core/..

CMake Error: your CXX compiler: "CMAKE_CXX_COMPILER-NOTFOUND" was not found.   Please set CMAKE_CXX_COMPILER to a valid compiler path or name.

-- Checking Compiler support
-- *************************
CMake Error at /usr/share/cmake-2.8/Modules/CMakeCXXInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
CMake Error at /usr/share/cmake-2.8/Modules/CMakeCXXInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
CMake Error at /usr/share/cmake-2.8/Modules/CMakeCXXInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
CMake Error at /usr/share/cmake-2.8/Modules/CMakeCXXInformation.cmake:37 (get_filename_component):
  get_filename_component called with incorrect number of arguments
Call Stack (most recent call first):
  CMakeLists.txt:3 (PROJECT)


CMake Error: CMAKE_CXX_COMPILER not set, after EnableLanguage
CMake Error: Internal CMake error, TryCompile configure of cmake failed
CMake Error at /home/ogf/avidemux2/cmake/admDetermineSystem.cmake:78 (MESSAGE):
  CPU not supported
Call Stack (most recent call first):
  /home/ogf/avidemux2/cmake/admMainChecks.cmake:73 (INCLUDE)
  CMakeLists.txt:28 (include)


-- Configuring incomplete, errors occurred!
See also "/home/ogf/avidemux2/buildCore/CMakeFiles/CMakeOutput.log".
See also "/home/ogf/avidemux2/buildCore/CMakeFiles/CMakeError.log".
** Failed at cmakeZ**
ogf@freekbox:~/avidemux2$

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Unable to load jpegs created in gimp.
« Reply #57 on: November 25, 2016, 08:02:46 PM »
I'm sorry, I meant running

Code: [Select]
cd ~/avidemux2 && bash createDebFromSourceUbuntu.bash 2>&1 | tee ~/adm-build.log
(edited... struggling with a tiny smartphone display)
« Last Edit: November 25, 2016, 08:05:26 PM by eumagga0x2a »

3d420

  • Jr. Member
  • **
  • Posts: 53
Re: Unable to load jpegs created in gimp.
« Reply #58 on: November 25, 2016, 08:29:49 PM »
-- Configuring done
-- Generating done
-- Build files have been written to: /home/ogf/avidemux2/buildQt5
** Failed at make, result in /tmp/logbuildQt5**
Installing avidemux...
createDebFromSourceUbuntu.bash: line 13: cd: debs: No such file or directory
ogf@freekbox:~/avidemux2$

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3404
Re: Unable to load jpegs created in gimp.
« Reply #59 on: November 25, 2016, 09:48:45 PM »
Great, at least the core libs have been built. Now it is the Qt5 interface which fails. We'll investigate this in a few minutes. Meanwhile you would help a lot if you compress (.tar.bz2) and attach the file logbuildQt5 from the /tmp folder.

Please note that this is only possible if you haven't rebooted since that build attempt: all files in /tmp get usually deleted during a shutdown/reboot sequence.