Author Topic: 2.7.1 building on ubuntu 18.04 lts  (Read 91 times)

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5959
2.7.1 building on ubuntu 18.04 lts
« on: June 10, 2018, 12:41:19 PM »
Are these still used in avidemux?
- libmad0-dev - MPEG audio decoder development library
- libvpx-dev  - VP8 and VP9 video codec
- libzip-dev  - library for reading, creating, and modifying zip archives


eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1956
Re: 2.7.1 building on ubuntu 18.04 lts
« Reply #1 on: June 10, 2018, 01:01:39 PM »
If you build with the system libmad by adding the --with-system-libmad build option, you need libmad0-dev. libvpx-dev is not needed, libzip-dev may be required by some other dependencies.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5959
Re: 2.7.1 building on ubuntu 18.04 lts
« Reply #2 on: June 10, 2018, 01:14:59 PM »
Thanks, added libmad0-dev and libzip-dev

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1956
Re: 2.7.1 building on ubuntu 18.04 lts
« Reply #3 on: June 10, 2018, 03:02:35 PM »
Maybe I was unclear. You need libmad0-dev exclusively in the case when you add the --with-system-libmad option to the bootstrap script. Only then. You don't need it otherwise.

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5959
Re: 2.7.1 building on ubuntu 18.04 lts
« Reply #4 on: June 10, 2018, 03:19:08 PM »
Ok, adjusted 18.04 like you explained