Author Topic: Wmv to Mp4, no sound after conversion  (Read 386 times)

TheInvoker

  • Newbie
  • *
  • Posts: 7
Wmv to Mp4, no sound after conversion
« on: September 10, 2018, 10:28:45 AM »
I'm trying to convert a wmv file to mp4
i can't use "copy" in audio because i get the message "only AAC AC3 E-Ac3 supported for this file"

I tried to use AAC and AC3 (FDK and lav) but i always get no sound

With a different software i have no problems but i prefer Avidemux because i can do more things (like changing saturation and hue)

Codec of the audio source is WMAPRO

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2296
Re: Wmv to Mp4, no sound after conversion
« Reply #1 on: September 10, 2018, 11:23:56 AM »
Please try the latest nightly (a possibly relevant issue was fixed by the [demuxers/Asf] Do not lose audio on rewind commit shortly after the 2.7.1 release).

https://avidemux.org/nightly/win64/
« Last Edit: September 10, 2018, 11:28:59 AM by eumagga0x2a »

TheInvoker

  • Newbie
  • *
  • Posts: 7
Re: Wmv to Mp4, no sound after conversion
« Reply #2 on: September 10, 2018, 01:51:48 PM »
It doesn't work

I think Avidemux can't even recognize the audio when i open the file. I try to play the video in avidemux and there is no sound

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2296
Re: Wmv to Mp4, no sound after conversion
« Reply #3 on: September 10, 2018, 01:58:12 PM »
Well, it would have been useful to mention that Avidemux can't play the audio. Obviously, if Avidemux can't decode the audio track, it would not be able to re-encode it. Please provide a sample then.

TheInvoker

  • Newbie
  • *
  • Posts: 7
Re: Wmv to Mp4, no sound after conversion
« Reply #4 on: September 10, 2018, 03:18:08 PM »
Original File Audio

   Audio #1
      ID : 1
      Format : WMA
      Format profile : Pro
      Codec ID : 162
      Codec ID/Info : Windows Media Audio
      Description of the codec : Windows Media Audio 10 Professional - 440 kbps, 44 kHz, 2 channel 24 bit 2-pass VBR
      Duration : 37 min 58 s
      Bit rate mode : Variable
      Bit rate : 381 kb/s
      Channel(s) : 2 channels
      Sampling rate : 44.1 kHz
      Bit depth : 24 bits
      Stream size : 104 MiB (7%)
      NumberOfFrames : 5273

After using Avidemux: AAC (lav)

   Audio #2
      ID : 2
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format profile : LC
      Codec ID : 40
      Duration : 1 min 14 s
      Bit rate mode : Constant
      Bit rate : 3 710 b/s
      Maximum bit rate : 128 kb/s
      Channel(s) : 2 channels
      Channel positions : Front: L R
      Sampling rate : 44.1 kHz
      Frame rate : 43.066 FPS (1024 spf)
      Compression mode : Lossy
      Stream size : 34.0 KiB (0%)
      Default : Yes
      Alternate group : 1

After using different software

   Audio #2
      ID : 2
      Format : AAC
      Format/Info : Advanced Audio Codec
      Format profile : LC
      Codec ID : 40
      Duration : 2 min 0 s
      Bit rate mode : Variable
      Bit rate : 160 kb/s
      Channel(s) : 2 channels
      Channel positions : Front: L R
      Sampling rate : 48.0 kHz
      Frame rate : 46.875 FPS (1024 spf)
      Compression mode : Lossy
      Stream size : 2.30 MiB (9%)
      Title : Stereo / Stereo
      Default : Yes
      Alternate group : 1
      Encoded date : UTC 2018-09-10 14:47:10
      Tagged date : UTC 2018-09-10 14:47:10

With settings/filters i tried to reproduce the same data (Constant---->Variable, 44.1khz----->48khz,128----->160 kb/s) but nothing changes.

TheInvoker

  • Newbie
  • *
  • Posts: 7
Re: Wmv to Mp4, no sound after conversion
« Reply #5 on: September 10, 2018, 03:35:25 PM »
i get no audio when the audio codec of the original file is Windows media audio 10 professional
With Windows media audio 9.2 or 8 i have no problems.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2296
Re: Wmv to Mp4, no sound after conversion
« Reply #6 on: September 10, 2018, 03:38:05 PM »
Please provide a sample video, you can use a service like WeTransfer, Mega, Dropbox, Google Drive or similar. While unable to promise anything, without a sample to play with no improvement is possible.

alexrayne

  • Newbie
  • *
  • Posts: 8
Re: Wmv to Mp4, no sound after conversion
« Reply #7 on: October 01, 2018, 09:24:56 PM »
I also got problems with WMV: video WMV3 + audio WMAPRO
1) i try to cut some region of source into AVI by copy - produced avi cant be loaded by avidexmux with crash: WMAPRO cant be processed by avi filter-graph. videoplayers alo says that audio can`t be handled
2) try to save video into avi by video copy and audio in PCM - PCM stream generated, but it is silence
3) when save into avi with null video and PCM audio - PCM stream only 20ms length.

saving to mkv or mp4 container - always loose audio, or not compatible with WMV

but avidemux2.7.0 - can save PCM audio when save into avi with null video, and PCM audio. Looks like ver 2.7.1 now can`t handle WMApro totaly.




« Last Edit: October 01, 2018, 09:29:00 PM by alexrayne »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2296
Re: Wmv to Mp4, no sound after conversion
« Reply #8 on: October 02, 2018, 07:15:44 PM »
Please don't bother reporting problems with WMAPRO without providing a sample, thank you.