Author Topic: 2.7.1 crashes when I try to load any file  (Read 75 times)

Mikey

  • Newbie
  • *
  • Posts: 3
2.7.1 crashes when I try to load any file
« on: December 06, 2018, 10:16:01 AM »
I have installed the new version Avidemux 2.7.1 181107-09h47m_a5821f88c79.
My OS X is El Capitan 10.11.6

I can not open a videofile, Avidemux crashes then.
I have tried it with a flv and with a mp4 and a png too (the png only in order to try it, and when I try to open a pdf, it comes the correct message cannot find a demuxer)
But flv and mp4 bring to crash the app without message.

The videos are downloaded from Youtube, the flv in 2012, the mp4 in 2016.

I don't know if this problem is the same like this one in the upper thread.
But the nightly build also doesn't work.

So what can I do?
(Sorry for my bad English.)
« Last Edit: December 06, 2018, 01:57:46 PM by Mikey »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2290
Re: 2.7.1 crashes when I try to load any file
« Reply #1 on: December 06, 2018, 05:29:48 PM »
Probably a bad build? What happens if you remove libADM_dm_ts.dylib from the "demuxers" subfolder and retry to launch Avidemux and load the files? Obviously, Avidemux won't be able to load MPEG-TS files, but if the damage is limited to this plugin, the remaining part of the application should work fine.

(My Mac runs High Sierra, and official builds are generated on High Sierra too, so incompatibilities with older releases can't be rules out.)

Mikey

  • Newbie
  • *
  • Posts: 3
Re: 2.7.1 crashes when I try to load any file
« Reply #2 on: December 06, 2018, 10:46:06 PM »
The build was from here: https://avidemux.org/nightly/osx_highsierra/

Removing libADM_dm_ts.dylib from the "demuxers" subfolder doesn't bring anything.

Should I try a older version? But which?

Which damage do you mean?

P.S.
This http://avidemux.org/nightly/osx_qt5/ works.

But there is no sound  :(
« Last Edit: December 06, 2018, 11:38:59 PM by Mikey »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2290
Re: 2.7.1 crashes when I try to load any file
« Reply #3 on: December 06, 2018, 11:42:15 PM »
The build was from here: https://avidemux.org/nightly/osx_highsierra/

Sure.

Quote
Removing libADM_dm_ts.dylib from the "demuxers" subfolder doesn't bring anything.

Well, this was just a try. According to the log you provided, Avidemux crashed while probing the file using the MpegTS demuxer, so there might have been a chance that if the build was damaged, this damage were limited to this demuxer.

Quote
Should I try a older version?

I've just noticed that all older nightlies have been removed from the server  :o

Quote
Which damage do you mean?

Maybe a couple of bits flipped or such. The VM used to generate these builds is known to be not particularly stable.

Quote
This https://avidemux.org/nightly/osx/Avidemux2.6_r2015_06_10_886d36abb54.dmg works.

Well, that one is completely ancient.

If you have Homebrew and XCode installed (not sure whether the entire XCode is required, but we need at least the compiler, the linker and the headers), it should be rather easy to build Avidemux from source using the bootStrapOsx_Sierra.bash script. A most likely incomplete list of build deps includes git, cmake, yasm, qt, a52dec, faad2, xvid, x264, x265, fdk-aac and opus.

Mikey

  • Newbie
  • *
  • Posts: 3
Re: 2.7.1 crashes when I try to load any file
« Reply #4 on: December 06, 2018, 11:54:19 PM »
I had modified my post during you have answered:

So this http://avidemux.org/nightly/osx_qt5/ works too

And sound is present. Under preferences / audio I changed from Dummy to CoreAudio.

 :)
« Last Edit: December 07, 2018, 12:04:14 AM by Mikey »