Author Topic: Fix audio that becomes out of sync during playback  (Read 383 times)

oldmoviebuff

  • Newbie
  • *
  • Posts: 5
Fix audio that becomes out of sync during playback
« on: December 12, 2018, 01:36:44 AM »
Can I use Avidemux to fix audio that goes out of sync with video at some point during playback? Thank you for your help.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2717
Re: Fix audio that becomes out of sync during playback
« Reply #1 on: December 12, 2018, 09:59:33 AM »
It depends. What kind of desync do you experience? Does it occur all of a sudden and stays constant from that moment on so that you can counteract it with audio shift in Avidemux and the shift value necessary to establish correct sync stays unchanged starting with a certain time in the video? Or does it grow gradually throughout the video? Does video get ahead of audio or audio ahead of video?

If the video gets behind: is the hardware fast enough to decode the video? This is e.g. sometimes not the case with HEVC and my own PC – depending on the content of the video, the video playback may get behind when decoded on the CPU. Obviously, trying this on a more up-to-date computer proves that audio and video are really perfectly in sync (<50ms offset).

In general, you could cut video in copy mode in short segments, short enough for A-V sync to be maintained using a constant shift value for each one of the segments and than append all these segments. In case of a sudden but constant desync, you would need just two segments.

oldmoviebuff

  • Newbie
  • *
  • Posts: 5
Re: Fix audio that becomes out of sync during playback
« Reply #2 on: December 17, 2018, 01:48:17 AM »
I tried the process you suggestion but no joy. The desync is caused by a momentary loss / degradation of signal during recording of an OTA broadcast with an eMatic AT103B.

So when the eMatic gets to the corrupted spot during playback the sound goes out of sync. It does not matter what I do with Avidemux to resync the sound it still goes out of sync at the same spot. As an aside VLC Media player is not affected by this problem and even though I can clearly see where the video breaks up the sound remains in sync.

Thank you for your help.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2717
Re: Fix audio that becomes out of sync during playback
« Reply #3 on: December 17, 2018, 08:28:34 AM »
I thought that you experienced A/V desync in Avidemux.

If this eMatic device is the target platform, you could either delete the damaged GOP (group of pictures) or re-encode the full video then.

oldmoviebuff

  • Newbie
  • *
  • Posts: 5
Re: Fix audio that becomes out of sync during playback
« Reply #4 on: December 18, 2018, 01:41:19 AM »
Hi eumagga0x2a,

I could delete the corrupted portion as you suggest but that would leave a disconcerting gap.

I think I did try to re-encode but it didn’t satisfy because the eMatic would still desync audio from video at the problem spot. It is a picky device. If it had a better tuner that was more consistent at holding a signal there would be no corruption and nothing to fix.

IIUYC what settings would you suggest I use to re-encode? Please state Video Output, Audio Output and Output Format. I’m a beginner and don’t know what might fix the corruption.