Author Topic: Audio and synchronization problems.  (Read 334 times)

franz.b

  • Newbie
  • *
  • Posts: 7
Audio and synchronization problems.
« on: April 27, 2020, 12:21:22 PM »
Hi everyone,
I compressed a .ts video with ac3 audio and did a cut operation, but the resulting file has annoying audio clicks every 10-20 seconds. (1st problem)

So to get around the problem I extracted the audio and I cut it apart and then reunited it with avidemux, but synchronization is impossible both in the preview and in the final file. there seems to be no adherence between the delay value set and the result ... the behavior seems random! (2nd problem)

how can I solve one of the 2 problems?
Thaks in advance

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 4084
Re: Audio and synchronization problems.
« Reply #1 on: April 27, 2020, 07:12:21 PM »
Are you using the latest nightly available (currently from April 15, 2020)?

https://avidemux.org/nightly/win64/

If yes, please delete the corresponding *.idx2 file, start Avidemux, reproduce the issue (without closing Avidemux!), then close Avidemux, compress admlog.txt from %localappdata%\avidemux\ and attach it to your reply.

franz.b

  • Newbie
  • *
  • Posts: 7
Re: Audio and synchronization problems.
« Reply #2 on: April 27, 2020, 10:17:11 PM »
Thanks a lot!
before I used the staile version, now I have installed the last nightly and the problem 1 occurs again. I attach the requested file.

problem 2 occurred starting from the compressed mp4 file, so there is no longer the .idx2 file to remove. Do I have to follow the same procedure to attach the admlog.txt file? and what operations should I do? I tried several audio delays and then listened from the interface and saved the files to check the result with mpc-hc or vlc.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 4084
Re: Audio and synchronization problems.
« Reply #3 on: April 27, 2020, 10:34:56 PM »
Thanks, I meant only the problem with the original stream, no need to reproduce the one with external audio.

As suspected, you experience the problem with handling of timestamp discontinuities in MPEG-PS (not MPEG-TS) streams, like this one at line 480 of the log:

Quote
Code: [Select]
[handleScrReset] 21:26:58-779 DTS are going back, maybe several video appended ?
[handleScrReset] 21:26:58-779 Trying to correct with VOBU offset :00:00:00,736
[handleScrReset] 21:26:58-780 SCR reset, using vobu to correct. New time offset 00:00:00,736, position 0xfb400
[handleScrReset] 21:26:58-780 last Valid Dts 00:00:00,296
[handleScrReset] 21:26:58-781 TimeOffset is now 00:00:00,736

I ran into it myself just yesterday while working on the MpegPS demuxer. Will try to fix it, but no guarantee that I'll find the exact cause an a solution in time for 2.7.6.

franz.b

  • Newbie
  • *
  • Posts: 7
Re: Audio and synchronization problems.
« Reply #4 on: April 28, 2020, 09:36:55 AM »
Ok, thanks a lot!

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 4084
Re: Audio and synchronization problems.
« Reply #5 on: May 01, 2020, 10:48:45 AM »
Please try the latest nightly (currently 200430, MinGW-built for win64), the issue might be mostly fixed there (albeit not universally). Don't forget to delete existing .idx2 files created by older versions prior to opening the video files with the new one.