Author Topic: Avidemux 2.7.1 ignores Video Quality settings  (Read 334 times)

BG Davis

  • Full Member
  • ***
  • Posts: 103
Avidemux 2.7.1 ignores Video Quality settings
« on: March 15, 2019, 01:45:16 AM »
Shoot AVCHD video at 60p.  Resulting video is about 90MB.
Open video in Avidemux.
Cut into three segments (cut at key frames); save each segment.
Open each segment in Avidemux, one at a time.
Make each segment a different fps speed (slow motion effect @24fps, fast motion effect@200fps)
Save each segment as MP4, configured at highest quality.  Each segment is about 330MB. So far so good.
Open segment 1, append segment 2, append segment 3.
Set Configure at 'Video Size', select 18MB.
Save at MP4.

Result is MP4 video, three different speeds.  BUT size is only about 6MB, which results in very poor quality with lots of very bad JPEG artifacts.

Try the same except with Video Quality of each segment set to medium.
Same result.

I tried the above with various methods, including saving each segment at medium quality and saving each segment at a target video size, but the bottom line is that no matter what I do, the output is only a fraction of the chosen Video Size.

This has never happened to me before.  Only since I uninstalled 2.7.1, installed 2.7.2 twice but had to give up due to missing .dll file, then uninstalled 2.7.2 and reinstalled 2.7.1.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2807
Re: Avidemux 2.7.1 ignores Video Quality settings
« Reply #1 on: March 15, 2019, 08:06:18 AM »
Quote
This has never happened to me before.  Only since I uninstalled 2.7.1, installed 2.7.2 twice but had to give up due to missing .dll file, then uninstalled 2.7.2 and reinstalled 2.7.1.

As 2.7.1 is an unsupported old version now, please ensure first that all Avidemux installs are compeletely removed from your system, then install a supported version (I would suggest trying the MinGW release build 2.7.2 r190310 for now --> https://avidemux.org/nightly/win64/, should be a safe bet).

BG Davis

  • Full Member
  • ***
  • Posts: 103
Re: Avidemux 2.7.1 ignores Video Quality settings
« Reply #2 on: March 16, 2019, 12:15:00 AM »
Removed all previous versions from computer.
Installed 2.7.2 twice but had to give up due to supposedly missing .dll file
2.7.2 would not open.

Can't open v.2.7.2.
Get this message: "The program can't start because ADM_coreVideoCodec6.dll is missing from your computer."
I've uninstalled and reinstalled twice.
I can see the "missing" .dll file in the Avidemux folder, so it's definitely not missing from my computer.
Running Win 7.

BG Davis

  • Full Member
  • ***
  • Posts: 103
Re: Avidemux 2.7.1 ignores Video Quality settings
« Reply #3 on: March 16, 2019, 01:25:58 AM »
Quote
This has never happened to me before.  Only since I uninstalled 2.7.1, installed 2.7.2 twice but had to give up due to missing .dll file, then uninstalled 2.7.2 and reinstalled 2.7.1.

As 2.7.1 is an unsupported old version now, please ensure first that all Avidemux installs are compeletely removed from your system, then install a supported version (I would suggest trying the MinGW release build 2.7.2 r190310 for now --> https://avidemux.org/nightly/win64/, should be a safe bet).
Just tried 2.7.2 r190310, same result.  :-[

BG Davis

  • Full Member
  • ***
  • Posts: 103
Re: Avidemux 2.7.1 ignores Video Quality settings
« Reply #4 on: March 16, 2019, 01:45:14 AM »
ADDITIONAL INFORMATION:

The program will comply with the "Quality" settings (0 to 51).  And of course this does allow some control of file size.  But it is very much hit or miss for file size.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 2807
Re: Avidemux 2.7.1 ignores Video Quality settings
« Reply #5 on: March 16, 2019, 08:23:39 AM »
Please provide (compressed) admlog.txt from an Avidemux session reflecting all the editing steps you described above.

For best results, don't forget to add "resample fps" filter after appending videos with different fps. Mixed content is generally poorly supported.

I took a video A of 1 minute duration at 25 fps, 6 MiB in size, re-encoded with x264 at 29.97 (NTSC) fps (video B) and at 200 fps (video C) both with target size 14 MiB. I appended A+B+C then and re-encoded as-is and target size set to 32 MiB: the result was 44 MiB in size. Added "resample fps" with output fps set to 25: the result is an almost perfect hit (33 MiB in size).

BG Davis

  • Full Member
  • ***
  • Posts: 103
Re: Avidemux 2.7.1 ignores Video Quality settings
« Reply #6 on: March 16, 2019, 07:48:47 PM »
"For best results, don't forget to add "resample fps" filter after appending videos with different fps. Mixed content is generally poorly supported."
This was the solution, thanks!