Author Topic: Avidemux 2.7.2 VC++ x64 is crashing on startup  (Read 720 times)

Lord_D

  • Newbie
  • *
  • Posts: 3
Avidemux 2.7.2 VC++ x64 is crashing on startup
« on: March 22, 2019, 03:35:29 AM »
Code: [Select]
Problem signature:
  Problem Event Name:   BEX64
  Application Name: avidemux.exe
  Application Version:  0.0.0.0
  Application Timestamp:    5c84b506
  Fault Module Name:    ucrtbase.DLL
  Fault Module Version: 10.0.10586.1171
  Fault Module Timestamp:   59ae5010
  Exception Offset: 0000000000068609
  Exception Code:   c0000417
  Exception Data:   0000000000000000
  OS Version:   6.1.7601.2.1.0.256.48
  Locale ID:    1049
  Additional Information 1: 4609
  Additional Information 2: 46092924a7d0675c86f3981158d71af4
  Additional Information 3: 1e51
  Additional Information 4: 1e518d0fde961919be588ce55d2510aa

OS: Windows 7 x64 SP1
CPU: AMD Phenom II X6 1100T
GPU: AMD Radeon R9 270X

The recently released Avidemux 2.7.3 also crashes.
Log file does not appear.
The problem may be in the missing processor instructions such as SSE4 or SSSE3.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3466
Re: Avidemux 2.7.2 VC++ x64 is crashing on startup
« Reply #1 on: March 22, 2019, 07:12:07 AM »
Both VC++ builds run on my Windows 7 x64 SP1 installation on a PC with an AMD Athlon II X2 CPU, so missing SSE4 and SSSE3 can be excluded as contributing factor.

Maybe a MSVC++ redist is missing on your system? The list of installed applications in the control panel on my system includes the 2013 x64 12.0.21005 and the 2017 x64 14.15.26706 versions.

If it doesn't help and you need new fixes (very much recommended) and features right now, you could try a private MinGW build from the topic https://avidemux.org/smif/index.php/topic,18653.0.html (WeTransfer will automatically delete it in 6 days or so).


Lord_D

  • Newbie
  • *
  • Posts: 3
Re: Avidemux 2.7.2 VC++ x64 is crashing on startup
« Reply #2 on: March 22, 2019, 07:40:45 AM »
The installed MSVC2013 redist already has a newer version (12.0.30501).
MSVC2017 redist was older than you mentioned, and I updated it to 14.16.27027 (newest one from Microsoft site), but that doesn't help.
Anyway, thanks for the help and for the MinGW build.

Lord_D

  • Newbie
  • *
  • Posts: 3
Re: Avidemux 2.7.2 VC++ x64 is crashing on startup
« Reply #3 on: August 16, 2019, 01:17:18 PM »
Fixed in 2.7.4.
Probably with this fix:
Quote
Core:Fix MSVC++ builds do not run when the path to user directory contains non-ASCII characters