Author Topic: --nogui does not work  (Read 314 times)

StR

  • Newbie
  • *
  • Posts: 11
--nogui does not work
« on: May 04, 2019, 02:12:13 AM »
--nogui doesn't seem to have any afffect when videos are processed.

I've observed this in various versions of Avidemux. I don't remember for sure, - but it seems to me that in some versions it worked, in others - didn't.
For sure, in the 2.7.3 VC++ 64 bits it doesn't. The GUI window opens for each video that I process from a .bat script.

Here is the command that is ran by the .bat script:
"C:\Program Files\Avidemux 2.7 VC++ 64bits\avidemux.exe" --nogui --load "T:\PATH\IR4_9575.AVI" --audio-codec PCM --save-uncompressed-audio "AUDIO\IR4_9575.wav" --quit

I wonder if this option is deprecated in the current version.
(The tutorial that was written for 2.5 still shows that.)

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3295
Re: --nogui does not work
« Reply #1 on: May 04, 2019, 12:19:06 PM »
The --nogui option was completely ineffective until aprox. a month ago. Apart from that, it was never designed to turn the GUI application into a CLI one, even the old tutorial speaks of dialogs, not the main window. Its purpose was (and is) to suppress confirmation dialogs, automatically answering them with "No" (which made the option safe and rather useless) and after the recent change, with "Yes" (which made it dangerous and useful).

A clear case of unclear naming, --yes would be better.

StR

  • Newbie
  • *
  • Posts: 11
Re: --nogui does not work
« Reply #2 on: May 07, 2019, 02:57:01 AM »
Aah!...
Thank you for the explanation.

Avidemux is a very good and powerful tool, but even after more than 5 years of using it, I am not sure about some options.

And yes, --yes (or previously --no) would be (evidently!) a better choice. Moreover, switching from one behavior to the opposite would be less dangerous.