Keine selbstgespeicherten x265-Konfigurationen (.json) abrufbar

Started by tobias18, March 22, 2019, 11:17:25 pm

Previous topic - Next topic

tobias18

Hallo,

unter Win 7 findet sich seit avidemux 2.7.2 eine gespeicherte z.B. "MyConfiguration.json" nur noch unter Benutzer\Benutzername\AppData\Roaming\avidemux\pluginSettings\x265\3\ ohne dann allerdings im Programm selbst angezeigt zu werden...

Weiß jemand Abhilfe?

Vielen Dank im Voraus für Eure Hilfe.


eumagga0x2a

Der Speicherort ist korrekt. Der Eintrag sollte dann im Konfigurationsdialog des x265-Encoders in der Auswahlliste oben zur Verfügung stehen. Ist es nicht der Fall? Verhält sich ein MinGW Build wie in https://avidemux.org/smif/index.php/topic,18653.0.html angeboten anders?

tobias18

Vielen Dank!

Mit der entpackten Datei "avidemux_r190321-233132_win64Qt5" wird meine gespeicherte Konfigurationsdatei in Avidemux sofort angezeigt - so wie ich es von avidemux 2.7.1 und noch älteren Versionen gewohnt war.

eumagga0x2a

Danke fürs Testen. Das Problem dürfte im Konfigurationsdialog des x264 Encoders wohl ebenfalls präsent sein?

tobias18

Ja, ich kann jetzt nach einem Test bestätigen:

Auch eine eigene x264-Konfiguration, welche zwar als .json im entsprechenden Ordner abgespeichert wird, wird nicht zur Auswahl angezeigt.

eumagga0x2a

Vielleicht ist die Verwendung von ADM_listFile in x265Dialog::updatePresetList, zum Beispiel wie die Erweiterung ".json" übergeben wird, nicht mit VC++ verträglich? Ich kann das in der nächsten Zeit leider nicht ausprobieren.

tobias18

Vielleicht. Nur leider verstehe ich hierbei leider ausschließlich nur "Bahnhof"...

tribun77

Ich habe leider das selbe Problem. (allerdings bei x264)
Selbst wenn ich mit der Version 2.7.3 eine neue Konfiguration abspeichere, wird mir diese dann nicht angezeigt.

edit:
Ich habe mir jetzt ein aktuelles nightly gezogen (avidemux_r190427_win64Qt5_38). Hier werden mir wieder alle meine Konfigurationen angezeigt.

eumagga0x2a

In den MinGW-Builds wie der erwähnte Nightly war diese Funktion nie kaputt. Für VC++-Builds wurde sie vom Avidemux-Maintainer am 4. April gefixt.

tribun77

Quote from: eumagga0x2a on May 01, 2019, 09:19:34 am
In den MinGW-Builds wie der erwähnte Nightly war diese Funktion nie kaputt. Für VC++-Builds wurde sie vom Avidemux-Maintainer am 4. April gefixt.

Also ich habe meine Avidemux-Version 2.7.3 VC++-Build am 30.04.2019 hier geladen: https://www.fosshub.com/Avidemux.html (Avidemux 64-bit Windows Installer)
Und da besteht das Problem definitiv.

Oder wie meinst Du das?

eumagga0x2a

Quote from: tribun77 on May 02, 2019, 02:39:39 pm
Quote from: eumagga0x2a on May 01, 2019, 09:19:34 am
In den MinGW-Builds wie der erwähnte Nightly war diese Funktion nie kaputt. Für VC++-Builds wurde sie vom Avidemux-Maintainer am 4. April gefixt.

Also ich habe meine Avidemux-Version 2.7.3 VC++-Build am 30.04.2019 hier geladen: https://www.fosshub.com/Avidemux.html (Avidemux 64-bit Windows Installer)
Und da besteht das Problem definitiv.


Der Release ist vom 21. März, egal wann man den Installer herunterlädt. Dass eine zwei Wochen später gemachte Änderung darin nicht enthalten sein kann, ist nur natürlich. Für die mit Microsoft Visual Studio kompilierten Nightlies geht es da lang --> https://avidemux.org/nightly/vsWin64/

Der aktuell letzte Build ist von heute, den 2. Mai.

tribun77

Quote from: eumagga0x2a on May 02, 2019, 02:50:54 pm
Der Release ist vom 21. März, egal wann man den Installer herunterlädt. Dass eine zwei Wochen später gemachte Änderung darin nicht enthalten sein kann, ist nur natürlich. Für die mit Microsoft Visual Studio kompilierten Nightlies geht es da lang --> https://avidemux.org/nightly/vsWin64/

Der aktuell letzte Build ist von heute, den 2. Mai.

Ach so meinst Du das. Ja, das ist dann klar.