Author Topic: Avidemux loads but immediately crashes (in Linux Mint)  (Read 834 times)

Kelvin8

  • Newbie
  • *
  • Posts: 3
Avidemux loads but immediately crashes (in Linux Mint)
« on: July 18, 2019, 05:31:06 AM »
After performing a "Timeshift" system restore in Mint 19.1 Xfce 64 bit, Avidemux no longer runs. When opening it from the Mint menu, it loads for a second but then quickly closes. I tried removing and re-installing it from Software Manager but that didn't help. Does anyone have a fix? TIA
« Last Edit: July 18, 2019, 05:41:27 AM by Kelvin8 »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3466
Re: Avidemux loads but immediately crashes (in Linux Mint)
« Reply #1 on: July 18, 2019, 10:41:13 AM »
The first step to assess a problem with an application on Linux is to launch the executable from the terminal.

Code: [Select]
avidemux3_qt5 > ~/admlog.txt 2>&1
Please compress and attach admlog.txt from your home directory to your reply.

By the way, there are no distributor Avidemux packages for Ubuntu Bionic (AKA Mint 19.1), you must be using a third-party build (of which version of Avidemux?). The best way to install Avidemux is to build it from git master, trivial on Ubuntu/Mint.

Kelvin8

  • Newbie
  • *
  • Posts: 3
Re: Avidemux loads but immediately crashes (in Linux Mint)
« Reply #2 on: July 18, 2019, 05:24:47 PM »
Thanks. Admin log reads:

Code: [Select]
avidemux3_qt5: command not found

Installing from Software Manager (see screenshot) has always worked perfectly, even through several restores and an unrelated Avidemux reinstall or two, but performing the latest restore has apparently fatally damaged Avidemux/Mint somehow. I'm no expert but I would be surprised if it's installation related.
« Last Edit: July 18, 2019, 07:53:36 PM by Kelvin8 »

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3466
Re: Avidemux loads but immediately crashes (in Linux Mint)
« Reply #3 on: July 18, 2019, 08:40:44 PM »
This is a Flatpak, please ask whoever provided this package for support. I can readily support you in building Avidemux from source, alternatively you could run Avidemux from AppImage (the latest one from 2019-06-30).

Kelvin8

  • Newbie
  • *
  • Posts: 3
Re: Avidemux loads but immediately crashes (in Linux Mint)
« Reply #4 on: July 22, 2019, 03:49:37 PM »
Thanks! The Appimage worked :).
I downloaded it using this link. After downloading, I changed the file type from "app" to "appimage", then followed these directions.

eumagga0x2a

  • Moderator
  • Hero Member
  • *****
  • Posts: 3466
Re: Avidemux loads but immediately crashes (in Linux Mint)
« Reply #5 on: July 22, 2019, 03:55:36 PM »
Good. Please be aware that official appImage builds of Avidemux are missing some nice features like support for HW accelerated encoding and decoding on Intel GPU.

You can't change file type, you just make the appImage file executable (chmod +x /path/to/appImage/file or an equivalent using a file manager).

(You will get used to the Linux way to do things efficiently and fast some time later :) ).
« Last Edit: July 22, 2019, 03:58:52 PM by eumagga0x2a »