[solved] Garbled UI (18.04, 2.7.4 & nightly appimage from today)

Started by uatschitchun, February 07, 2020, 06:36:50 pm

Previous topic - Next topic

uatschitchun

Hi, I'm running latest avidemux on Kubuntu 18.04 and always get an output like this:


Only am able to see half or one third of the video!?

Here's the log when starting up:
https://pastebin.com/Mznc4Ncp

And this when opening a video:
https://pastebin.com/UNiFPTqG

Any idea someone?!

eumagga0x2a

Quote [init] 18:30:03-791  [VDPAU] API : 0x1, info : OpenGL/VAAPI backend for VDPAU


I wonder whether the redraw problem has to do with the fact that there is no native VDPAU backend on your system, just an emulation. Does switching to a different video output, e.g. to XVideo, help?

How does it come that your screenshot shows LibVA (if I read the blurry scaled-down label correctly) as video decoder? LibVA is not enabled in the official appImage AFAIR.

uatschitchun

This is the startup log of the installed version, just tested the appimage to see if the latest version fixes something:
https://pastebin.com/LUQNh0xR

This is vainfo & vdpauinfo:
https://pastebin.com/PUitJEbe

Comparison (grepping libva & vdpau)
https://pastebin.com/txNf9BAk

eumagga0x2a

I understand, the screenshot showed 2.7.4, not the Avidemux nightly build from the appImage.

As libva is available on your system both for decoding and display, you should use it for both when running an installed version (I would strongly recommend building from source). When using appImage, please try XVideo. Don't try to use the emulated VDPAU output. Does the problem persist nevertheless?

uatschitchun

Problem is, I can't get avidemux to just display the video correctly.

No matter what, it always only displays any video I open like in the screenshot (1/2-1/3) and garbles the UI when changimg it's size.

How would I set xvideo? Can't find a setting?!


eumagga0x2a

Quote from: uatschitchun on February 09, 2020, 09:29:41 am
Problem is, I can't get avidemux to just display the video correctly.

No matter what, it always only displays any video I open like in the screenshot (1/2-1/3) and garbles the UI when changimg it's size.


This is all related IMHO.

QuoteHow would I set xvideo? Can't find a setting?!


Edit --> Preferences --> Display --> Video display: [XVideo (best)]

(Bearbeiten --> Einstellungen --> Darstellung --> Video-Anzeige: [XVideo (bestens)])

uatschitchun

Ah, nice! Never seen this setting!

So setting it to libva, it results in a full picture of the video, but only 1/4th of the available screen (rest black)
and with Xvideo, it shows full ;)

This setting has nothing to do with GPU rendering method when re-encoding, does it?

eumagga0x2a

February 11, 2020, 05:02:25 pm #7 Last Edit: February 11, 2020, 05:08:20 pm by eumagga0x2a
This might be related to an incomplete support for HiDPI scaling in parts of the desktop environment. You could try launching Avidemux (avidemux3_qt5) from terminal like

QT_AUTO_SCREEN_SCALE_FACTOR=0 avidemux3_qt5

to disable automatic scaling in Qt.

Quote from: uatschitchun on February 11, 2020, 10:22:40 am
This setting has nothing to do with GPU rendering method when re-encoding, does it?


Do you mean the libva based HW accelerated video encoder? Honestly, I don't know by heart whether disabling libva video decoding disables the encoder too, but keeping HW accelerated video decoding enabled is a good thing anyway as long as it works, even with a different video output (it will result just in copying of a lot of data in memory). libva based video output is not required for the encoder.