AV1 decoder not working on v.2.7.6 ?

Started by fullhdfan, July 19, 2020, 11:52:24 PM

Previous topic - Next topic


I cannot open AV1 videos in the avidemux (tried on linux mint 64 flatpack and appimage). I get an error message(internal error finding codec 0x31307661 on appimage and video not loading properly on flatpack).


The environment used to generate official appImages lacks necessary components for AV1 support in Avidemux. One has to build Avidemux from source with libaom headers installed or use a Linux distribution which ships Avidemux with AV1 decoder enabled (Fedora with the RPM Fusion repository).


Do you intend to add VDPAU-based hardware accelerated deinterlacer in the next release ?


?? The plugin is present since ages, working, some things were refined in March. Maybe your graphics hardware doesn't support this feature, or you use not the native VDPAU with NVIDIA driver but a VDPAU wrapper for VA-API?


I mean as video filter, not for displaying the video to be encoded. i have never seen it in the avidemux's deinterlacing filters list on my PC, neither on windows, nor on linux. i think my linux uses VDPAU(see attachment)


Sorry it has nothing to do with windows


Quote from: fullhdfan on July 20, 2020, 01:27:48 PM
I mean as video filter, not for displaying the video to be encoded.

It is a video filter.

Quotei have never seen it in the avidemux's deinterlacing filters list on my PC, neither on windows, nor on linux.

It is not available on Windows as VDPAU is Linux-only. It is available on Linux if Avidemux has picked up the VDPAU header at build time.

Quotei think my linux uses VDPAU(see attachment)

Yes, thanks, it does. Your NVIDIA driver is ancient, however. I'm not sure whether it matters for the filter, but you miss out on support for hardware accelerated encoding which AFAIR requires 440.xx or later.


A screenshot of the configuration dialog.


In other words, please build Avidemux from git master and use the supplied convenience script:

bash createDebFromSourceUbuntu.bash --help

Without "--help" it just installs dependencies, builds Avidemux and installs generated Debian packages. Please note that you have to install nv-codec-headers ahead of building Avidemux manually as they are provided since very recently only for Ubuntu 20.04 and are not yet included into the convenience script*.

If the resulting Avidemux build lacks features, please compress and attach /tmp/log-bootstrap-*.log to your reply.

Avidemux Flatpack packages are third-party.

*) edit: Of course, without an up-to-date NVIDIA driver NVENC still won't work, nvidia-graphics-drivers-440 available from Ubuntu Bionic on (whatever Linux Mint version it corresponds to).


What's wrong here ? Did i reach the point where i made an executable file ?


If you want to run Avidemux (avidemux3_qt5) without installation (i.e. as a portable application), you need to use the wrapper template script (run_avidemux_template.sh) to set library search path to the real location where the libraries are.

Please use copy and paste to post error messages instead of making close-up photos of the display (unless your computer is purposely airgapped, of course).


QuoteDid i reach the point where i made an executable file ?

Sure, the build succeeded. Details regarding enabled and disabled features are not available as you haven't provided the bootstrap log.


When running run_avidemux_template.sh it says :

(Path)/../.../../adm_coreconfig.h not found. Can't determine the relative library directory. Aborting.

There is no bootstrap log file in the /tmp directory (i think you mean system directory).


# This is a script template to run Avidemux on Linux without installation.
# Adjust variables appropriately, copy it to a location included in $PATH
# and make it executable.

# TOPSRCDIR must match the location of the Avidemux source tree,
# default: ${HOME}/avidemux2

Did you check that the location of the source directory in the script (which is meant to be placed in your $PATH) is correct?

QuoteThere is no bootstrap log file in the /tmp directory

On most if not all systems, the content of /tmp is cleared on reboot, so if you have rebooted since then, the file is gone.


Judging from the photo of your screen, you need to edit


to become


Copy the script to a directory in your $PATH (many distributions append ~/bin to the $PATH via ~/.bash_profile, which is very practical for executables residing in the user's home directory), make it executable and optionally rename it, e.g. to "avidemux".


I changed the path in the avidemux template file as you said , but it still get the first  error message(from the picture).
I have also replaced {HOME} with /home/myname/... and still got the same. It seems that the problem is elsewhere, because if i write some nonsense to the path  i get the latest (admcoreconfig) error message.

Also changed the location of the template file to avidemux usr directory, but this doesn't work either.