June 21, 2021, 07:39:35 PM

News:

--


Problem mit Streaming-File

Started by Strunz, June 11, 2021, 09:57:08 AM

Previous topic - Next topic

Strunz

June 11, 2021, 09:57:08 AM Last Edit: June 11, 2021, 02:43:58 PM by Strunz
Hallo @eumagga0x2a,

normalerweise mach ich nichts mit Streaming, aber vielleicht wird sich das ja in Zukunft ändern...
Das Streaming-File ruckelt selbst in MPC-HC und VLC, im Browser lief es noch problemlos. 

Folgende Fehlermeldung kommt beim Laden dieses Files.


Da die Datei ursprünglich 11 GB groß ist, habe ich mit Avidemux einen kleinen Teil herausgeschnitten. Das Problem blieb bestehen. Es ist auch egal, wie man die Frage beantwortet, das Ergebnis ruckelt immer noch, ebenso wenn man MT disabled. 

Wenn ich es nun aber in StaxRip als Quelle mit FFVideoSource lade und es damit umwandle, dann ist das Ergebnis ruckelfrei.

Jetzt weiß ich viel zu wenig über Software usw., würde mir halt nur wünschen, dass auch Avidemux das umwandeln könnte. Ob das realistisch ist, keine Ahnung und es gibt ja wie gesagt Alternativen.

Würde Dir den Link zum File wieder per PM schicken, falls Du es dir noch angucken möchtest.

Edit: Und danke für die neuste nightly.

eumagga0x2a

Quote from: Strunz on June 11, 2021, 09:57:08 AMFolgende Fehlermeldung kommt beim Laden dieses Files.

Das ist keine Fehlermeldung sondern eine Frage (ein Angebot, das man nicht ablehnen sollte ;)).

Quote from: Strunz on June 11, 2021, 09:57:08 AMDa die Datei ursprünglich 11 GB groß ist, habe ich mit Avidemux einen kleinen Teil herausgeschnitten. Das Problem blieb bestehen.

Herausgeschnitten nachdem Avidemux versuchen durfte, die korrekte Bild-Reihenfolge wiederherzustellen? Oder einfach so?

Die Datei – was für ein Container ist das? MPEG-TS, Matroska, MP4 / MOV, AVI?

Strunz

Quote from: eumagga0x2a on June 11, 2021, 09:16:24 PMHerausgeschnitten nachdem Avidemux versuchen durfte, die korrekte Bild-Reihenfolge wiederherzustellen? Oder einfach so?
Habe wie gesagt beides probiert, brachte jeweils keinen Erfolg. Da aber auch Staxrip Probleme machte und erst "funktioniert" hat, als ich die Source(-Filter?) manuell umgestellt habe, ist die Lösung vermutlich alles andere als trivial? Container war im Original meine ich mp4, aber eh über ein AddOn im Firefox heruntergeladener Stream von einer Website. Wer weiß, was da alles passieren kann.

eumagga0x2a

Quote from: Strunz on June 12, 2021, 08:19:42 AMHabe wie gesagt beides probiert, brachte jeweils keinen Erfolg.

Dass das Ablehnen keinen Erfolg brachte, ist naheliegend. Bitte admlog.txt vom Laden der ursprünglichen Datei mit PTS-Rekonstruktion bereitstellen. Multithreading für diesen Fall bitte deaktivieren, dafür aber Dekodierung in HW gerne aktivieren.

Strunz

Quote from: eumagga0x2a on June 12, 2021, 06:23:15 PM
Quote from: Strunz on June 12, 2021, 08:19:42 AMHabe wie gesagt beides probiert, brachte jeweils keinen Erfolg.
Bitte admlog.txt vom Laden der ursprünglichen Datei mit PTS-Rekonstruktion bereitstellen.
Original ist nicht mehr vorhanden, der Auszug zeigt aber selbiges Verhalten.
Aber alles nicht weiter wild.

eumagga0x2a

Ich habe verspätet registriert, dass ich ein Sample bekommen hatte  :-[

Die Zeitstempel sind in der Tat kaputt, man müsste einen neuen Filter schreiben, der alle Zeitstempel invalidiert und alle Frames schlicht als CFR (hier mit 50 fps) interpretiert. Ohne so einen Filter exportiert man das ganze Video als eine Bildersequenz, um diese Bilder anschließend wieder in Avidemux zu importieren, mit der Tonspur unterlegen (hoffentlich bleibt sie synchron) und neu kodieren.

Strunz

Da hat wohl der Video Download Helper für FF die Probleme verursacht. Gar nicht so einfach, was geeignetes zum Speichern von Streams zu finden.

eumagga0x2a


Strunz

Quote from: eumagga0x2a on June 12, 2021, 07:54:12 PMVersagt youtube-dl?
Ehrlich gesagt brauche ich was mit gui, mit der Kommandozeile stehe ich auf Kriegsfuß. Es war außerdem ein Live-Stream, kein Video-Download, aber letztlich kann ich dazu nichts sagen.

eumagga0x2a

Habe zwar nur mit einer Auswahl von einer Minute Länge probiert, aber die Methode mit dem Exportieren als eine Sequenz von JPEGs und anschließendem Reimport in Avidemux produziert gute Ergebnisse, Bild und Ton bleiben synchron.

1. Das Sample in Avidemux laden, PTS wiederherstellen lassen.

2. Die Audiospur unter "Audio" --> "Audio speichern" in copy mode exportieren.

3. Unter "Datei" --> "Als Bild speichern" die Option "Auswahl als JPEG-Bilderserie" wählen (Achtung, Avidemux kann maximal 99999 Bilder auf einmal exportieren, bei 50 fps entspricht es ~33 Minuten).

4. Wenn Video länger als 33 Minuten ist (wovon ich ausgehe), zum nächsten Bild nach B wechseln, die Markierung B auf diesen Bild setzen (sonst bekommt man das letzte Bild der ursprünglichen Auswahl doppelt) und die Auswahl löschen (Entf), dann die neue Position für die Markierung B auf maximal 33 Minuten setzen, den Schritt 3 jeweils mit einem anderen Zielordner wiederholen bis das Ende des Videos erreicht ist. Speicherplatzbedarf: ~ 25 GiB pro Stunde Video, ganz grob veranschlagt.

5. Das Video schließen und die erste exportierte JPEG aus dem ersten Ordner öffnen (die restlichen werden automatisch geladen).

6. "Datei" --> "Anfügen" (Strg+A) und auf die erste JPEG-Datei aus dem zweiten Ordner zeigen. Diese Schritte für alle Ordner wiederholen.

7. Das Audio aus der exportierten .aac-Datei als eine externe Audiospur einbinden.

8. Den Filter "Bildfrequenz ändern" von "25 (PAL)" zu "50 (PAL)" aktivieren.

9. Das Video neu kodieren.

Strunz

Quote from: eumagga0x2a on June 12, 2021, 10:39:48 PMHabe zwar nur mit einer Auswahl von einer Minute Länge probiert, aber die Methode mit dem Exportieren als eine Sequenz von JPEGs und anschließendem Reimport in Avidemux produziert gute Ergebnisse, Bild und Ton bleiben synchron.

Danke Dir! Ich nutze lieber StaxRip. Man brauch halt für jeden Anwendungsfall das passende Werkzeug.