October 17, 2021, 04:02:03 PM

News:

--


Reaching last frame "bug"

Started by ivitek, August 29, 2021, 10:42:38 AM

Previous topic - Next topic

ivitek

Example:
I cut off the video end, let's say the last frame is now at 00:42:05.360.
When moving with arrows, the last frame I can reach and see is 00:42:05.320.
When I press key "E", I still see 00:42:05.320 only. Same with the slider.
The only way to diplay the last frame (00:42:05.360) is go to end mark (key "B").
Is this bug or a feature (if a feature, what is this good for)?
Version: avidemux_r210823_win64Qt5_70.zip

eumagga0x2a

Quote from: ivitek on August 29, 2021, 10:42:38 AMI cut off the video end, let's say the last frame is now at 00:42:05.360.

What is the duration of the video then? 00:42:05.400? Is it about the video being edited (i.e. cut means that the deleted section is only hidden) or the video was saved then the result loaded?

Quote from: ivitek on August 29, 2021, 10:42:38 AMWhen moving with arrows, the last frame I can reach and see is 00:42:05.320.
When I press key "E", I still see 00:42:05.320 only. Same with the slider.
The only way to diplay the last frame (00:42:05.360) is go to end mark (key "B").

This is definitely a bug, it should not matter whether you press "E" or go the the B marker at its default position equal video duration. If a frame PTS matches video duration exactly, it should not be reachable at all.

Please reproduce the issue and provide the generated %localappdata%\avidemux\admlog.txt.

ivitek

August 29, 2021, 11:46:56 AM #2 Last Edit: August 29, 2021, 12:10:35 PM by ivitek
I've placed the "A" mark to 00:42:05.360, pressed DEL
00:42:05.360 is now the duration, but to see this frame I have to press B
00:42:05.320 is the last frame accessible by E, arrows or slider
Tried multiple videos and filetypes - .ts, .mp4 - same problem

Another video - just opened, no cutting:
Duration: 00:56:40.266
Last accesible: 00:56:40.233
but now B and E point to the same frame and 00:56:40.266 cannot be accessed, as you wrote...

eumagga0x2a

I can reproduce, thanks. The bug is that the frame in the deleted range is still reachable (it has to be there to display the early B-frames preceding it in the display order, however).

ivitek

August 29, 2021, 12:57:01 PM #4 Last Edit: August 29, 2021, 01:06:49 PM by ivitek
Just for clarification - because we dealt with different problem but same topic here: https://avidemux.org/smif/index.php/topic,18277.msg83788.html#msg83788
And I'm afraid I missed the behavior has changed again (back to the old one).

I open the file, place the "A" mark, press DEL, cut off the whole rest of the file (f.e. advertisement)
The frame I placed "A" mark to, will be in the saved/recompressed file?

eumagga0x2a

Quote from: ivitek on August 29, 2021, 12:57:01 PMThe frame I placed "A" mark to, will be in the saved/recompressed file?

No, it will be discarded. This is the new old.

The divergent behaviour of "E" and "B" is effectively fixed now by [editor/segment] Exclude time matching segment duration from segment.