Avidemux 2.8.1 Qt6 220506-06h20m_2a70ea03b68 won't work on Catalina 10.15.7

Started by Philo, May 09, 2022, 08:31:35 AM

Previous topic - Next topic

Philo

I know this was posted as a Monterey build but sometimes your builds still work on earlier versions of MacOS, not this one though.  As soon as you click the icon it looks like it starts to open and then immediately closes again.  The older 2.8.1 from back in February does work in Catalina but it appears to have a couple bugs that have probably been fixed in the newer version (mostly crashes that only happen under certain conditions) so I'd like to be able to run the newer version, but any time I upgrade MacOS lately a lot of my other, older software stops working and also Apple seems to be on a tear about removing functionality from their own software (particularly Messages which gets worse with every new version of MacOS).  I don't know if there is a way to make to compatible with both Monterey and earlier versions but just thought I'd let you know (and before you suggest it, I have neither the ability nor the desire to attempt to build a version from source - I'm old and I use a Mac rather than Linux precisely so I don't have to do things like that!).

EDITED:  I wrote "Mohave" when I meant "Monterey".

eumagga0x2a

Quote from: Philo on May 09, 2022, 08:31:35 AMAs soon as you click the icon it looks like it starts to open and then immediately closes again.

Please launch it in the Terminal

/Applications/Avidemux_2.8.1.app/Contents/MacOS/Avidemux2.8
to reveal the exact error message.

However, unless the failure is due to Gatekeeper, there is little one could do as the official build environment was migrated to Monterey. It already qualifies as a miracle that a build for macOS can be provided at all.

I cannot help by offering a private build as my MBP runs Monterey too and Homebrew libs Avidemux bundles don't work on older systems. So there is nothing I can do, unfortunately.

Philo

$ /Applications/Avidemux_2.8.1.app/Contents/MacOS/Avidemux2.8
Sorry, "Avidemux2.8.app" cannot be run on this version of macOS. Qt requires macOS 12.0.0 or later, you have macOS 10.15.7.

eumagga0x2a

Thank you, some error messages on macOS are astoundingly polite. As feared, bundled Homebrew libraries such as the Qt framework prevent Avidemux from runnding on older macOS versions.