2.8.1 AppImage - Avidemux cannot set up encoder. The configuration supplied...

Started by postcd, October 07, 2022, 07:47:35 AM

Previous topic - Next topic


I have downloaded avidemux_2.8.1.appImage from https://www.fosshub.com/Avidemux.html yesterday to stable version of Linux Debian which is up to date, set it executable, launched and tried to convert a webm video to HEVC and then Mpeg4 but it always shows message in title.

Image - full error:

source video detail by ffplay:
Input #0, matroska,webm, from 'Session - Joining open group.webm': 
    ENCODER        : Lavf58.45.100
  Duration: 00:00:24.72, start: 0.000000, bitrate: 158 kb/s
    Stream #0:0: Video: vp9 (Profile 0), yuv420p(tv), 875x627, SAR 1:1 DAR 875:627, 25 fps, 25 tbr, 1k tbn, 1k tbc (default)
      ENCODER        : Lavc58.91.100 libvpx-vp9
      DURATION        : 00:00:24.720000000

I have ffmpeg installed, here listing packages.

Converting some other .avi video worked though. What to try please?


Quote from: postcd on October 07, 2022, 07:47:35 AM    Stream #0:0: Video: vp9 (Profile 0), yuv420p(tv), 875x627,

I am stunned to see that VP9 apparently supports odd sizes, but most of other codecs like H.264 and HEVC don't. For this reason the setup of x264 and x265 encoders fails. You should use the crop filter to make dimensions even.


Replying to a question posed via a PM, making dimensions even means making both width and height divisible by 2.

I'll think about adding a specific error message about odd width or height when encoding video with encoders which are incompatible with dimensions not being a multiple of 2.


Just to be clearer: the problem is not that width and height don't match usual resolutions. The problem is that none of values may be odd.