Main Menu

Howto install Avidemux 2.6 on OSX using Homebrew

Started by nibbles, November 05, 2011, 02:57:12 AM

Previous topic - Next topic


i've successful installed qt 4.8.2 and everything back to normal.
so there is a issue with qt 4.8.3 .
iMac 24\" Intel Core 2 Duo@2.4GHz - OSX 10.6.1



I am afraid, I am the most total noob concerning command lines... :( I am running X.6.8, managed to update the XCode to 3.2.6 (was it?), first managed to get MacPorts up (because at some stage, installing Avidemux via Macport was the thing), then somehow managed getting Homebrew sort of installed (which doesnt like MacPorts, as the brew doctor tells me)

The brew doctor gives me this:
bash-3.2$ brew doctor
Warning: Some directories in /usr/local/share/man aren't writable.
This can happen if you "sudo make install" software that isn't managed
by Homebrew. If a brew tries to add locale information to one of these
directories, then the install will fail during the link step.
You should probably `chown` them:

Warning: You have Macports or Fink installed.
This can cause trouble. You don't have to uninstall them, but you may li
try temporarily moving them away, eg.

  sudo mv /opt/local ~/macports
Warning: /usr/bin occurs before /usr/local/bin
This means that system-provided programs will be used instead of those
provided by Homebrew. The following tools exist at both paths:


Consider amending your PATH so that /usr/local/bin
occurs before /usr/bin in your PATH.

I tried to amend the path, (with the line given in this link: - but it didnt seem to have done anything, the brew doctor keeps on giving me his message about the path.

And when trying to brew avidemux, I get this:
Quotebash-3.2$ brew rm -f avidemux3
bash-3.2$ brew install avidemux3
Error: No available formula for avidemux3
though I did safe the script at the other end of your formula link in the right path, with exactly the filename.

As I said, I am no coder at all (even though I managed to slightly control my shell-panic) and at the moment I rather feel like: 'Woman, why don't you get back into the kitchen?!' - in other words, helpless...

All this, because 2.5.3 (which can do x264, which 2.5.4 can't) misinterprets the audio of a ts stream, I can't get it encoded right. Well, I think, it is sort of an incapability of the older versions, and did hope, that the newer (eg avidemux3) perhaps can do that, but I seem to be unable to try because I am a noob. I am so whishing, that you could find the time to release a binary... :(
I really like the things Avidemux can do, it's nifty and I dont think there is any other program out there that can do all that nice stuff as one single program (this is a praise, not a threat).


@yami your problems are relatively minor.  Fixing the things `brew doctor` complains about is fairly important, but the main thing affecting you is the name you are using.  There is avidemux, and avidemux3. Let me explain:

There is the avidemux-2.5.x branch (which doesn't do x264 very well) that you would build with
brew install --HEAD avidemux`
The 2.5.x formula comes built into Homebrew and is available without saving anything.

There is also the avidemux-2.6 branch that I have called avidemux3.  To build that, you have to save this special formula as

and build that with
brew install avidemux3

You may have to remove Macports first, though. You shouldn't need it, and it confuses things.
You should fix your permissions problems with this command:
sudo chown -R $USER:admin /usr/local

The PATH issue is not very important anymore, because Homebrew no longer uses whatever you PATH happens to be. It creates a special PATH just for the install.  If you'd like to fix that and silence the problem, then on OSX, the usual place to do that is in

where you would make it say something like mine:
export PATH=/usr/local/bin:/usr/local/sbin:/usr/local/share/python:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin

After you save that file, then you go back to your terminal window and click it to be sure it is active, then hit Command-t which will open up a new Terminal tab that will read your profile and set your new path.  You can see that by typing

Good luck (10.6.8 is okay, but I haven't tested this against XCode-3.2.6.  I paid $5 for XCode-4.0.2 when I ran 10.6.8).


Hi everybody,
after successfully compiled avidemux3 on mountain lion i 've got this error when i try to load my own preset for x264 :

[ADM_paramValidatePartialList]  Param : <analyze.fast_pskip> not found
[ADM_paramValidatePartialList]  Some parameters are not in the parameter list, typo ?(57 vs 58)

Any solution?

ps i've got error "Can't load Preset" with iPhone and PSP too.

Thank you.
iMac 24\" Intel Core 2 Duo@2.4GHz - OSX 10.6.1


What kind of crap is this? Who in their right mind is going to be able to build this crap? Can't someone just post a binary of the latest version of avidemux that works on 10.6 through 10.8??? I can't believe that the official build is ML only. This moron just fucked over 80% of mac users. Thanks idiots.

Jan Gruuthuse

Look in the mirror. You know immediately to whom this applies.


Oh no...

As I was going through the thread to find out how to install on 10.7.5, I started to hope that someone may be kind enough to release a "ready to install" package for 2.6.4 that could run on 10.7.5.

With such comments, I think this has much less chances to happen, as I don't see why anyone would bother if the rare requests are made this way.

Then I think I will try to go through the homebrew steps as it seems the most straightforward option available.

Just a couple of questions:
- when looking inside the formula, (I think) it refers to version 2.6.0, but will it install the 2.6.4?
- Just in case (u never know) anyone is working on making an installable package of the 2.6.4 version work on osx 10.7.5, could you give me a heads-up before I get started? This would be much appreciated!
- Finally, assuming I can install it from homebrew, is it portable? Meaning could I kind of zip it into a package that could be shared with other people in the same situation? (I guess not otherwise there would not need for homebrew right? Please bear with my newbie questions).

Thank you.

Jan Gruuthuse

may be that still works for 2.6.4, I can't confirm it would.


Hi Thanks for the formula.

I tried it and am on OSX 10.7.5.

I ran into a problem:
==> cmake -DCMAKE_INSTALL_PREFIX=/usr/local/Cellar/avidemux3/2.6.0 -DCMAKE_BUILD_TYPE=None -DCMAKE_FIND_FRAMEWORK=LAST -Wno-dev -DCMAKE_PREFIX_PATH=/usr/local/Cellar/gettext/0.18.2
==> make
ld: framework not found QtGui
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make[2]: *** [ADM_UIsQt4/src/libADM_UIQT46.dylib] Error 1
make[1]: *** [ADM_UIsQt4/src/CMakeFiles/ADM_UIQT46.dir/all] Error 2
make: *** [all] Error 2

The brew doctor says I do not have the Xcode command line tools for Xcode, not sure if this is necessary for the formula.

Also, I checked the /usr/local/Cellar/ folder and there is no avidemux3 folder, so I think the install did not work.

Any thoughts on what I can do?

Your help is appreciated.


If you build it using, you 'll end up with a dmg in the source folder
That dmg can be reused on another mac


Update: it finally worked! 8)

So, after some research, it seems that the problem is due to a linker looking for libraries in the wrong place, and that can be solved by creating links, please see the below link because it is not like if I am comfortably understanding what I write:

However, looking further just to make sure, I found that installing the Xcode command line tools solves the problem for some people, link below.

So I tried it and guess what, it worked.
Actually all I had to do is listen to what the brew doctor was saying - nothing to brag about then :-[

@negativeions: well then me apparently ;)

@mean: I do not understand what you mean (pun unintended) but I will make some research after some time. I installed 2.6.0, and I will try to upgrade to latest version first. Happy to help but unfortunately I cannot commit I will get it done. It may help Yami.

@nibbles: thanks for the formula, hope you see it, as you did not post for half a year.

@Jan Gruuthuse: Thanks for the guidance again.



It worked like a charm with the --HEAD option.

I have 2.6.4 running!

Mean, I am happy to help, I had a quick look on internet about bootstrap osx, but I did not find things I understood.
It would be nice if I can create:
- a package dmg
- including an icon in applications/launcher
- and maybe with a way of hiding the terminal that opens when I launch avidemux3.

I feel this becomes a separated topic than building with homebrew, please feel free to pm me or we can create a separate thread?



go to the avidemux source folder and run
Assuming everything is where it is expected to be, it will compile everything and build
a dmg

Jan Gruuthuse

there is only: bootStrapOsx.bash in source from svn.