Author Topic: large videos fail to append while rendering  (Read 324 times)

ahmad

  • Newbie
  • *
  • Posts: 11
large videos fail to append while rendering
« on: March 15, 2017, 07:25:12 PM »
I'm trying to append two large videos (about 1.5 GB each) on avidemux 2.6.18 64bit (windows 7)
the videos have a resolution of 3840x2160 so I tried to compress those videos and resize them:
*video output : average bitrate (two pass) using AVC(X264) with the resize filter applied (reducing the resolution to 720x1280)
*audio output set to copy
*muxer: mp4

the first pass went successfully but the second pass failed at the appendage point displaying a failure message
I've tried to append small clips of the same videos (using edit options) and it went successful, I've also tried to append those videos without compression (video output set to copy) and no problems happend

what should the problem be?  :-\
« Last Edit: March 15, 2017, 07:31:25 PM by ahmad »

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1244
Re: large videos fail to append while rendering
« Reply #1 on: March 15, 2017, 07:42:12 PM »
Do you get the same highly classified error if you encode the video resulting from appending and saving in copy mode?
Please attach admlog.txt (compress it if necessary) from an Avidemux run resulting in this failure. You'll find the log file in the Avidemux data directory (%appdata%\avidemux), accessible also from the "Help" menu.

ahmad

  • Newbie
  • *
  • Posts: 11
Re: large videos fail to append while rendering
« Reply #2 on: March 15, 2017, 10:13:46 PM »
no it doesn't happen in copy mode
here is the log file

ahmad

  • Newbie
  • *
  • Posts: 11
Re: large videos fail to append while rendering
« Reply #3 on: March 17, 2017, 09:14:06 AM »
and this is the error message

eumagga0x2a

  • Hero Member
  • *****
  • Posts: 1244
Re: large videos fail to append while rendering
« Reply #4 on: March 17, 2017, 10:28:19 AM »
Thanks, the nature of the problem is outlined here:

Code: [Select]
[adm_lavLogCallback] 22:05:22-581 [lavc] Application provided invalid, non monotonically increasing dts to muxer in stream 0: 11524000 >= 11524000
(two video frames have exactly the same decoding timestamp) which results in the MP4 muxer, which actually just uses the bundled ffmpeg to perform the task, bailing out:

Code: [Select]
[FF]Error writing video packet
You should probably try another muxer (preferably MKV).

ahmad

  • Newbie
  • *
  • Posts: 11
Re: large videos fail to append while rendering
« Reply #5 on: March 17, 2017, 12:46:57 PM »
why did it happen?
is it a problem in the video itself, or a problem in ffmpeg, or both?

Jan Gruuthuse

  • Hero Member
  • *****
  • Posts: 5428
Re: large videos fail to append while rendering
« Reply #6 on: March 17, 2017, 03:56:41 PM »
Quote
(two video frames have exactly the same decoding timestamp)
The source of your video (recorded) stream: transmission / recording error.

ahmad

  • Newbie
  • *
  • Posts: 11
Re: large videos fail to append while rendering
« Reply #7 on: March 17, 2017, 05:17:40 PM »
I encoded every video on it's own then I appended them together and it worked!
thank you very much  ;D