April 15, 2021, 02:11:39 PM



Cannot setup codec. Bitrate too low?

Started by thany, September 03, 2013, 04:04:15 PM

Previous topic - Next topic


June 16, 2014, 12:20:59 PM #15 Last Edit: June 16, 2014, 12:28:37 PM by thany
I stumbled upon another video that somehow has this problem. I found something. Well, I may have.

When I change the video encoder setting from "Average Bitrate (Two Pass)" to "Constant Bitrate (Single Pass)" with all the same settings otherwise, I get this when trying to start the encode:

"Too short
The video has been saved but seems to be incomplete."

After that it has saved roughly 4KB of data, while the original video is definately more than that. It looks like it's literally only saved a matroska header.

When I choose the video codec "HuffYUV" and container AVI, and then start the encode (leaves everything else alone), the process is almost instantly finished, after having saved just 32KB of data. Again, probably just a header. It looks to me like it cannot find a single frame to work with, even though the video is loading fine and is navigable like any other - so from that perspective I see no reason why it wouldn't find the first frame... But who knows.

When I choose "Copy" for the video codec, it does work. Well sort of, it's not doing any kind of video recoding of course, but it does happily copy the video track over to the destination file.


I am also getting this error under Windows 10 with Avidemux 2.6.12 . In this case it only happens when I select the H264 output.

How do I find the option to set the IDC level or the Average Bitrate setting?

Jan Gruuthuse

March 21, 2016, 06:37:29 PM #17 Last Edit: March 21, 2016, 07:13:39 PM by Jan Gruuthuse
Video Output
set [Copy] to [Mpeg4 AVC (x264)]
[Configure] <- click
IDC Level [Auto] <- click and select wanted

Rate Control
Encoding Mode: change [Constant Rate Factor (Single Pass) to [Average bitrate (Two Pass)]

notice when doing so Target Bitrate will change to Average Bitrate


I had problem with error "Bitrate too low". After a lot of time and many attempts I added filter "swsResize" with checked option "Round to nearest multiple of 16" and voila. It works.


August 11, 2019, 12:18:42 PM #19 Last Edit: August 11, 2019, 10:40:55 PM by awdrifter
I have tried all the suggestions in this thread, I still get the same error. I don't have a ~ in the username, I have set the IDC level to 3.1,I have set the swsResize to Round to the nearest 16, and I have tried to set the Encoding Mode to 2 pass.

So I guess another data point for whoever wants to take a whack at solving it (or maybe just remove the BitRate limit, let us encode even if you think the result will end up looking bad).

Edit: I could not post new post, it says I'm spammer. But I updated to the latest version, it works. Thanks.


The suggestion in the error message doesn't mean that the reason for setup() of the particular encoder to return false has anything to do with  bitrate. If you have tried with the latest nightly build of Avidemux 2.7.4 and the problem persists, please compress (zip or 7z) and attach admlog.txt from %localappdata%\avidemux\ originating from the failed re-encoding attempt.

64 bits Windows executables built with VC++ from git master on Windows
64 bits Windows executables and ZIP packages built with MinGW from git master on Linux
32 bits Windows executables built from the legacy-compat branch with MinGW on Linux
DMGs for macOS Mojave 64 bits (should work with Sierra too) built from git master
64 bits appImages for Linux built from git master


I had this problem with on old video file. The simplest solution is to read it with VLC and stream it to a new file after letting vlc reformat it.  VLC is very robust program an seems to be able to fixall ofthe issues relating to aged video formats.