Avidemux Forum

Avidemux => Windows => Topic started by: pstein on August 25, 2018, 10:40:08 AM

Title: Audio problem when appending two *.mp4 files solved meanhile?
Post by: pstein on August 25, 2018, 10:40:08 AM
I read in the past that there is a problem in Avidemux (approx v2.4.5) when appending two *.mp4 files.

The audio track was not correctly continued resp. cut.

Is this problem solved meanwhile?

Peter
Title: Re: Audio problem when appending two *.mp4 files solved meanhile?
Post by: Jan Gruuthuse on August 25, 2018, 10:49:35 AM
Most likely yes.
2.5.4 is from November 2010, nearly 8 years ago ...
Title: Re: Audio problem when appending two *.mp4 files solved meanhile?
Post by: fhpro on August 25, 2018, 11:06:06 AM
In addition to the Audio problems, there have been lately servral issues which seems to have crept up while trying to post .ts file to Avedimux for conversion. I am attaching a screen shot of the error message.

Could some one please help?
Title: Re: Audio problem when appending two *.mp4 files solved meanhile?
Post by: eumagga0x2a on August 25, 2018, 12:00:59 PM
I read in the past that there is a problem in Avidemux (approx v2.4.5) when appending two *.mp4 files.

The audio track was not correctly continued resp. cut.

Is this problem solved meanwhile?

No idea about anything pre-2.6, but the requirement that the number of audio tracks, codecs including codec parameters used and channel layouts must exactly match persists.

Especially if the appended video starts not at zero, which is always the case when the video codec uses B-frames, a brief gap in audio is unavoidable.

There have been a fix for audio delay computation in the mp4 demuxer recently, you may want to test with the latest nightly.

@fhpro, please try the latest nightly. The error you see indicates that the particular video is corrupted. Current nightlies should not crash when they encounter such a condition, they just refuse to decode the video at this point.
Title: Re: Audio problem when appending two *.mp4 files solved meanhile?
Post by: fhpro on August 25, 2018, 12:16:13 PM
@eumagga0x2a - Thank you for your response. Could you please the link from where I could download?
Title: Re: Audio problem when appending two *.mp4 files solved meanhile?
Post by: eumagga0x2a on August 25, 2018, 12:48:08 PM
https://avidemux.org/nightly/

Pick the most recent one matching your platform (there have been no official macOS builds after 2018-07-02, unfortunately).
Title: Re: Audio problem when appending two *.mp4 files solved meanhile?
Post by: fhpro on August 25, 2018, 03:17:14 PM
@eumagga0x2a - No worries mate. You are a star. Thanks a ton :-)
Title: Re: Audio problem when appending two *.mp4 files solved meanhile?
Post by: fhpro on August 25, 2018, 03:26:19 PM
@eumagga0x2a - I owe you one for this in case this does work mate. While we are on this subject, are you aware of any similar video converting software such as Avidemux with the same converting speed. I use Avidemux for soccer highlights and TIME is the most important factor in being a hit or a flop. Any advice on this subject since it clearly sounds you have the expertise is greatly appreciated. Thank you once gain mate :-)